Release Tizen2.0 beta
[framework/location/gps-manager.git] / packaging / gps-manager.spec
1 Name:       gps-manager
2 Summary:    GPS Manager for Tizen
3 Version:    0.2.1
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO_BE/FILLED_IN
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(glib-2.0)
9 BuildRequires:  pkgconfig(dbus-glib-1)
10 BuildRequires:  pkgconfig(geoclue)
11 BuildRequires:  pkgconfig(network)
12 BuildRequires:  pkgconfig(tapi)
13 BuildRequires:  pkgconfig(vconf)
14 BuildRequires:  pkgconfig(heynoti)
15 BuildRequires:  pkgconfig(sysman)
16 BuildRequires:  pkgconfig(msg-service)
17 BuildRequires:  pkgconfig(dlog)
18 BuildRequires:  pkgconfig(pmapi)
19 BuildRequires:  pkgconfig(location)
20
21 %description
22 GPS Manager for Tizen
23
24 %package -n location-gps-manager
25 Summary:    GPS Manager for Tizen
26 Group:      Development/Libraries
27 Requires:   %{name} = %{version}-%{release}
28
29 %description -n location-gps-manager
30 GPS Manager for Tizen
31
32
33 %package -n gps-manager-plugin-devel
34 Summary:    GPS Manager for Tizen (development files)
35 Group:      Development/Libraries
36 Requires:   %{name} = %{version}-%{release}
37
38 %description -n gps-manager-plugin-devel
39 GPS Manager for Tizen (development files)
40
41
42 %prep
43 %setup -q
44
45 %ifarch %{arm}
46 %define GPS_ENABLER --enable-gps
47 %define ARCH armel
48 %else
49 %define GPS_ENABLER --enable-gps
50 %define ARCH x86
51 %endif
52
53 ./autogen.sh
54 ./configure --prefix=%{_prefix} %{GPS_ENABLER}
55
56
57 %build
58 make %{?jobs:-j%jobs}
59
60 %install
61 rm -rf %{buildroot}
62 %make_install
63
64
65 %clean
66 rm -rf %{buildroot}
67
68
69 %post
70 #GPS Indicator value
71 vconftool set -t int memory/location/position/state 0 -i
72 vconftool set -t int memory/location/gps/state 0 -i
73 vconftool set -t int memory/location/wps/state 0 -i
74
75 #GPS_SETTING
76 vconftool set -t int db/location/gps/Operation "1" -f
77 vconftool set -t int db/location/gps/Starting "0" -f
78 vconftool set -t int db/location/gps/Session "1" -f
79
80 #SUPL_SETTING
81 vconftool set -t string db/location/supl/Server "bcmls2.glpals.com" -f
82 vconftool set -t int db/location/supl/Port "7275" -f
83 vconftool set -t int db/location/supl/SslEnabled "0" -f
84
85 #NMEA_SETTING
86 vconftool set -t int db/location/nmea/LoggingEnabled "0" -f
87
88 #REPLAY_SETTING
89 vconftool set -t string db/location/replay/FileName "nmea_replay.log" -f
90 %ifarch %arm
91         vconftool set -t int db/location/replay/ReplayEnabled "0" -f
92         vconftool set -t int db/location/replay/ReplayMode "1" -f
93 %else
94         vconftool set -t int db/location/replay/ReplayEnabled "1" -f
95         vconftool set -t int db/location/replay/ReplayMode "0" -f
96 %endif
97 vconftool set -t double db/location/replay/ManualLatitude "0.0" -f
98 vconftool set -t double db/location/replay/ManualLongitude "0.0" -f
99 vconftool set -t double db/location/replay/ManualAltitude "0.0" -f
100
101 %post -n location-gps-manager
102 %ifnarch %arm
103         cp -f /usr/lib/location/module/libgps.so /usr/lib/location/module/libwps0.so
104 %endif
105
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(-,root,root,-)
110 /usr/libexec/gps-manager
111 /usr/share/dbus-1/services/org.freedesktop.Geoclue.Providers.GpsManager.service
112 /usr/share/geoclue-providers/gps-manager.provider
113 /usr/etc/dbus-1/system.d/Geoclue.conf
114 /etc/rc.d/init.d/gps-manager
115 /etc/rc.d/rc3.d/S90gps-manager
116 /etc/rc.d/rc5.d/S90gps-manager
117
118 %files -n location-gps-manager
119 %defattr(-,root,root,-)
120 %{_libdir}/location/module/libgps.so*
121
122 %files -n gps-manager-plugin-devel
123 %defattr(-,root,root,-)
124 %{_libdir}/pkgconfig/gps-manager-plugin.pc
125 %{_includedir}/gps-manager-plugin/*.h
126