upload tizen1.0 source
[framework/location/gps-manager.git] / packaging / gps-manager.spec
1 Name:       gps-manager
2 Summary:    GPS Manager for Tizen 
3 Version:    0.1.6
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO_BE/FILLED_IN
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(glib-2.0)
10 BuildRequires:  pkgconfig(dbus-glib-1)
11 BuildRequires:  pkgconfig(geoclue)
12 BuildRequires:  pkgconfig(network)
13 BuildRequires:  pkgconfig(tapi)
14 BuildRequires:  pkgconfig(vconf)
15 BuildRequires:  pkgconfig(heynoti)
16 BuildRequires:  pkgconfig(sysman)
17 BuildRequires:  pkgconfig(msg-service)
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(pmapi)
20 BuildRequires:  pkgconfig(location)
21
22 %description
23 GPS Manager for Tizen
24
25 %package -n location-gps-manager
26 Summary:    GPS Manager for Tizen 
27 Group:      Development/Libraries
28 Requires:   %{name} = %{version}-%{release}
29
30 %description -n location-gps-manager
31 libslp-location module for gps-manager
32
33
34 %package -n gps-manager-plugin-devel
35 Summary:    GPS Manager for Tizen (development files)
36 Group:      Development/Libraries
37 Requires:   %{name} = %{version}-%{release}
38
39 %description -n gps-manager-plugin-devel
40 GPS Manager for Tizen (development files)
41
42
43 %prep
44 %setup -q 
45
46 %ifarch %{arm}
47 %define GPS_ENABLER --enable-gps
48 %define ARCH armel
49 %else
50 %define GPS_ENABLER --enable-gps
51 %define ARCH x86
52 %endif
53
54 ./autogen.sh
55 CFLAGS="$CFLAGS" CXXFLAGS="$CXXFLAGS" LDFLAGS="$LDFLAGS" ./configure --prefix=%{_prefix} %{GPS_ENABLER}
56
57
58 %build
59 make %{?jobs:-j%jobs}
60
61 %install
62 rm -rf %{buildroot}
63 %make_install
64
65
66 %clean
67 rm -rf %{buildroot}
68
69
70 %post
71 #GPS Indicator value
72 vconftool set -t int memory/gps/state 0 -i
73 vconftool set -t int memory/wps/state 0 -i
74
75 #GPS_SETTING
76 vconftool set -t int db/location/gps/Operation "1" -f
77 vconftool set -t int db/location/gps/Starting "0" -f
78 vconftool set -t int db/location/gps/Session "1" -f
79
80 #SUPL_SETTING
81 vconftool set -t string db/location/supl/Server "your.supl-server.com" -f
82 vconftool set -t int db/location/supl/Port "7275" -f
83 vconftool set -t int db/location/supl/SslEnabled "1" -f
84
85 #NMEA_SETTING
86 vconftool set -t int db/location/nmea/LoggingEnabled "0" -f
87
88 #REPLAY_SETTING
89 vconftool set -t string db/location/replay/FileName "nmea_replay.log" -f
90 %ifarch %arm
91         vconftool set -t int db/location/replay/ReplayEnabled "0" -f
92         vconftool set -t int db/location/replay/ReplayMode "1" -f
93 %else
94         vconftool set -t int db/location/replay/ReplayEnabled "1" -f
95         vconftool set -t int db/location/replay/ReplayMode "0" -f
96 %endif
97 vconftool set -t double db/location/replay/ManualLatitude "0.0" -f
98 vconftool set -t double db/location/replay/ManualLongitude "0.0" -f
99 vconftool set -t double db/location/replay/ManualAltitude "0.0" -f
100
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(-,root,root,-)
105 /usr/libexec/gps-manager
106 /usr/share/dbus-1/services/org.freedesktop.Geoclue.Providers.GpsManager.service
107 /usr/share/geoclue-providers/gps-manager.provider
108 /usr/etc/dbus-1/system.d/Geoclue.conf
109 /etc/rc.d/init.d/gps-manager
110 /etc/rc.d/rc3.d/S90gps-manager
111 /etc/rc.d/rc5.d/S90gps-manager
112
113 %files -n location-gps-manager
114 %defattr(-,root,root,-)
115 %{_libdir}/location/module/libgps.so*
116
117 %files -n gps-manager-plugin-devel
118 %defattr(-,root,root,-)
119 %{_libdir}/pkgconfig/gps-manager-plugin.pc
120 %{_includedir}/gps-manager-plugin/*.h
121