resetting manifest requested domain to floor
[platform/upstream/gperf.git] / packaging / gperf.spec
1 Name:           gperf
2 Version:        3.0.4
3 Release:        1
4 License:        GPL-2.0+
5 Summary:        A perfect hash function generator
6 Url:            http://www.gnu.org/software/gperf/
7 Group:          Development/Tools
8 Source0:        ftp://ftp.gnu.org/pub/gnu/%{name}/%{name}-%{version}.tar.gz
9 Source1001:     gperf.manifest
10 BuildRequires:  gcc-c++
11
12 %description
13 GNU gperf is a perfect hash function generator. For a given list of strings, it
14 produces a hash function and hash table, in form of C or C++ code, for looking
15 up a value depending on the input string. The hash function is perfect, which
16 means that the hash table has no collisions, and the hash table lookup needs
17 a single string comparison only.
18
19 %prep
20 %setup -q
21 cp %{SOURCE1001} .
22
23
24 %build
25
26 %configure --disable-static
27 make %{?_smp_mflags}
28
29 %install
30 %make_install
31
32 rm -f %{buildroot}%{_datadir}/doc/gperf.html
33
34
35
36
37
38
39 %files
40 %manifest %{name}.manifest
41 %license COPYING
42 %defattr(-,root,root,-)
43 %doc NEWS README doc/gperf.html
44 %doc %{_mandir}/man1/gperf.1*
45 %doc %{_infodir}/gperf.info*
46 %{_bindir}/%{name}
47
48