Add gobject-introspection.changes file
[profile/ivi/gobject-introspection.git] / packaging / gobject-introspection.spec
1 Name:           gobject-introspection
2 Version:        1.32.1
3 Release:        1%{?dist}
4 Summary:        Introspection system for GObject-based libraries
5 Group:          Development/Libraries
6 License:        GPLv2+, LGPLv2+, MIT
7 URL:            http://live.gnome.org/GObjectIntrospection
8 Source0:        %{name}-%{version}.tar.xz
9 Obsoletes:      gir-repository
10 BuildRequires:  python-lxml
11 BuildRequires:  python-xml
12 BuildRequires:  glib2-devel
13 BuildRequires:  python-devel >= 2.5
14 BuildRequires:  gettext
15 BuildRequires:  flex
16 BuildRequires:  bison
17 BuildRequires:  libffi-devel
18 BuildRequires:  mesa-libGL-devel
19 BuildRequires:  cairo-gobject-devel
20 BuildRequires:  libxml2-devel
21 BuildRequires:  libXfixes-devel
22 BuildRequires:  libX11-devel
23 BuildRequires:  fontconfig-devel
24 BuildRequires:  libXft-devel
25 BuildRequires:  freetype-devel
26 # Bootstrap requirements
27 BuildRequires:  gnome-common
28 BuildRequires:  intltool
29 #BuildRequires:  gtk-doc
30
31 %description
32 GObject Introspection can scan C header and source files in order to
33 generate introspection "typelib" files.  It also provides an API to examine
34 typelib files, useful for creating language bindings among other
35 things.
36
37 %package devel
38 Summary: Libraries and headers for gobject-introspection
39 Group: Development/Libraries
40 Requires: %name = %{version}-%{release}
41 Requires: glib2-devel
42 Requires: pkgconfig
43 # Not always, but whatever, it's a tiny dep to pull in
44 Requires: libtool
45 Obsoletes: gir-repository-devel
46
47 %description devel
48 Libraries and headers for gobject-introspection
49
50 %prep
51 %setup -q
52
53 %build
54 (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
55  %configure $CONFIGFLAGS)
56 make V=1 %{?_smp_mflags}
57
58 %install
59 make install DESTDIR=$RPM_BUILD_ROOT
60
61 # Die libtool, die.
62 find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
63 find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
64
65 %post -p /sbin/ldconfig
66
67 %postun -p /sbin/ldconfig
68
69 %files
70 %doc COPYING
71
72 %{_libdir}/lib*.so.*
73 %dir %{_libdir}/girepository-1.0
74 %{_libdir}/girepository-1.0/*.typelib
75
76 %files devel
77 %{_libdir}/lib*.so
78 %dir %{_libdir}/gobject-introspection
79 %{_libdir}/gobject-introspection/*
80 %{_libdir}/pkgconfig/*
81 %{_includedir}/*
82 %{_bindir}/g-ir-*
83 %{_datadir}/gir-1.0
84 %dir %{_datadir}/gobject-introspection-1.0
85 %{_datadir}/gobject-introspection-1.0/*
86 %{_datadir}/aclocal/introspection.m4
87 %{_mandir}/man1/*.gz
88 %dir %{_datadir}/gtk-doc/html/gi
89 %{_datadir}/gtk-doc/html/gi/*