Conditionalise ARM asm on !__thumb__.
[platform/upstream/gmp.git] / packaging / gmp.spec
1 %define keepstatic 1
2 Name:           gmp
3 Version:        6.0.0
4 Release:        0
5 License:        GPL-2.0 and LGPL-3.0+
6 Summary:        The GNU MP Library
7 Url:            http://gmplib.org/
8 Group:          Base/Libraries
9 Source:         %{name}-%{version}.tar.bz2
10 Source2:        baselibs.conf
11 Source1001:     gmp.manifest
12 BuildRequires:  gcc-c++
13 BuildRequires:  pkg-config
14
15 %description
16 A library for calculating huge numbers (integer and floating point).
17
18 %package -n libgmp
19 Summary:        Shared library for the GNU MP Library
20 Group:          Base/Libraries
21
22 %description -n libgmp
23 Shared library for the GNU MP Library.
24
25 %package -n libgmpxx
26 Summary:        C++ bindings for the GNU MP Library
27 Group:          Base/Libraries
28 Requires:       libgmp = %{version}
29
30 %description -n libgmpxx
31 C++ bindings for the GNU MP Library.
32
33 %package devel
34 Summary:        Include Files and Libraries for Development with the GNU MP Library
35 Group:          Base/Development
36 Requires:       libgmp = %{version}
37 Requires:       libgmpxx = %{version}
38
39 %description devel
40 These libraries are needed to develop programs which calculate with
41 huge numbers (integer and floating point).
42
43 %prep
44 %setup -q
45 cp %{SOURCE1001} .
46
47 %build
48 export CFLAGS="%{optflags} -fexceptions";
49 %reconfigure \
50          --enable-cxx
51 make %{?_smp_mflags}
52
53 %check
54 # do not disable "make check", FIX THE BUGS!
55 make check
56
57 %install
58 %make_install
59
60 %post -n libgmp -p /sbin/ldconfig
61
62 %post -n libgmpxx -p /sbin/ldconfig
63
64 %postun -n libgmp -p /sbin/ldconfig
65
66 %postun -n libgmpxx -p /sbin/ldconfig
67
68 %files
69 %manifest %{name}.manifest
70 %license COPYINGv2
71 %doc AUTHORS README NEWS
72
73 %files -n libgmp
74 %manifest %{name}.manifest
75 %defattr(-,root,root)
76 %{_libdir}/libgmp.so.10*
77
78 %files -n libgmpxx
79 %manifest %{name}.manifest
80 %defattr(-,root,root)
81 %{_libdir}/libgmpxx.so.4*
82
83 %files devel
84 %manifest %{name}.manifest
85 %defattr(-,root,root)
86 %doc AUTHORS README NEWS
87 %doc %{_infodir}/gmp.info*.gz
88 %{_libdir}/libgmp.a
89 %{_libdir}/libgmpxx.a
90 %{_libdir}/libgmp.so
91 %{_libdir}/libgmpxx.so
92 %{_libdir}/pkgconfig/gmp.pc
93 /usr/include/gmp.h
94 /usr/include/gmpxx.h