2 # spec file for package glibc
4 # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
16 %define glibc_run_tests 1
19 # This will avoid building some parts of glibc
20 %define asan_arch x86_64 armv7l aarch64
21 %bcond_with fast_build
23 Summary: Standard Shared Libraries (from the GNU C Library)
24 License: LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
27 BuildRequires: makeinfo
29 BuildRequires: gcc-c++
30 BuildRequires: gettext-tools
31 BuildRequires: libstdc++-devel
33 BuildRequires: python3-base
36 #BuildRequires: python
37 BuildRequires: glibc-devel-static
40 #BuildRequires: pkgconfig(systemd)
41 %define _filter_GLIBC_PRIVATE 1
42 %if %_target_cpu == "i686"
43 # For i686 let's only build what's different from i586, so
44 # no need to build documentation
45 %define build_profile 1
46 %define build_locales 0
49 %if %{with fast_build}
50 %define build_profile 0
51 %define build_locales 0
55 %define build_profile 1
56 %define build_locales 0
61 %define disable_assert 0
62 %define enable_stackguard_randomization 1
63 %define multiarcharches %{ix86} x86_64
66 %define enablekernel 2.6.16
68 %define enablekernel 2.6.16
70 Conflicts: kernel < %{enablekernel}
71 %ifarch armv7l armv7hl
72 # The old runtime linker link gets not provided by rpm find.provides, but it exists
73 Provides: ld-linux.so.3
74 Provides: ld-linux.so.3(GLIBC_2.4)
78 %define glibc_major_version %{version}
79 %define git_id 0a8262a1b2
81 Url: http://www.gnu.org/software/libc/libc.html
82 Source: glibc-%{version}.tar.xz
83 Source5: nsswitch.conf
84 Source7: bindresvport.blacklist
85 Source8: glibc_post_upgrade.c
86 Source9: glibc.rpmlintrc
87 Source10: baselibs.conf
89 Source1001: glibc.manifest
91 Requires(pre): filesystem
92 Provides: rtld(GNU_HASH)
95 The GNU C Library provides the most important standard libraries used
96 by nearly all programs: the standard C library, the standard math
97 library, and the POSIX thread library. A system is not functional
98 without these libraries.
101 Summary: Info Files for the GNU C Library
107 This package contains the documentation for the GNU C library stored as
108 info files. Due to a lack of resources, this documentation is not
109 complete and is partially out of date.
112 Summary: HTML Documentation for the GNU C Library
118 This package contains the HTML documentation for the GNU C library. Due
119 to a lack of resources, this documentation is not complete and is
120 partially out of date.
123 Summary: Database Sources for 'locale'
124 License: GPL-2.0+ and MIT
125 Group: Base/Libraries
128 %description i18ndata
129 This package contains the data needed to build the locale data files to
130 use the internationalization features of the GNU libc. It is normally
131 not necessary to install this packages, the data files are already
135 Summary: Locale Data for Localized Programs
136 License: GPL-2.0+ and MIT and LGPL-2.1+
137 Requires(post): /usr/bin/cat
138 Requires: glibc = %{version}
140 Locale data for the internationalisation features of the GNU C library.
143 Summary: Libc Profiling and Debugging Versions
144 License: LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
145 Group: Base/Utilities
146 Requires: glibc = %{version}
149 This package contains special versions of the GNU C library which are
150 necessary for profiling and debugging.
153 Summary: Include Files and Libraries Mandatory for Development
154 License: BSD-3-Clause and LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
155 Requires: glibc = %{version}
156 Requires: linux-kernel-headers
159 These libraries are needed to develop programs which use the standard C
162 %package devel-static
163 Summary: C library static libraries for -static linking
164 License: BSD-3-Clause and LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
165 Requires: %{name}-devel = %{version}
166 # Provide Fedora name for package to make packaging easier
167 Provides: %{name}-static = %version
169 %description devel-static
170 The glibc-devel-static package contains the C library static libraries
171 for -static linking. You don't need these, unless you link statically,
172 which is highly discouraged.
175 Summary: Development utilities from GNU C library
177 Requires: glibc = %{version}
179 %description devel-utils
180 The glibc-devel-utils package contains various binaries which can be helpful during program
183 If you are unsure if you need this, don't install this package.
186 Summary: Extra binaries from GNU C Library
188 Requires: glibc = %{version}
191 The glibc-extra package contains some extra binaries for glibc that
192 are not essential but recommend to use.
194 makedb: A program to create a database for nss
197 Summary: Obsolete Shared Libraries from the GNU C Library
199 Requires: glibc = %{version}
201 %description obsolete
202 This package provides some old libraries from the GNU C Library which
203 are no longer supported. Additional it provides a compatibility library
204 for old binaries linked against glibc 2.0.
206 Install this package if you need one of this libraries to get old
207 binaries working, but since this libraries are not supported and there
208 is no gurantee that they work for you, you should try to get newer
209 versions of your software.
212 Summary: Testsuite results
214 Group: Development/Languages
215 %description testresults
216 Results from running the glibc testsuites.
221 Summary: glibc with ASan instrumentation
222 License: LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
223 Requires: glibc = %{version}
226 This package provides glibc with ASan instrumentation
229 ln -s --force /%{_lib}/libc-2.24-asan.so /%{_lib}/libc.so.6
232 ln -s --force /%{_lib}/libc-2.24.so /%{_lib}/libc.so.6
238 %setup -n glibc-%{version} -q
242 %{?asan:%gcc_unforce_options}
243 if [ -x /bin/uname.bin ]; then
251 # We do not want configure to figure out the system its building one
252 # to support a common ground and thus set build and host to the
255 %define target %{_target_cpu}-tizen-linux-gnueabi
257 %define target %{_target_cpu}-tizen-linux
259 # Don't use as-needed, it breaks glibc assumptions
260 # Before enabling it, run the testsuite and verify that it
262 export LD_AS_NEEDED=0
263 # Adjust glibc version.h
264 echo "#define CONFHOST \"%{target}\"" >> version.h
265 echo "#define GITID \"%{git_id}\"" >> version.h
267 # Default CFLAGS and Compiler
269 BuildFlags=$(echo %{optflags} | sed -e "s/-Wp,-D_FORTIFY_SOURCE=2//g" | sed -e "s/-ffast-math//" | sed -e "s/atom/i686/g" | sed -e "s/-fexceptions//" | sed -e "s/-fno-omit-frame-pointer//" )
270 BuildFlags="$BuildFlags -O2 -g -U_FORTIFY_SOURCE"
271 BuildFlags="$(echo $BuildFlags | sed -e 's#-fstack-protector##' -e 's#-ffortify=[0-9]*##')"
272 BuildFlags="$(echo $BuildFlags | sed -e 's/-Wa,-mimplicit-it=thumb//g' | sed -e 's/-mthumb//g')"
273 # Turn off all -Wformat enable flags as there are glibc tests that explicitly
274 # append -Wno-format and with enabled Wformat options that produced warnings
275 # that turns into errors. Remove -Wformat=1|2 or -Wformat-..-arg
276 BuildFlags="$(echo $BuildFlags | sed -re 's/-Wformat((=[1-2])|((-\w+)+))?(\s|$)//g')"
282 BuildFlags="$BuildFlags -g"
285 # Glibc must have both functions' implementations
286 BuildFlags="$BuildFlags -U_LARGEFILE_SOURCE -U_LARGEFILE64_SOURCE -U_FILE_OFFSET_BITS"
288 %if %{disable_assert}
289 BuildFlags="$BuildFlags -DNDEBUG=1"
298 # fails to build otherwise - need to recheck and fix
299 %define enable_stackguard_randomization 0
302 configure_and_build_glibc() {
303 local dirname="$1"; shift
304 local cflags="$1"; shift
305 local addons="$1"; shift
308 conf_cflags="$cflags -funwind-tables -fPIC"
309 %{?asan: conf_cflags="$conf_cflags -DASAN_INIT_FIRST "}
311 profile="--disable-profile"
313 if [ "$dirname" = "base" ] ; then
314 profile="--enable-profile"
317 CFLAGS="$conf_cflags" BUILD_CFLAGS="$conf_cflags" \
318 CC="$BuildCC" CXX="$BuildCCplus" ../configure \
319 --prefix=%{_prefix} \
320 --libexecdir=%{_libexecdir} --infodir=%{_infodir} \
321 --enable-add-ons=$addons \
324 %if %{enable_stackguard_randomization}
325 --enable-stackguard-randomization \
327 --build=%{target} --host=%{target} \
328 %ifnarch %{multiarcharches}
329 --disable-multi-arch \
331 %ifarch %{ix86} x86_64
334 --enable-kernel=%{enablekernel} \
335 --enable-bind-now --enable-obsolete-rpc \
337 --disable-experimental-malloc \
338 libc_cv_pie_default=yes
339 # explicitly set CFLAGS to use the full CFLAGS (not the reduced one for configure)
340 make %{?_smp_mflags} #CFLAGS="$cflags" BUILD_CFLAGS="$cflags"
344 configure_flags="--prefix=/usr --without-cvs --without-selinux --enable-stackguard-randomization --enable-obsolete-rpc --disable-mathvec"
346 configure_flags="$configure_flags --disable-sanity-checks"
349 HERE=%{_builddir}/%{name}-%{version}
352 ASAN_BUILD=$HERE/asan-build
356 #chmod +x $HERE/asan-glibc-gcc-wrapper.py
357 #build static wrapper, because we don't want asan to intercept allocators
358 g++ -o gcc-wrapper gcc-wrapper.cc -O3 -funroll-loops -fno-unwind-tables -fno-asynchronous-unwind-tables -fno-exceptions -static
363 # CC=$HERE/asan-glibc-gcc-wrapper.py $GLIBC/configure $configure_flags
364 CC=$HERE/gcc-wrapper $GLIBC/configure $configure_flags
366 # Quick build - builds only libraries, but does not create symlinks.
367 make -r -j $J -C $GLIBC objdir=`pwd` subdir_lib
368 #make -r -j $J -C $GLIBC objdir=`pwd` install_root=$ASAN_INST install-lib
375 configure_and_build_glibc base "$BuildFlags" "$add_ons"
383 # Build html documentation
390 # Build glibc_post_upgrade binary
392 $BuildCC -static %{optflags} -Os $RPM_SOURCE_DIR/glibc_post_upgrade.c -o glibc_post_upgrade \
393 -Lcc-base -Bcc-base/csu \
394 '-DREMOVE_TLS_DIRS' '-DREMOVE_PPC_OPTIMIZE_POWER5' \
395 '-DLIBDIR="/%{_lib}"' '-DGCONV_MODULES_DIR="%{_libdir}/gconv"'
400 # #check sections could be redefined/disabled, so keep this inside #build
403 export LD_AS_NEEDED=0
404 (make %{?_smp_mflags} -C cc-base check || true) 2>&1 | tee check.log
408 #######################################################################
412 #######################################################################
415 # The testsuite will fail if asneeded is used
416 export LD_AS_NEEDED=0
417 # This has to pass on all platforms!
420 make %{?_smp_mflags} -C cc-base check-abi
422 #######################################################################
426 #######################################################################
429 # We don't want to strip the .symtab from our libraries in find-debuginfo.sh,
430 # certainly not from libpthread.so.* because it is used by libthread_db to find
431 # some non-exported symbols in order to detect if threading support
432 # should be enabled. These symbols are _not_ exported, and we can't easily
433 # export them retroactively without changing the ABI. So we have to
434 # continue to "export" them via .symtab, instead of .dynsym :-(
435 # But we also want to keep .symtab and .strtab of other libraries since some
436 # debugging tools currently require these sections directly inside the main
437 # files - specifically valgrind and PurifyPlus.
438 export STRIP_KEEP_SYMTAB=*.so*
440 # Make sure we will create the gconv-modules.cache
441 mkdir -p %{buildroot}%{_libdir}/gconv
442 touch %{buildroot}%{_libdir}/gconv/gconv-modules.cache
445 make %{?_smp_mflags} install_root=%{buildroot} install -C cc-base
447 install_optimized_variant() {
448 local dirname="$1"; shift
449 local subdir="$1"; shift
450 local subdir_up="$1"; shift
453 destdir=$RPM_BUILD_ROOT/%{_lib}/$subdir
455 # Don't run a complete make install, we know which libraries
457 for lib in libc math/libm nptl/libpthread rt/librt nptl_db/libthread_db
460 libbaseso=$(basename $RPM_BUILD_ROOT/%{_lib}/${libbase}-*.so)
461 # Only install if different from base lib
462 if cmp -s ${lib}.so ../cc-base/${lib}.so; then
463 ln -sf $subdir_up/$libbaseso $destdir/$libbaseso
465 cp -a ${lib}.so $destdir/$libbaseso
468 ln -sf $libbaseso $destdir/$(basename $RPM_BUILD_ROOT/%{_lib}/${libbase}.so.*)
476 # XXX Do not install locales in parallel!
478 # localedef creates hardlinks to other locales if possible
479 # this will not work if we generate them in parallel.
480 # thus we need to run fdupes on /usr/lib/locale/
481 # Still, on my system this is a speed advantage:
482 # non-parallel build for install-locales: 9:34mins
483 # parallel build with fdupes: 7:08mins
484 make %{?_smp_mflags} install_root=%{buildroot} localedata/install-locales
485 %fdupes %{buildroot}/usr/lib/locale
488 # Create file list for glibc-locale package
491 # Prepare obsolete/, used only on some architectures:
492 export RPM_BUILD_ROOT
494 mkdir -p %{buildroot}/%{_lib}/obsolete
497 # NPTL <bits/stdio-lock.h> is not usable outside of glibc, so include
498 # the generic one (RH#162634)
499 # cp -av bits/stdio-lock.h %{buildroot}%{_includedir}/bits/stdio-lock.h
504 install -m 0700 glibc_post_upgrade %{buildroot}%{_sbindir}
506 install -m 644 %{SOURCE7} %{buildroot}/etc
507 install -m 644 %{SOURCE5} %{buildroot}/etc
508 install -m 644 posix/gai.conf %{buildroot}/etc
510 mkdir -p %{buildroot}/etc/default
511 install -m 644 nis/nss %{buildroot}/etc/default/
513 mkdir -p %{buildroot}%{_includedir}/resolv
514 install -m 0644 resolv/mapv4v6addr.h %{buildroot}%{_includedir}/resolv/
515 install -m 0644 resolv/mapv4v6hostent.h %{buildroot}%{_includedir}/resolv/
518 mkdir -p %{buildroot}%{_datadir}/doc/glibc
519 cp -p cc-base/manual/libc/*.html %{buildroot}%{_datadir}/doc/glibc
526 cat > %{buildroot}/etc/ld.so.conf <<EOF
527 %if "%{_lib}" == "lib64"
531 include /etc/ld.so.conf.d/*.conf
532 # /lib64, /lib, /usr/lib64 and /usr/lib gets added
533 # automatically by ldconfig after parsing this file.
534 # So, they do not need to be listed.
536 # Add ldconfig cache directory for directory ownership
537 mkdir -p %{buildroot}/var/cache/ldconfig
538 # Empty the ld.so.cache:
539 rm -f %{buildroot}/etc/ld.so.cache
540 touch %{buildroot}/etc/ld.so.cache
542 # Don't look at ldd! We don't wish a /bin/sh requires
543 chmod 644 %{buildroot}%{_bindir}/ldd
545 # Remove timezone data, now coming in standalone package:
546 for i in sbin/sln usr/bin/tzselect usr/sbin/zic usr/sbin/zdump etc/localtime; do
547 rm -f %{buildroot}/$i
549 rm -rf %{buildroot}%{_datadir}/zoneinfo
552 # Provide compatibility link
553 ln -s ld-%{glibc_major_version}.so %{buildroot}/lib/ld-linux.so.3
556 # Move getconf to %{_libexecdir}/getconf/ to avoid cross device link
557 mv %{buildroot}%{_bindir}/getconf %{buildroot}%{_libexecdir}/getconf/getconf
558 ln -s %{_libexecdir}/getconf/getconf %{buildroot}%{_bindir}/getconf
560 #######################################################################
564 #######################################################################
568 HERE=%{_builddir}/%{name}-%{version}
570 ASAN_BUILD=$HERE/asan-build
571 cp $ASAN_BUILD/libc.so %{buildroot}/%{_lib}/libc-2.24-asan.so
577 cp --parents $(find cc-base -name "*tests.sum") testresults/
578 cp check.log testresults/
579 chmod 644 $(find testresults/ -type f)
582 %post -p %{_sbindir}/glibc_post_upgrade
584 %postun -p /sbin/ldconfig
587 for l in /usr/share/locale/locale.alias %{_libdir}/gconv/gconv-modules; do
588 [ -d "$l.d" ] || continue
589 echo "###X# The following is autogenerated from extra files in the .d directory:" >>"$l"
592 /usr/sbin/iconvconfig
595 %install_info --info-dir=%{_infodir} %{_infodir}/libc.info.gz
598 %install_info_delete --info-dir=%{_infodir} %{_infodir}/libc.info.gz
601 %manifest %{name}.manifest
603 %defattr(-,root,root)
604 %license LICENSES COPYING COPYING.LIB
605 %config(noreplace) /etc/bindresvport.blacklist
606 %config /etc/ld.so.conf
607 %attr(0644,root,root) %verify(not md5 size mtime) %ghost %config(missingok,noreplace) /etc/ld.so.cache
608 %config(noreplace) /etc/rpc
609 %verify(not md5 size mtime) %config(noreplace) /etc/nsswitch.conf
610 %verify(not md5 size mtime) %config(noreplace) /etc/gai.conf
611 %config(noreplace) /etc/default/nss
612 /%{_lib}/ld-%{glibc_major_version}.so
614 # Each architecture has a different name for the dynamic linker:
617 /%{_lib}/ld-linux-armhf.so.3
618 # Keep compatibility link
619 /%{_lib}/ld-linux.so.3
621 /%{_lib}/ld-linux.so.3
625 /%{_lib}/ld-linux-x86-64.so.2
628 /%{_lib}/ld-linux.so.2
631 /lib/ld-linux-aarch64.so.1
632 /%{_lib}/ld-linux-aarch64.so.1
635 /%{_lib}/libanl-%{glibc_major_version}.so
637 /%{_lib}/libc-%{glibc_major_version}.so
639 /%{_lib}/libcrypt-%{glibc_major_version}.so
640 /%{_lib}/libcrypt.so.1
641 /%{_lib}/libdl-%{glibc_major_version}.so
643 /%{_lib}/libm-%{glibc_major_version}.so
645 /%{_lib}/libnsl-%{glibc_major_version}.so
647 /%{_lib}/libnss_compat-%{glibc_major_version}.so
648 /%{_lib}/libnss_compat.so.2
649 /%{_lib}/libnss_db-%{glibc_major_version}.so
650 /%{_lib}/libnss_db.so.2
651 /%{_lib}/libnss_dns-%{glibc_major_version}.so
652 /%{_lib}/libnss_dns.so.2
653 /%{_lib}/libnss_files-%{glibc_major_version}.so
654 /%{_lib}/libnss_files.so.2
655 /%{_lib}/libnss_optfiles-%{glibc_major_version}.so
656 /%{_lib}/libnss_optfiles.so.2
657 /%{_lib}/libnss_hesiod-%{glibc_major_version}.so
658 /%{_lib}/libnss_hesiod.so.2
659 /%{_lib}/libpthread-%{glibc_major_version}.so
660 /%{_lib}/libpthread.so.0
661 /%{_lib}/libthread_db-1.0.so
662 /%{_lib}/libthread_db.so.1
663 /%{_lib}/libresolv-%{glibc_major_version}.so
664 /%{_lib}/libresolv.so.2
665 /%{_lib}/librt-%{glibc_major_version}.so
667 /%{_lib}/libutil-%{glibc_major_version}.so
668 /%{_lib}/libutil.so.1
669 %define optimized_libs() \
670 %dir %attr(0755,root,root) /%{_lib}/%1\
671 /%{_lib}/%1/libc-%{glibc_major_version}.so\
672 /%{_lib}/%1/libc.so.6*\
673 /%{_lib}/%1/libm-%{glibc_major_version}.so\
674 /%{_lib}/%1/libm.so.6*\
675 /%{_lib}/%1/libpthread-%{glibc_major_version}.so\
676 /%{_lib}/%1/libpthread.so.0\
677 /%{_lib}/%1/librt-%{glibc_major_version}.so\
678 /%{_lib}/%1/librt.so.1\
679 /%{_lib}/%1/libthread_db-1.0.so\
680 /%{_lib}/%1/libthread_db.so.1
682 %dir %attr(0700,root,root) /var/cache/ldconfig
688 %attr(755,root,root) %{_bindir}/ldd
689 %ifarch %ix86 sparc sparcv9
694 %dir %attr(0755,root,root) %{_libexecdir}/getconf
695 %{_libexecdir}/getconf/*
696 %{_sbindir}/glibc_post_upgrade
697 %{_sbindir}/iconvconfig
698 /%{_lib}/libBrokenLocale-%{glibc_major_version}.so
699 /%{_lib}/libBrokenLocale.so.1
704 %manifest %{name}.manifest
706 %defattr (755,root,root,755)
707 %dir /%{_lib}/obsolete/
708 #%dir /%{_lib}/obsolete/noversion
709 #/%{_lib}/obsolete/noversion/libNoVersion-%{glibc_major_version}.so
710 #/%{_lib}/obsolete/noversion/libNoVersion.so.1
713 %files locale -f libc.lang
714 %manifest %{name}.manifest
715 %license COPYING COPYING.LIB
716 %defattr(-,root,root)
717 %{_datadir}/locale/locale.alias
726 %manifest %{name}.manifest
727 /%{_lib}/libc-2.24-asan.so
732 %manifest %{name}.manifest
733 %defattr(-,root,root)
734 %license COPYING COPYING.LIB
740 # These static libraries are needed even for shared builds
741 %{_libdir}/libc_nonshared.a
743 %ifarch ppc ppc64 s390 s390x sparc sparcv8 sparcv9 sparcv9v
744 # This is not built on sparc64.
745 %{_libdir}/libnldbl_nonshared.a
747 %{_libdir}/libmcheck.a
748 %{_libdir}/librpcsvc.a
751 %manifest %{name}.manifest
752 %defattr(-,root,root)
753 %{_libdir}/libBrokenLocale.a
756 %{_libdir}/libcrypt.a
759 %{_libdir}/libpthread.a
760 %{_libdir}/libresolv.a
765 %manifest %{name}.manifest
766 %defattr(-,root,root)
767 %doc %{_infodir}/libc.info.gz
768 %doc %{_infodir}/libc.info-?.gz
769 %doc %{_infodir}/libc.info-??.gz
773 %manifest %{name}.manifest
774 %defattr(-,root,root)
775 %doc %{_prefix}/share/doc/glibc
779 %manifest %{name}.manifest
780 %defattr(-,root,root)
781 %{_prefix}/share/i18n
785 %manifest %{name}.manifest
786 %license COPYING COPYING.LIB
787 %defattr(-,root,root)
789 %{_libdir}/libBrokenLocale_p.a
790 %{_libdir}/libanl_p.a
792 %{_libdir}/libcrypt_p.a
793 %{_libdir}/libpthread_p.a
794 %{_libdir}/libresolv_p.a
796 %{_libdir}/librpcsvc_p.a
797 %{_libdir}/libutil_p.a
802 %manifest %{name}.manifest
803 %defattr(-,root,root)
804 /%{_lib}/libmemusage.so
805 /%{_lib}/libpcprofile.so
806 /%{_libdir}/libBrokenLocale.so
807 /%{_lib}/libSegFault.so
808 /%{_lib}/libthread_db-1.0.so
809 /%{_lib}/libthread_db.so.1
810 /%{_libdir}/libthread_db.so
811 %dir /%{_libdir}/audit
812 /%{_libdir}/audit/sotruss-lib.so
813 # These need gd-devel for building
814 # %%{_bindir}/memusage
815 # %%{_bindir}/memusagestat
817 %{_bindir}/pcprofiledump
825 %manifest %{name}.manifest
827 %defattr(-,root,root)
833 %defattr(-,root,root)
834 %doc testresults/check.log