packaging: Turning on PIE compilation by default
[platform/upstream/glibc.git] / packaging / glibc.spec
1 #
2 # spec file for package glibc
3 #
4 # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14
15 %if 0%{?run_tests}
16 %define glibc_run_tests 1
17 %endif
18
19 # This will avoid building some parts of glibc
20 %define asan_arch x86_64 armv7l aarch64
21 %bcond_with    fast_build
22 Name:           glibc
23 Summary:        Standard Shared Libraries (from the GNU C Library)
24 License:        LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
25 Group:          Base/Libraries
26 BuildRequires:  fdupes
27 BuildRequires:  makeinfo
28 BuildRequires:  xz
29 BuildRequires:  gcc-c++
30 BuildRequires:  gettext-tools
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  bison
33 BuildRequires:  python3-base
34 %{?asan:
35 %ifarch %asan_arch
36 #BuildRequires:  python
37 BuildRequires:  glibc-devel-static
38 %endif
39 }
40 #BuildRequires:  pkgconfig(systemd)
41 %define _filter_GLIBC_PRIVATE 1
42 %if %_target_cpu == "i686"
43 # For i686 let's only build what's different from i586, so
44 # no need to build documentation
45 %define build_profile 1
46 %define build_locales 0
47 %define build_html 0
48 %else
49 %if %{with fast_build}
50 %define build_profile 0
51 %define build_locales 0
52 %define build_html 0
53 %else
54 # Default:
55 %define build_profile 1
56 %define build_locales 0
57 %define build_html 1
58 %endif
59 %endif
60
61 %define disable_assert 0
62 %define enable_stackguard_randomization 1
63 %define multiarcharches %{ix86} x86_64
64
65 %ifarch x86_64
66 %define enablekernel 2.6.16
67 %else
68 %define enablekernel 2.6.16
69 %endif
70 Conflicts:      kernel < %{enablekernel}
71 %ifarch armv7l armv7hl
72 # The old runtime linker link gets not provided by rpm find.provides, but it exists
73 Provides:       ld-linux.so.3
74 Provides:       ld-linux.so.3(GLIBC_2.4)
75 %endif
76 Version:        2.30
77 Release:        0
78 %define glibc_major_version %{version}
79 %define git_id 0a8262a1b2
80
81 Url:            http://www.gnu.org/software/libc/libc.html
82 Source:         glibc-%{version}.tar.xz
83 Source5:        nsswitch.conf
84 Source7:        bindresvport.blacklist
85 Source8:        glibc_post_upgrade.c
86 Source9:        glibc.rpmlintrc
87 Source10:       baselibs.conf
88 # For systemd 
89 Source1001:     glibc.manifest
90
91 Requires(pre):  filesystem
92 Provides:       rtld(GNU_HASH)
93
94 %description
95 The GNU C Library provides the most important standard libraries used
96 by nearly all programs: the standard C library, the standard math
97 library, and the POSIX thread library. A system is not functional
98 without these libraries.
99
100 %package info
101 Summary:        Info Files for the GNU C Library
102 License:        GFDL-1.1
103 Group:          Documentation
104 BuildArch:      noarch
105
106 %description info
107 This package contains the documentation for the GNU C library stored as
108 info files. Due to a lack of resources, this documentation is not
109 complete and is partially out of date.
110
111 %package html
112 Summary:        HTML Documentation for the GNU C Library
113 License:        GFDL-1.1
114 Group:          Documentation
115 BuildArch:      noarch
116
117 %description html
118 This package contains the HTML documentation for the GNU C library. Due
119 to a lack of resources, this documentation is not complete and is
120 partially out of date.
121
122 %package i18ndata
123 Summary:        Database Sources for 'locale'
124 License:        GPL-2.0+ and MIT
125 Group:          Base/Libraries
126 BuildArch:      noarch
127
128 %description i18ndata
129 This package contains the data needed to build the locale data files to
130 use the internationalization features of the GNU libc. It is normally
131 not necessary to install this packages, the data files are already
132 created.
133
134 %package locale
135 Summary:        Locale Data for Localized Programs
136 License:        GPL-2.0+ and MIT and LGPL-2.1+
137 Requires(post): /usr/bin/cat
138 Requires:       glibc = %{version}
139 %description locale
140 Locale data for the internationalisation features of the GNU C library.
141
142 %package profile
143 Summary:        Libc Profiling and Debugging Versions
144 License:        LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
145 Group:          Base/Utilities
146 Requires:       glibc = %{version}
147
148 %description profile
149 This package contains special versions of the GNU C library which are
150 necessary for profiling and debugging.
151
152 %package devel
153 Summary:        Include Files and Libraries Mandatory for Development
154 License:        BSD-3-Clause and LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
155 Requires:       glibc = %{version}
156 Requires:       linux-kernel-headers
157
158 %description devel
159 These libraries are needed to develop programs which use the standard C
160 library.
161
162 %package devel-static
163 Summary:        C library static libraries for -static linking
164 License:        BSD-3-Clause and LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
165 Requires:       %{name}-devel = %{version}
166 # Provide Fedora name for package to make packaging easier
167 Provides:       %{name}-static = %version
168
169 %description devel-static
170 The glibc-devel-static package contains the C library static libraries
171 for -static linking.  You don't need these, unless you link statically,
172 which is highly discouraged.
173
174 %package devel-utils
175 Summary:        Development utilities from GNU C library
176 License:        LGPL-2.1+
177 Requires:       glibc = %{version}
178
179 %description devel-utils
180 The glibc-devel-utils package contains various binaries which can be helpful during program
181 debugging.
182
183 If you are unsure if you need this, don't install this package.
184
185 %package extra
186 Summary:        Extra binaries from GNU C Library
187 License:        LGPL-2.1+
188 Requires:       glibc = %{version}
189
190 %description extra
191 The glibc-extra package contains some extra binaries for glibc that
192 are not essential but recommend to use.
193
194 makedb: A program to create a database for nss
195
196 %package obsolete
197 Summary:        Obsolete Shared Libraries from the GNU C Library
198 License:        LGPL-2.0+
199 Requires:       glibc = %{version}
200
201 %description obsolete
202 This package provides some old libraries from the GNU C Library which
203 are no longer supported. Additional it provides a compatibility library
204 for old binaries linked against glibc 2.0.
205
206 Install this package if you need one of this libraries to get old
207 binaries working, but since this libraries are not supported and there
208 is no gurantee that they work for you, you should try to get newer
209 versions of your software.
210
211 %package testresults
212 Summary:       Testsuite results
213 License:       LGPL-2.1+
214 Group:         Development/Languages
215 %description testresults
216 Results from running the glibc testsuites.
217
218 %{?asan:
219 %ifarch %asan_arch
220 %package asan
221 Summary:     glibc with ASan instrumentation
222 License:     LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
223 Requires:    glibc = %{version}
224
225 %description asan
226 This package provides glibc with ASan instrumentation
227
228 %post asan
229 ln -s --force /%{_lib}/libc-2.24-asan.so /%{_lib}/libc.so.6
230
231 %preun asan
232 ln -s --force /%{_lib}/libc-2.24.so /%{_lib}/libc.so.6
233
234 %endif
235 }
236
237 %prep
238 %setup -n glibc-%{version} -q 
239 cp %{SOURCE1001} .
240
241 %build
242 %{?asan:%gcc_unforce_options}
243 if [ -x /bin/uname.bin ]; then
244         /bin/uname.bin -a
245 else
246         uname -a
247 fi
248 uptime || :
249 ulimit -a
250 nice
251 # We do not want configure to figure out the system its building one
252 # to support a common ground and thus set build and host to the
253 # target_cpu.
254 %ifarch %arm
255 %define target %{_target_cpu}-tizen-linux-gnueabi
256 %else
257 %define target %{_target_cpu}-tizen-linux
258 %endif
259 # Don't use as-needed, it breaks glibc assumptions
260 # Before enabling it, run the testsuite and verify that it
261 # passes completely
262 export LD_AS_NEEDED=0
263 # Adjust glibc version.h
264 echo "#define CONFHOST \"%{target}\"" >> version.h
265 echo "#define GITID \"%{git_id}\"" >> version.h
266 #
267 # Default CFLAGS and Compiler
268 #
269 BuildFlags=$(echo %{optflags} | sed -e "s/-Wp,-D_FORTIFY_SOURCE=2//g" | sed -e "s/-ffast-math//" | sed -e "s/atom/i686/g" | sed -e "s/-fexceptions//" | sed -e "s/-fno-omit-frame-pointer//" )
270 BuildFlags="$BuildFlags -O2 -g -U_FORTIFY_SOURCE"
271 BuildFlags="$(echo $BuildFlags | sed -e 's#-fstack-protector##' -e 's#-ffortify=[0-9]*##')"
272 BuildFlags="$(echo $BuildFlags | sed -e 's/-Wa,-mimplicit-it=thumb//g' | sed -e 's/-mthumb//g')"
273 # Turn off all -Wformat enable flags as there are glibc tests that explicitly
274 # append -Wno-format and with enabled Wformat options that produced warnings
275 # that turns into errors. Remove -Wformat=1|2 or -Wformat-..-arg
276 BuildFlags="$(echo $BuildFlags | sed -re 's/-Wformat((=[1-2])|((-\w+)+))?(\s|$)//g')"
277
278 BuildCC="%__cc"
279 BuildCCplus="%__cxx"
280 add_ons=",libidn"
281
282 BuildFlags="$BuildFlags -g"
283
284 %ifarch %arm
285 # Glibc must have both functions' implementations
286 BuildFlags="$BuildFlags -U_LARGEFILE_SOURCE -U_LARGEFILE64_SOURCE -U_FILE_OFFSET_BITS"
287 %endif
288 %if %{disable_assert}
289         BuildFlags="$BuildFlags -DNDEBUG=1"
290 %endif
291 %ifarch %ix86
292         BuildFlags="$(echo $BuildFlags | sed -e 's/-g2//g' | sed -e 's/-g//g')"
293         add_ons=$add_ons
294 %endif
295 %ifarch %arm aarch64
296         add_ons=$add_ons
297 %endif
298 %ifarch mipsel
299         # fails to build otherwise - need to recheck and fix
300         %define enable_stackguard_randomization 0
301 %endif
302
303 configure_and_build_glibc() {
304         local dirname="$1"; shift
305         local cflags="$1"; shift
306         local addons="$1"; shift
307         mkdir "cc-$dirname"
308         cd "cc-$dirname"
309         conf_cflags="$cflags -funwind-tables -fPIC"
310         %{?asan: conf_cflags="$conf_cflags -DASAN_INIT_FIRST "}
311
312         profile="--disable-profile"
313 %if %{build_profile}
314         if [ "$dirname" = "base" ] ; then
315             profile="--enable-profile"
316         fi
317 %endif
318         CFLAGS="$conf_cflags" BUILD_CFLAGS="$conf_cflags" \
319         CC="$BuildCC" CXX="$BuildCCplus"  ../configure \
320                 --prefix=%{_prefix} \
321                 --libexecdir=%{_libexecdir} --infodir=%{_infodir} \
322                 --enable-add-ons=$addons \
323                 $profile \
324                 "$@" \
325 %if %{enable_stackguard_randomization}
326                 --enable-stackguard-randomization \
327 %endif
328                 --build=%{target} --host=%{target} \
329 %ifnarch %{multiarcharches}
330                 --disable-multi-arch \
331 %endif
332 %ifarch %{ix86} x86_64 
333                 --disable-mathvec \
334 %endif
335                 --enable-kernel=%{enablekernel} \
336                 --enable-bind-now  --enable-obsolete-rpc \
337                 --disable-nscd \
338                 --disable-experimental-malloc \
339                 libc_cv_cc_pie_default=yes
340         # explicitly set CFLAGS to use the full CFLAGS (not the reduced one for configure)
341         make %{?_smp_mflags} #CFLAGS="$cflags" BUILD_CFLAGS="$cflags"
342         cd ..
343 }
344
345 configure_flags="--prefix=/usr --without-cvs --without-selinux --enable-stackguard-randomization --enable-obsolete-rpc --disable-mathvec"
346
347 configure_flags="$configure_flags --disable-sanity-checks"
348
349 build_asan() {
350   HERE=%{_builddir}/%{name}-%{version}
351   J=${J:-32}
352   GLIBC=$HERE
353   ASAN_BUILD=$HERE/asan-build
354   unset CXXFLAGS
355   unset CFLAGS
356   unset LDFLAGS
357   #chmod +x $HERE/asan-glibc-gcc-wrapper.py
358   #build static wrapper, because we don't want asan to intercept allocators
359   g++ -o gcc-wrapper gcc-wrapper.cc -O3 -funroll-loops -fno-unwind-tables -fno-asynchronous-unwind-tables -fno-exceptions -static
360
361   rm -rf $ASAN_BUILD
362   mkdir -p $ASAN_BUILD
363   cd $ASAN_BUILD
364 #  CC=$HERE/asan-glibc-gcc-wrapper.py $GLIBC/configure $configure_flags
365   CC=$HERE/gcc-wrapper $GLIBC/configure $configure_flags
366
367   # Quick build - builds only libraries, but does not create symlinks.
368   make -r -j $J -C $GLIBC objdir=`pwd` subdir_lib
369   #make -r -j $J -C $GLIBC objdir=`pwd` install_root=$ASAN_INST install-lib
370   cd $HERE
371 }
372
373         #
374         # Build base glibc
375         #
376         configure_and_build_glibc base "$BuildFlags" "$add_ons"
377
378 %{?asan:
379 %ifarch %{asan_arch}
380 build_asan
381 %endif
382 }
383 #
384 # Build html documentation
385 #
386 %if %{build_html}
387 make -C cc-base html
388 %endif
389
390 #
391 # Build glibc_post_upgrade binary
392 #
393 $BuildCC -static %{optflags} -Os $RPM_SOURCE_DIR/glibc_post_upgrade.c -o glibc_post_upgrade \
394      -Lcc-base -Bcc-base/csu \
395     '-DREMOVE_TLS_DIRS' '-DREMOVE_PPC_OPTIMIZE_POWER5' \
396     '-DLIBDIR="/%{_lib}"' '-DGCONV_MODULES_DIR="%{_libdir}/gconv"'
397
398 #
399 # Build testsuite
400 #
401 # #check sections could be redefined/disabled, so keep this inside #build
402
403 %{?glibc_run_tests:
404   export LD_AS_NEEDED=0
405   (make %{?_smp_mflags} -C cc-base check || true) 2>&1 | tee check.log
406 }
407
408
409 #######################################################################
410 ###
411 ### CHECK
412 ###
413 #######################################################################
414
415 %check
416 # The testsuite will fail if asneeded is used
417 export LD_AS_NEEDED=0
418 # This has to pass on all platforms!
419 # Exceptions:
420 # None!
421 make %{?_smp_mflags} -C cc-base check-abi
422
423 #######################################################################
424 ###
425 ### INSTALL
426 ###
427 #######################################################################
428
429 %install
430 # We don't want to strip the .symtab from our libraries in find-debuginfo.sh,
431 # certainly not from libpthread.so.* because it is used by libthread_db to find
432 # some non-exported symbols in order to detect if threading support
433 # should be enabled.  These symbols are _not_ exported, and we can't easily
434 # export them retroactively without changing the ABI.  So we have to
435 # continue to "export" them via .symtab, instead of .dynsym :-(
436 # But we also want to keep .symtab and .strtab of other libraries since some
437 # debugging tools currently require these sections directly inside the main
438 # files - specifically valgrind and PurifyPlus.
439 export STRIP_KEEP_SYMTAB=*.so*
440
441 # Make sure we will create the gconv-modules.cache
442 mkdir -p %{buildroot}%{_libdir}/gconv
443 touch %{buildroot}%{_libdir}/gconv/gconv-modules.cache
444
445 # Install base glibc
446 make %{?_smp_mflags} install_root=%{buildroot} install -C cc-base
447
448 install_optimized_variant() {
449         local dirname="$1"; shift
450         local subdir="$1"; shift
451         local subdir_up="$1"; shift
452
453 cd "cc-$dirname"
454 destdir=$RPM_BUILD_ROOT/%{_lib}/$subdir
455 mkdir -p $destdir
456 # Don't run a complete make install, we know which libraries
457 # we want
458 for lib in libc math/libm nptl/libpthread rt/librt nptl_db/libthread_db
459 do
460   libbase=${lib#*/}
461   libbaseso=$(basename $RPM_BUILD_ROOT/%{_lib}/${libbase}-*.so)
462   # Only install if different from base lib
463   if cmp -s ${lib}.so ../cc-base/${lib}.so; then
464     ln -sf $subdir_up/$libbaseso $destdir/$libbaseso
465   else
466     cp -a ${lib}.so $destdir/$libbaseso
467   fi
468   # Emulate ldconfig
469   ln -sf $libbaseso $destdir/$(basename $RPM_BUILD_ROOT/%{_lib}/${libbase}.so.*)
470 done
471 cd ..
472 }
473
474
475 # Install locales
476 %if %{build_locales}
477         # XXX Do not install locales in parallel!
478         cd cc-base
479         # localedef creates hardlinks to other locales if possible
480         # this will not work if we generate them in parallel.
481         # thus we need to run fdupes on  /usr/lib/locale/
482         # Still, on my system this is a speed advantage:
483         # non-parallel build for install-locales: 9:34mins
484         # parallel build with fdupes: 7:08mins
485         make %{?_smp_mflags} install_root=%{buildroot} localedata/install-locales
486         %fdupes %{buildroot}/usr/lib/locale
487         cd ..
488 %endif
489 # Create file list for glibc-locale package
490 %{find_lang} libc
491
492 # Prepare obsolete/, used only on some architectures:
493 export RPM_BUILD_ROOT
494 %ifarch %ix86
495 mkdir -p %{buildroot}/%{_lib}/obsolete
496 %endif
497
498 # NPTL <bits/stdio-lock.h> is not usable outside of glibc, so include
499 # the generic one (RH#162634)
500 # cp -av bits/stdio-lock.h %{buildroot}%{_includedir}/bits/stdio-lock.h
501
502
503 # Miscelanna:
504
505 install -m 0700 glibc_post_upgrade %{buildroot}%{_sbindir}
506
507 install -m 644 %{SOURCE7} %{buildroot}/etc
508 install -m 644 %{SOURCE5} %{buildroot}/etc
509 install -m 644 posix/gai.conf %{buildroot}/etc
510
511 mkdir -p %{buildroot}/etc/default
512 install -m 644 nis/nss %{buildroot}/etc/default/
513
514 mkdir -p %{buildroot}%{_includedir}/resolv
515 install -m 0644 resolv/mapv4v6addr.h %{buildroot}%{_includedir}/resolv/
516 install -m 0644 resolv/mapv4v6hostent.h %{buildroot}%{_includedir}/resolv/
517
518 %if %{build_html}
519 mkdir -p %{buildroot}%{_datadir}/doc/glibc
520 cp -p cc-base/manual/libc/*.html %{buildroot}%{_datadir}/doc/glibc
521 %endif
522
523
524 #
525 # Create ld.so.conf
526 #
527 cat > %{buildroot}/etc/ld.so.conf <<EOF
528 %if "%{_lib}" == "lib64"
529 /usr/local/lib64
530 %endif
531 /usr/local/lib
532 include /etc/ld.so.conf.d/*.conf
533 # /lib64, /lib, /usr/lib64 and /usr/lib gets added
534 # automatically by ldconfig after parsing this file.
535 # So, they do not need to be listed.
536 EOF
537 # Add ldconfig cache directory for directory ownership
538 mkdir -p %{buildroot}/var/cache/ldconfig
539 # Empty the ld.so.cache:
540 rm -f %{buildroot}/etc/ld.so.cache
541 touch %{buildroot}/etc/ld.so.cache
542
543 # Don't look at ldd! We don't wish a /bin/sh requires
544 chmod 644 %{buildroot}%{_bindir}/ldd
545
546 # Remove timezone data, now coming in standalone package:
547 for i in sbin/sln usr/bin/tzselect usr/sbin/zic usr/sbin/zdump etc/localtime; do
548         rm -f %{buildroot}/$i
549 done
550 rm -rf %{buildroot}%{_datadir}/zoneinfo
551
552 %ifarch armv7hl
553 # Provide compatibility link
554 ln -s ld-%{glibc_major_version}.so %{buildroot}/lib/ld-linux.so.3
555 %endif
556
557 # Move getconf to %{_libexecdir}/getconf/ to avoid cross device link
558 mv %{buildroot}%{_bindir}/getconf %{buildroot}%{_libexecdir}/getconf/getconf
559 ln -s %{_libexecdir}/getconf/getconf %{buildroot}%{_bindir}/getconf
560
561 #######################################################################
562 ###
563 ### ...
564 ###
565 #######################################################################
566
567 %{?asan:
568 %ifarch %{asan_arch}
569 HERE=%{_builddir}/%{name}-%{version}
570 GLIBC=$HERE
571 ASAN_BUILD=$HERE/asan-build
572 cp $ASAN_BUILD/libc.so %{buildroot}/%{_lib}/libc-2.24-asan.so
573 %endif
574 }
575
576 %{?glibc_run_tests:
577   mkdir testresults
578   cp --parents $(find cc-base -name "*tests.sum") testresults/
579   cp check.log testresults/
580   chmod 644 $(find testresults/ -type f)
581 }
582
583 %post -p %{_sbindir}/glibc_post_upgrade
584
585 %postun -p /sbin/ldconfig
586
587 %post locale
588 for l in /usr/share/locale/locale.alias %{_libdir}/gconv/gconv-modules; do
589         [ -d "$l.d" ] || continue
590         echo "###X# The following is autogenerated from extra files in the .d directory:" >>"$l"
591         cat "$l.d"/* >>"$l"
592 done
593 /usr/sbin/iconvconfig
594
595 %post info
596 %install_info --info-dir=%{_infodir} %{_infodir}/libc.info.gz
597
598 %postun info
599 %install_info_delete --info-dir=%{_infodir} %{_infodir}/libc.info.gz
600
601 %files
602 %manifest %{name}.manifest
603 # glibc
604 %defattr(-,root,root)
605 %license LICENSES COPYING COPYING.LIB
606 %config(noreplace) /etc/bindresvport.blacklist
607 %config /etc/ld.so.conf
608 %attr(0644,root,root) %verify(not md5 size mtime) %ghost %config(missingok,noreplace) /etc/ld.so.cache
609 %config(noreplace) /etc/rpc
610 %verify(not md5 size mtime) %config(noreplace) /etc/nsswitch.conf
611 %verify(not md5 size mtime) %config(noreplace) /etc/gai.conf
612 %config(noreplace) /etc/default/nss
613 /%{_lib}/ld-%{glibc_major_version}.so
614
615 # Each architecture has a different name for the dynamic linker:
616 %ifarch %arm
617 %ifarch armv7hl
618 /%{_lib}/ld-linux-armhf.so.3
619 # Keep compatibility link
620 /%{_lib}/ld-linux.so.3
621 %else
622 /%{_lib}/ld-linux.so.3
623 %endif
624 %endif
625 %ifarch x86_64
626 /%{_lib}/ld-linux-x86-64.so.2
627 %endif
628 %ifarch %ix86 %sparc
629 /%{_lib}/ld-linux.so.2
630 %endif
631 %ifarch aarch64
632 /lib/ld-linux-aarch64.so.1
633 /%{_lib}/ld-linux-aarch64.so.1
634 %endif
635
636 /%{_lib}/libanl-%{glibc_major_version}.so
637 /%{_lib}/libanl.so.1
638 /%{_lib}/libc-%{glibc_major_version}.so
639 /%{_lib}/libc.so.6*
640 /%{_lib}/libcrypt-%{glibc_major_version}.so
641 /%{_lib}/libcrypt.so.1
642 /%{_lib}/libdl-%{glibc_major_version}.so
643 /%{_lib}/libdl.so.2*
644 /%{_lib}/libm-%{glibc_major_version}.so
645 /%{_lib}/libm.so.6*
646 /%{_lib}/libnsl-%{glibc_major_version}.so
647 /%{_lib}/libnsl.so.1
648 /%{_lib}/libnss_compat-%{glibc_major_version}.so
649 /%{_lib}/libnss_compat.so.2
650 /%{_lib}/libnss_db-%{glibc_major_version}.so
651 /%{_lib}/libnss_db.so.2
652 /%{_lib}/libnss_dns-%{glibc_major_version}.so
653 /%{_lib}/libnss_dns.so.2
654 /%{_lib}/libnss_files-%{glibc_major_version}.so
655 /%{_lib}/libnss_files.so.2
656 /%{_lib}/libnss_optfiles-%{glibc_major_version}.so
657 /%{_lib}/libnss_optfiles.so.2
658 /%{_lib}/libnss_hesiod-%{glibc_major_version}.so
659 /%{_lib}/libnss_hesiod.so.2
660 /%{_lib}/libpthread-%{glibc_major_version}.so
661 /%{_lib}/libpthread.so.0
662 /%{_lib}/libthread_db-1.0.so
663 /%{_lib}/libthread_db.so.1
664 /%{_lib}/libresolv-%{glibc_major_version}.so
665 /%{_lib}/libresolv.so.2
666 /%{_lib}/librt-%{glibc_major_version}.so
667 /%{_lib}/librt.so.1
668 /%{_lib}/libutil-%{glibc_major_version}.so
669 /%{_lib}/libutil.so.1
670 %define optimized_libs() \
671         %dir %attr(0755,root,root) /%{_lib}/%1\
672         /%{_lib}/%1/libc-%{glibc_major_version}.so\
673         /%{_lib}/%1/libc.so.6*\
674         /%{_lib}/%1/libm-%{glibc_major_version}.so\
675         /%{_lib}/%1/libm.so.6*\
676         /%{_lib}/%1/libpthread-%{glibc_major_version}.so\
677         /%{_lib}/%1/libpthread.so.0\
678         /%{_lib}/%1/librt-%{glibc_major_version}.so\
679         /%{_lib}/%1/librt.so.1\
680         /%{_lib}/%1/libthread_db-1.0.so\
681         /%{_lib}/%1/libthread_db.so.1
682
683 %dir %attr(0700,root,root) /var/cache/ldconfig
684 /sbin/ldconfig
685 %{_bindir}/gencat
686 %{_bindir}/getconf
687 %{_bindir}/getent
688 %{_bindir}/iconv
689 %attr(755,root,root) %{_bindir}/ldd
690 %ifarch %ix86 sparc sparcv9
691         %{_bindir}/lddlibc4
692 %endif
693 %{_bindir}/locale
694 %{_bindir}/localedef
695 %dir %attr(0755,root,root) %{_libexecdir}/getconf
696 %{_libexecdir}/getconf/*
697 %{_sbindir}/glibc_post_upgrade
698 %{_sbindir}/iconvconfig
699 /%{_lib}/libBrokenLocale-%{glibc_major_version}.so
700 /%{_lib}/libBrokenLocale.so.1
701
702 %ifarch %ix86
703
704 %files obsolete
705 %manifest %{name}.manifest
706 %license COPYING.LIB
707 %defattr (755,root,root,755)
708 %dir /%{_lib}/obsolete/
709         #%dir /%{_lib}/obsolete/noversion
710         #/%{_lib}/obsolete/noversion/libNoVersion-%{glibc_major_version}.so
711         #/%{_lib}/obsolete/noversion/libNoVersion.so.1
712 %endif
713
714 %files locale -f libc.lang
715 %manifest %{name}.manifest
716 %license COPYING COPYING.LIB
717 %defattr(-,root,root)
718 %{_datadir}/locale/locale.alias
719 %if %{build_locales}
720 /usr/lib/locale/*
721 %endif
722 %{_libdir}/gconv
723
724 %{?asan:
725 %ifarch %{asan_arch}
726 %files asan
727 %manifest %{name}.manifest
728 /%{_lib}/libc-2.24-asan.so
729 %endif
730 }
731
732 %files devel
733 %manifest %{name}.manifest
734 %defattr(-,root,root)
735 %license COPYING COPYING.LIB 
736 %doc NEWS README
737 %{_bindir}/rpcgen
738 %{_includedir}/*
739 %{_libdir}/*.o
740 %{_libdir}/*.so
741 # These static libraries are needed even for shared builds
742 %{_libdir}/libc_nonshared.a
743 %{_libdir}/libg.a
744 %ifarch ppc ppc64 s390 s390x sparc sparcv8 sparcv9 sparcv9v
745 # This is not built on sparc64.
746         %{_libdir}/libnldbl_nonshared.a
747 %endif
748 %{_libdir}/libmcheck.a
749 %{_libdir}/librpcsvc.a
750
751 %files devel-static
752 %manifest %{name}.manifest
753 %defattr(-,root,root)
754 %{_libdir}/libBrokenLocale.a
755 %{_libdir}/libanl.a
756 %{_libdir}/libc.a
757 %{_libdir}/libcrypt.a
758 %{_libdir}/libdl.a
759 %{_libdir}/libm.a
760 %{_libdir}/libpthread.a
761 %{_libdir}/libresolv.a
762 %{_libdir}/librt.a
763 %{_libdir}/libutil.a
764
765 %files info
766 %manifest %{name}.manifest
767 %defattr(-,root,root)
768 %doc %{_infodir}/libc.info.gz
769 %doc %{_infodir}/libc.info-?.gz
770 %doc %{_infodir}/libc.info-??.gz
771
772 %if %{build_html}
773 %files html
774 %manifest %{name}.manifest
775 %defattr(-,root,root)
776 %doc %{_prefix}/share/doc/glibc
777 %endif
778
779 %files i18ndata
780 %manifest %{name}.manifest
781 %defattr(-,root,root)
782 %{_prefix}/share/i18n
783
784 %if %{build_profile}
785 %files profile
786 %manifest %{name}.manifest
787 %license COPYING COPYING.LIB
788 %defattr(-,root,root)
789 %{_libdir}/libc_p.a
790 %{_libdir}/libBrokenLocale_p.a
791 %{_libdir}/libanl_p.a
792 %{_libdir}/libm_p.a
793 %{_libdir}/libcrypt_p.a
794 %{_libdir}/libpthread_p.a
795 %{_libdir}/libresolv_p.a
796 %{_libdir}/librt_p.a
797 %{_libdir}/librpcsvc_p.a
798 %{_libdir}/libutil_p.a
799 %{_libdir}/libdl_p.a
800 %endif
801
802 %files devel-utils
803 %manifest %{name}.manifest
804 %defattr(-,root,root)
805 /%{_lib}/libmemusage.so
806 /%{_lib}/libpcprofile.so
807 /%{_libdir}/libBrokenLocale.so
808 /%{_lib}/libSegFault.so
809 /%{_lib}/libthread_db-1.0.so
810 /%{_lib}/libthread_db.so.1
811 /%{_libdir}/libthread_db.so
812 %dir /%{_libdir}/audit
813 /%{_libdir}/audit/sotruss-lib.so
814 # These need gd-devel for building
815 # %%{_bindir}/memusage
816 # %%{_bindir}/memusagestat
817 %{_bindir}/mtrace
818 %{_bindir}/pcprofiledump
819 %{_bindir}/sotruss
820 %{_bindir}/xtrace
821 %{_bindir}/pldd
822 %{_bindir}/catchsegv
823 %{_bindir}/sprof
824
825 %files extra
826 %manifest %{name}.manifest
827 %license COPYING.LIB
828 %defattr(-,root,root)
829 %{_bindir}/makedb
830 /var/db/Makefile
831
832 %{?glibc_run_tests:
833 %files testresults
834 %defattr(-,root,root)
835 %doc testresults/check.log
836 %doc testresults/*
837 }
838
839 %docs_package