packaging: renamed linaro-glibc.spec -> glibc.spec
[platform/upstream/glibc.git] / packaging / glibc.spec
1 #
2 # spec file for package glibc
3 #
4 # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14
15 # This will avoid building some parts of glibc
16 %bcond_with    fast_build
17
18 Name:           glibc
19 Summary:        Standard Shared Libraries (from the GNU C Library)
20 License:        LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
21 Group:          Base/Libraries
22 BuildRequires:  fdupes
23 BuildRequires:  makeinfo
24 BuildRequires:  xz
25 BuildRequires:  gcc-c++
26 BuildRequires:  gettext-tools
27 BuildRequires:  libstdc++-devel
28 #BuildRequires:  pkgconfig(systemd)
29
30 %define _filter_GLIBC_PRIVATE 1
31 %if %_target_cpu == "i686"
32 # For i686 let's only build what's different from i586, so
33 # no need to build documentation
34 %define build_profile 1
35 %define build_locales 0
36 %define build_html 0
37 %else
38 %if %{with fast_build}
39 %define build_profile 0
40 %define build_locales 0
41 %define build_html 0
42 %else
43 # Default:
44 %define build_profile 1
45 %define build_locales 0
46 %define build_html 1
47 %endif
48 %endif
49
50 %define disable_assert 0
51 %define enable_stackguard_randomization 1
52
53
54 %ifarch x86_64
55 %define enablekernel 2.6.16
56 %else
57 %define enablekernel 2.6.16
58 %endif
59 Conflicts:      kernel < %{enablekernel}
60 %ifarch armv7l armv7hl
61 # The old runtime linker link gets not provided by rpm find.provides, but it exists
62 Provides:       ld-linux.so.3
63 Provides:       ld-linux.so.3(GLIBC_2.4)
64 %endif
65 Version:        2.24
66 Release:        0
67 %define glibc_major_version 2.24
68 %define git_id 4e42b5b8f89f
69
70 Url:            http://www.gnu.org/software/libc/libc.html
71 Source:         glibc-%{version}.tar.xz
72 Source5:        nsswitch.conf
73 Source7:        bindresvport.blacklist
74 Source8:        glibc_post_upgrade.c
75 Source9:        glibc.rpmlintrc
76 Source10:       baselibs.conf
77 # For systemd 
78 Source1001:     glibc.manifest
79
80 Requires(pre):  filesystem
81 Provides:       rtld(GNU_HASH)
82
83 %description
84 The GNU C Library provides the most important standard libraries used
85 by nearly all programs: the standard C library, the standard math
86 library, and the POSIX thread library. A system is not functional
87 without these libraries.
88
89 %package info
90 Summary:        Info Files for the GNU C Library
91 License:        GFDL-1.1
92 Group:          Documentation
93 BuildArch:      noarch
94
95 %description info
96 This package contains the documentation for the GNU C library stored as
97 info files. Due to a lack of resources, this documentation is not
98 complete and is partially out of date.
99
100 %package html
101 Summary:        HTML Documentation for the GNU C Library
102 License:        GFDL-1.1
103 Group:          Documentation
104 BuildArch:      noarch
105
106 %description html
107 This package contains the HTML documentation for the GNU C library. Due
108 to a lack of resources, this documentation is not complete and is
109 partially out of date.
110
111 %package i18ndata
112 Summary:        Database Sources for 'locale'
113 License:        GPL-2.0+ and MIT
114 Group:          Base/Libraries
115 BuildArch:      noarch
116
117 %description i18ndata
118 This package contains the data needed to build the locale data files to
119 use the internationalization features of the GNU libc. It is normally
120 not necessary to install this packages, the data files are already
121 created.
122
123 %package locale
124 Summary:        Locale Data for Localized Programs
125 License:        GPL-2.0+ and MIT and LGPL-2.1+
126 Requires(post): /usr/bin/cat
127 Requires:       glibc = %{version}
128 %description locale
129 Locale data for the internationalisation features of the GNU C library.
130
131 %package profile
132 Summary:        Libc Profiling and Debugging Versions
133 License:        LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
134 Group:          Base/Utilities
135 Requires:       glibc = %{version}
136
137 %description profile
138 This package contains special versions of the GNU C library which are
139 necessary for profiling and debugging.
140
141 %package devel
142 Summary:        Include Files and Libraries Mandatory for Development
143 License:        BSD-3-Clause and LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
144 Requires:       glibc = %{version}
145 Requires:       linux-kernel-headers
146
147 %description devel
148 These libraries are needed to develop programs which use the standard C
149 library.
150
151 %package devel-static
152 Summary:        C library static libraries for -static linking
153 License:        BSD-3-Clause and LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
154 Requires:       %{name}-devel = %{version}
155 # Provide Fedora name for package to make packaging easier
156 Provides:       %{name}-static = %version
157
158 %description devel-static
159 The glibc-devel-static package contains the C library static libraries
160 for -static linking.  You don't need these, unless you link statically,
161 which is highly discouraged.
162
163 %package devel-utils
164 Summary:        Development utilities from GNU C library
165 License:        LGPL-2.1+
166 Requires:       glibc = %{version}
167
168 %description devel-utils
169 The glibc-devel-utils package contains various binaries which can be helpful during program
170 debugging.
171
172 If you are unsure if you need this, don't install this package.
173
174 %package extra
175 Summary:        Extra binaries from GNU C Library
176 License:        LGPL-2.1+
177 Requires:       glibc = %{version}
178
179 %description extra
180 The glibc-extra package contains some extra binaries for glibc that
181 are not essential but recommend to use.
182
183 makedb: A program to create a database for nss
184
185 %package obsolete
186 Summary:        Obsolete Shared Libraries from the GNU C Library
187 License:        LGPL-2.0+
188 Requires:       glibc = %{version}
189
190 %description obsolete
191 This package provides some old libraries from the GNU C Library which
192 are no longer supported. Additional it provides a compatibility library
193 for old binaries linked against glibc 2.0.
194
195 Install this package if you need one of this libraries to get old
196 binaries working, but since this libraries are not supported and there
197 is no gurantee that they work for you, you should try to get newer
198 versions of your software.
199
200 %prep
201 %setup -n glibc-%{version} -q 
202 cp %{SOURCE1001} .
203
204 %build
205 if [ -x /bin/uname.bin ]; then
206         /bin/uname.bin -a
207 else
208         uname -a
209 fi
210 uptime || :
211 ulimit -a
212 nice
213 # We do not want configure to figure out the system its building one
214 # to support a common ground and thus set build and host to the
215 # target_cpu.
216 %ifarch %arm
217 %define target %{_target_cpu}-tizen-linux-gnueabi
218 %else
219 %define target %{_target_cpu}-tizen-linux
220 %endif
221 # Don't use as-needed, it breaks glibc assumptions
222 # Before enabling it, run the testsuite and verify that it
223 # passes completely
224 export LD_AS_NEEDED=0
225 # Adjust glibc version.h
226 echo "#define CONFHOST \"%{target}\"" >> version.h
227 echo "#define GITID \"%{git_id}\"" >> version.h
228 #
229 # Default CFLAGS and Compiler
230 #
231 BuildFlags=$(echo %{optflags} | sed -e "s/-Wp,-D_FORTIFY_SOURCE=2//g" | sed -e "s/-ffast-math//" | sed -e "s/atom/i686/g" | sed -e "s/-fexceptions//" | sed -e "s/-fno-omit-frame-pointer//" )
232 BuildFlags="$BuildFlags -O2 -g -U_FORTIFY_SOURCE"
233 BuildFlags="$(echo $BuildFlags | sed -e 's#-fstack-protector##' -e 's#-ffortify=[0-9]*##')"
234 BuildFlags="$(echo $BuildFlags | sed -e 's/-Wa,-mimplicit-it=thumb//g' | sed -e 's/-mthumb//g')"
235 BuildCC="%__cc"
236 BuildCCplus="%__cxx"
237 add_ons=",libidn"
238
239
240 BuildFlags="$BuildFlags -g"
241 %if %{disable_assert}
242         BuildFlags="$BuildFlags -DNDEBUG=1"
243 %endif
244 %ifarch %ix86
245         add_ons=$add_ons
246 %endif
247 %ifarch %arm aarch64
248         add_ons=$add_ons
249 %endif
250 %ifarch mipsel
251         # fails to build otherwise - need to recheck and fix
252         %define enable_stackguard_randomization 0
253 %endif
254
255 configure_and_build_glibc() {
256         local dirname="$1"; shift
257         local cflags="$1"; shift
258         local addons="$1"; shift
259         mkdir "cc-$dirname"
260         cd "cc-$dirname"
261         conf_cflags="$cflags -funwind-tables"
262
263         profile="--disable-profile"
264 %if %{build_profile}
265         if [ "$dirname" = "base" ] ; then
266             profile="--enable-profile"
267         fi
268 %endif
269         CFLAGS="$conf_cflags" BUILD_CFLAGS="$conf_cflags" \
270         CC="$BuildCC" CXX="$BuildCCplus"  ../configure \
271                 --prefix=%{_prefix} \
272                 --libexecdir=%{_libexecdir} --infodir=%{_infodir} \
273                 --enable-add-ons=$addons \
274                 $profile \
275                 "$@" \
276 %if %{enable_stackguard_randomization}
277                 --enable-stackguard-randomization \
278 %endif
279                 --build=%{target} --host=%{target} \
280 %ifarch %{ix86} x86_64 
281                 --enable-multi-arch \
282                 --disable-mathvec \
283 %endif
284                 --enable-kernel=%{enablekernel} \
285                 --enable-bind-now  --enable-obsolete-rpc \
286                 --disable-nscd
287         # explicitly set CFLAGS to use the full CFLAGS (not the reduced one for configure)
288         make %{?_smp_mflags} #CFLAGS="$cflags" BUILD_CFLAGS="$cflags"
289         cd ..
290 }
291
292         #
293         # Build base glibc
294         #
295         configure_and_build_glibc base "$BuildFlags" "$add_ons"
296
297 #
298 # Build html documentation
299 #
300 %if %{build_html}
301 make -C cc-base html
302 %endif
303
304 #
305 # Build glibc_post_upgrade binary
306 #
307 $BuildCC -static %{optflags} -Os $RPM_SOURCE_DIR/glibc_post_upgrade.c -o glibc_post_upgrade \
308      -Lcc-base -Bcc-base/csu \
309     '-DREMOVE_TLS_DIRS' '-DREMOVE_PPC_OPTIMIZE_POWER5' \
310     '-DLIBDIR="/%{_lib}"' '-DGCONV_MODULES_DIR="%{_libdir}/gconv"'
311
312
313 #######################################################################
314 ###
315 ### CHECK
316 ###
317 #######################################################################
318
319 %check
320 # The testsuite will fail if asneeded is used
321 export LD_AS_NEEDED=0
322 # This has to pass on all platforms!
323 # Exceptions:
324 # None!
325 make %{?_smp_mflags} -C cc-base check-abi
326
327 #######################################################################
328 ###
329 ### INSTALL
330 ###
331 #######################################################################
332
333 %install
334 # We don't want to strip the .symtab from our libraries in find-debuginfo.sh,
335 # certainly not from libpthread.so.* because it is used by libthread_db to find
336 # some non-exported symbols in order to detect if threading support
337 # should be enabled.  These symbols are _not_ exported, and we can't easily
338 # export them retroactively without changing the ABI.  So we have to
339 # continue to "export" them via .symtab, instead of .dynsym :-(
340 # But we also want to keep .symtab and .strtab of other libraries since some
341 # debugging tools currently require these sections directly inside the main
342 # files - specifically valgrind and PurifyPlus.
343 export STRIP_KEEP_SYMTAB=*.so*
344
345 # Make sure we will create the gconv-modules.cache
346 mkdir -p %{buildroot}%{_libdir}/gconv
347 touch %{buildroot}%{_libdir}/gconv/gconv-modules.cache
348
349 # Install base glibc
350 make %{?_smp_mflags} install_root=%{buildroot} install -C cc-base
351
352 install_optimized_variant() {
353         local dirname="$1"; shift
354         local subdir="$1"; shift
355         local subdir_up="$1"; shift
356
357 cd "cc-$dirname"
358 destdir=$RPM_BUILD_ROOT/%{_lib}/$subdir
359 mkdir -p $destdir
360 # Don't run a complete make install, we know which libraries
361 # we want
362 for lib in libc math/libm nptl/libpthread rt/librt nptl_db/libthread_db
363 do
364   libbase=${lib#*/}
365   libbaseso=$(basename $RPM_BUILD_ROOT/%{_lib}/${libbase}-*.so)
366   # Only install if different from base lib
367   if cmp -s ${lib}.so ../cc-base/${lib}.so; then
368     ln -sf $subdir_up/$libbaseso $destdir/$libbaseso
369   else
370     cp -a ${lib}.so $destdir/$libbaseso
371   fi
372   # Emulate ldconfig
373   ln -sf $libbaseso $destdir/$(basename $RPM_BUILD_ROOT/%{_lib}/${libbase}.so.*)
374 done
375 cd ..
376 }
377
378
379 # Install locales
380 %if %{build_locales}
381         # XXX Do not install locales in parallel!
382         cd cc-base
383         # localedef creates hardlinks to other locales if possible
384         # this will not work if we generate them in parallel.
385         # thus we need to run fdupes on  /usr/lib/locale/
386         # Still, on my system this is a speed advantage:
387         # non-parallel build for install-locales: 9:34mins
388         # parallel build with fdupes: 7:08mins
389         make %{?_smp_mflags} install_root=%{buildroot} localedata/install-locales
390         %fdupes %{buildroot}/usr/lib/locale
391         cd ..
392 %endif
393 # Create file list for glibc-locale package
394 %{find_lang} libc
395
396 # Prepare obsolete/, used only on some architectures:
397 export RPM_BUILD_ROOT
398 %ifarch %ix86
399 mkdir -p %{buildroot}/%{_lib}/obsolete
400 %endif
401
402 # NPTL <bits/stdio-lock.h> is not usable outside of glibc, so include
403 # the generic one (RH#162634)
404 # cp -av bits/stdio-lock.h %{buildroot}%{_includedir}/bits/stdio-lock.h
405
406
407 # Miscelanna:
408
409 install -m 0700 glibc_post_upgrade %{buildroot}%{_sbindir}
410
411 install -m 644 %{SOURCE7} %{buildroot}/etc
412 install -m 644 %{SOURCE5} %{buildroot}/etc
413 install -m 644 posix/gai.conf %{buildroot}/etc
414
415 mkdir -p %{buildroot}/etc/default
416 install -m 644 nis/nss %{buildroot}/etc/default/
417
418 mkdir -p %{buildroot}%{_includedir}/resolv
419 install -m 0644 resolv/mapv4v6addr.h %{buildroot}%{_includedir}/resolv/
420 install -m 0644 resolv/mapv4v6hostent.h %{buildroot}%{_includedir}/resolv/
421
422 %if %{build_html}
423 mkdir -p %{buildroot}%{_datadir}/doc/glibc
424 cp -p cc-base/manual/libc/*.html %{buildroot}%{_datadir}/doc/glibc
425 %endif
426
427
428 #
429 # Create ld.so.conf
430 #
431 cat > %{buildroot}/etc/ld.so.conf <<EOF
432 %if "%{_lib}" == "lib64"
433 /usr/local/lib64
434 %endif
435 /usr/local/lib
436 include /etc/ld.so.conf.d/*.conf
437 # /lib64, /lib, /usr/lib64 and /usr/lib gets added
438 # automatically by ldconfig after parsing this file.
439 # So, they do not need to be listed.
440 EOF
441 # Add ldconfig cache directory for directory ownership
442 mkdir -p %{buildroot}/var/cache/ldconfig
443 # Empty the ld.so.cache:
444 rm -f %{buildroot}/etc/ld.so.cache
445 touch %{buildroot}/etc/ld.so.cache
446
447 # Don't look at ldd! We don't wish a /bin/sh requires
448 chmod 644 %{buildroot}%{_bindir}/ldd
449
450 # Remove timezone data, now coming in standalone package:
451 for i in sbin/sln usr/bin/tzselect usr/sbin/zic usr/sbin/zdump etc/localtime; do
452         rm -f %{buildroot}/$i
453 done
454 rm -rf %{buildroot}%{_datadir}/zoneinfo
455
456 %ifarch armv7hl
457 # Provide compatibility link
458 ln -s ld-%{glibc_major_version}.so %{buildroot}/lib/ld-linux.so.3
459 %endif
460
461 # Move getconf to %{_libexecdir}/getconf/ to avoid cross device link
462 mv %{buildroot}%{_bindir}/getconf %{buildroot}%{_libexecdir}/getconf/getconf
463 ln -s %{_libexecdir}/getconf/getconf %{buildroot}%{_bindir}/getconf
464
465 #######################################################################
466 ###
467 ### ...
468 ###
469 #######################################################################
470
471 %post -p %{_sbindir}/glibc_post_upgrade
472
473 %postun -p /sbin/ldconfig
474
475 %post locale
476 for l in /usr/share/locale/locale.alias %{_libdir}/gconv/gconv-modules; do
477         [ -d "$l.d" ] || continue
478         echo "###X# The following is autogenerated from extra files in the .d directory:" >>"$l"
479         cat "$l.d"/* >>"$l"
480 done
481 /usr/sbin/iconvconfig
482
483 %post info
484 %install_info --info-dir=%{_infodir} %{_infodir}/libc.info.gz
485
486 %postun info
487 %install_info_delete --info-dir=%{_infodir} %{_infodir}/libc.info.gz
488
489 %files
490 %manifest %{name}.manifest
491 # glibc
492 %defattr(-,root,root)
493 %license LICENSES
494 %config(noreplace) /etc/bindresvport.blacklist
495 %config /etc/ld.so.conf
496 %attr(0644,root,root) %verify(not md5 size mtime) %ghost %config(missingok,noreplace) /etc/ld.so.cache
497 %config(noreplace) /etc/rpc
498 %verify(not md5 size mtime) %config(noreplace) /etc/nsswitch.conf
499 %verify(not md5 size mtime) %config(noreplace) /etc/gai.conf
500 %config(noreplace) /etc/default/nss
501 /%{_lib}/ld-%{glibc_major_version}.so
502
503 # Each architecture has a different name for the dynamic linker:
504 %ifarch %arm
505 %ifarch armv7hl
506 /%{_lib}/ld-linux-armhf.so.3
507 # Keep compatibility link
508 /%{_lib}/ld-linux.so.3
509 %else
510 /%{_lib}/ld-linux.so.3
511 %endif
512 %endif
513 %ifarch x86_64
514 /%{_lib}/ld-linux-x86-64.so.2
515 %endif
516 %ifarch %ix86 %sparc
517 /%{_lib}/ld-linux.so.2
518 %endif
519 %ifarch aarch64
520 /lib/ld-linux-aarch64.so.1
521 /%{_lib}/ld-linux-aarch64.so.1
522 %endif
523
524 /%{_lib}/libanl-%{glibc_major_version}.so
525 /%{_lib}/libanl.so.1
526 /%{_lib}/libc-%{glibc_major_version}.so
527 /%{_lib}/libc.so.6*
528 /%{_lib}/libcidn-%{glibc_major_version}.so
529 /%{_lib}/libcidn.so.1
530 /%{_lib}/libcrypt-%{glibc_major_version}.so
531 /%{_lib}/libcrypt.so.1
532 /%{_lib}/libdl-%{glibc_major_version}.so
533 /%{_lib}/libdl.so.2*
534 /%{_lib}/libm-%{glibc_major_version}.so
535 /%{_lib}/libm.so.6*
536 /%{_lib}/libnsl-%{glibc_major_version}.so
537 /%{_lib}/libnsl.so.1
538 /%{_lib}/libnss_compat-%{glibc_major_version}.so
539 /%{_lib}/libnss_compat.so.2
540 /%{_lib}/libnss_db-%{glibc_major_version}.so
541 /%{_lib}/libnss_db.so.2
542 /%{_lib}/libnss_dns-%{glibc_major_version}.so
543 /%{_lib}/libnss_dns.so.2
544 /%{_lib}/libnss_files-%{glibc_major_version}.so
545 /%{_lib}/libnss_files.so.2
546 /%{_lib}/libnss_hesiod-%{glibc_major_version}.so
547 /%{_lib}/libnss_hesiod.so.2
548 /%{_lib}/libnss_nis-%{glibc_major_version}.so
549 /%{_lib}/libnss_nis.so.2
550 /%{_lib}/libnss_nisplus-%{glibc_major_version}.so
551 /%{_lib}/libnss_nisplus.so.2
552 /%{_lib}/libpthread-%{glibc_major_version}.so
553 /%{_lib}/libpthread.so.0
554 /%{_lib}/libthread_db-1.0.so
555 /%{_lib}/libthread_db.so.1
556 /%{_lib}/libresolv-%{glibc_major_version}.so
557 /%{_lib}/libresolv.so.2
558 /%{_lib}/librt-%{glibc_major_version}.so
559 /%{_lib}/librt.so.1
560 /%{_lib}/libutil-%{glibc_major_version}.so
561 /%{_lib}/libutil.so.1
562 %define optimized_libs() \
563         %dir %attr(0755,root,root) /%{_lib}/%1\
564         /%{_lib}/%1/libc-%{glibc_major_version}.so\
565         /%{_lib}/%1/libc.so.6*\
566         /%{_lib}/%1/libm-%{glibc_major_version}.so\
567         /%{_lib}/%1/libm.so.6*\
568         /%{_lib}/%1/libpthread-%{glibc_major_version}.so\
569         /%{_lib}/%1/libpthread.so.0\
570         /%{_lib}/%1/librt-%{glibc_major_version}.so\
571         /%{_lib}/%1/librt.so.1\
572         /%{_lib}/%1/libthread_db-1.0.so\
573         /%{_lib}/%1/libthread_db.so.1
574
575 %dir %attr(0700,root,root) /var/cache/ldconfig
576 /sbin/ldconfig
577 %{_bindir}/gencat
578 %{_bindir}/getconf
579 %{_bindir}/getent
580 %{_bindir}/iconv
581 %attr(755,root,root) %{_bindir}/ldd
582 %ifarch %ix86 sparc sparcv9
583         %{_bindir}/lddlibc4
584 %endif
585 %{_bindir}/locale
586 %{_bindir}/localedef
587 %dir %attr(0755,root,root) %{_libexecdir}/getconf
588 %{_libexecdir}/getconf/*
589 %{_sbindir}/glibc_post_upgrade
590 %{_sbindir}/iconvconfig
591 /%{_lib}/libBrokenLocale-%{glibc_major_version}.so
592 /%{_lib}/libBrokenLocale.so.1
593
594 %ifarch %ix86
595
596 %files obsolete
597 %manifest %{name}.manifest
598 %defattr (755,root,root,755)
599 %dir /%{_lib}/obsolete/
600         #%dir /%{_lib}/obsolete/noversion
601         #/%{_lib}/obsolete/noversion/libNoVersion-%{glibc_major_version}.so
602         #/%{_lib}/obsolete/noversion/libNoVersion.so.1
603 %endif
604
605 %files locale -f libc.lang
606 %manifest %{name}.manifest
607 %defattr(-,root,root)
608 %{_datadir}/locale/locale.alias
609 %if %{build_locales}
610 /usr/lib/locale/*
611 %endif
612 %{_libdir}/gconv
613
614 %files devel
615 %manifest %{name}.manifest
616 %defattr(-,root,root)
617 %license COPYING COPYING.LIB 
618 %doc NEWS README BUGS CONFORMANCE
619 %{_bindir}/rpcgen
620 %{_includedir}/*
621 %{_libdir}/*.o
622 %{_libdir}/*.so
623 # These static libraries are needed even for shared builds
624 %{_libdir}/libc_nonshared.a
625 %{_libdir}/libg.a
626 %{_libdir}/libieee.a
627 %ifarch ppc ppc64 s390 s390x sparc sparcv8 sparcv9 sparcv9v
628 # This is not built on sparc64.
629         %{_libdir}/libnldbl_nonshared.a
630 %endif
631 %{_libdir}/libmcheck.a
632 %{_libdir}/libpthread_nonshared.a
633 %{_libdir}/librpcsvc.a
634
635 %files devel-static
636 %manifest %{name}.manifest
637 %defattr(-,root,root)
638 %{_libdir}/libBrokenLocale.a
639 %{_libdir}/libanl.a
640 %{_libdir}/libc.a
641 %{_libdir}/libcrypt.a
642 %{_libdir}/libdl.a
643 %{_libdir}/libm.a
644 %{_libdir}/libnsl.a
645 %{_libdir}/libpthread.a
646 %{_libdir}/libresolv.a
647 %{_libdir}/librt.a
648 %{_libdir}/libutil.a
649
650 %files info
651 %manifest %{name}.manifest
652 %defattr(-,root,root)
653 %doc %{_infodir}/libc.info.gz
654 %doc %{_infodir}/libc.info-?.gz
655 %doc %{_infodir}/libc.info-??.gz
656
657 %if %{build_html}
658 %files html
659 %manifest %{name}.manifest
660 %defattr(-,root,root)
661 %doc %{_prefix}/share/doc/glibc
662 %endif
663
664 %files i18ndata
665 %manifest %{name}.manifest
666 %defattr(-,root,root)
667 %{_prefix}/share/i18n
668
669 %if %{build_profile}
670 %files profile
671 %manifest %{name}.manifest
672 %defattr(-,root,root)
673 %{_libdir}/libc_p.a
674 %{_libdir}/libBrokenLocale_p.a
675 %{_libdir}/libanl_p.a
676 %{_libdir}/libm_p.a
677 %{_libdir}/libcrypt_p.a
678 %{_libdir}/libpthread_p.a
679 %{_libdir}/libresolv_p.a
680 %{_libdir}/libnsl_p.a
681 %{_libdir}/librt_p.a
682 %{_libdir}/librpcsvc_p.a
683 %{_libdir}/libutil_p.a
684 %{_libdir}/libdl_p.a
685 %endif
686
687 %files devel-utils
688 %manifest %{name}.manifest
689 %defattr(-,root,root)
690 /%{_lib}/libmemusage.so
691 /%{_lib}/libpcprofile.so
692 /%{_libdir}/libBrokenLocale.so
693 /%{_lib}/libSegFault.so
694 /%{_lib}/libthread_db-1.0.so
695 /%{_lib}/libthread_db.so.1
696 /%{_libdir}/libthread_db.so
697 %dir /%{_libdir}/audit
698 /%{_libdir}/audit/sotruss-lib.so
699 # These need gd-devel for building
700 # %%{_bindir}/memusage
701 # %%{_bindir}/memusagestat
702 %{_bindir}/mtrace
703 %{_bindir}/pcprofiledump
704 %{_bindir}/sotruss
705 %{_bindir}/xtrace
706 %{_bindir}/pldd
707 %{_bindir}/catchsegv
708 %{_bindir}/sprof
709
710 %files extra
711 %manifest %{name}.manifest
712 %defattr(-,root,root)
713 %{_bindir}/makedb
714 /var/db/Makefile
715
716
717 %docs_package