Add rpm with testresults
[platform/upstream/glibc.git] / packaging / glibc.spec
1 #
2 # spec file for package glibc
3 #
4 # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14
15 %if 0%{?run_tests}
16 %define glibc_run_tests 1
17 %endif
18
19 # This will avoid building some parts of glibc
20 %define asan_arch x86_64 armv7l aarch64
21 %bcond_with    fast_build
22 Name:           glibc
23 Summary:        Standard Shared Libraries (from the GNU C Library)
24 License:        LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
25 Group:          Base/Libraries
26 BuildRequires:  fdupes
27 BuildRequires:  makeinfo
28 BuildRequires:  xz
29 BuildRequires:  gcc-c++
30 BuildRequires:  gettext-tools
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  bison
33 BuildRequires:  python3-base
34 %{?asan:
35 %ifarch %asan_arch
36 #BuildRequires:  python
37 BuildRequires:  glibc-devel-static
38 %endif
39 }
40 #BuildRequires:  pkgconfig(systemd)
41 %define _filter_GLIBC_PRIVATE 1
42 %if %_target_cpu == "i686"
43 # For i686 let's only build what's different from i586, so
44 # no need to build documentation
45 %define build_profile 1
46 %define build_locales 0
47 %define build_html 0
48 %else
49 %if %{with fast_build}
50 %define build_profile 0
51 %define build_locales 0
52 %define build_html 0
53 %else
54 # Default:
55 %define build_profile 1
56 %define build_locales 0
57 %define build_html 1
58 %endif
59 %endif
60
61 %define disable_assert 0
62 %define enable_stackguard_randomization 1
63 %define multiarcharches %{ix86} x86_64
64
65 %ifarch x86_64
66 %define enablekernel 2.6.16
67 %else
68 %define enablekernel 2.6.16
69 %endif
70 Conflicts:      kernel < %{enablekernel}
71 %ifarch armv7l armv7hl
72 # The old runtime linker link gets not provided by rpm find.provides, but it exists
73 Provides:       ld-linux.so.3
74 Provides:       ld-linux.so.3(GLIBC_2.4)
75 %endif
76 Version:        2.30
77 Release:        0
78 %define glibc_major_version %{version}
79 %define git_id 0a8262a1b2
80
81 Url:            http://www.gnu.org/software/libc/libc.html
82 Source:         glibc-%{version}.tar.xz
83 Source5:        nsswitch.conf
84 Source7:        bindresvport.blacklist
85 Source8:        glibc_post_upgrade.c
86 Source9:        glibc.rpmlintrc
87 Source10:       baselibs.conf
88 # For systemd 
89 Source1001:     glibc.manifest
90
91 Requires(pre):  filesystem
92 Provides:       rtld(GNU_HASH)
93
94 %description
95 The GNU C Library provides the most important standard libraries used
96 by nearly all programs: the standard C library, the standard math
97 library, and the POSIX thread library. A system is not functional
98 without these libraries.
99
100 %package info
101 Summary:        Info Files for the GNU C Library
102 License:        GFDL-1.1
103 Group:          Documentation
104 BuildArch:      noarch
105
106 %description info
107 This package contains the documentation for the GNU C library stored as
108 info files. Due to a lack of resources, this documentation is not
109 complete and is partially out of date.
110
111 %package html
112 Summary:        HTML Documentation for the GNU C Library
113 License:        GFDL-1.1
114 Group:          Documentation
115 BuildArch:      noarch
116
117 %description html
118 This package contains the HTML documentation for the GNU C library. Due
119 to a lack of resources, this documentation is not complete and is
120 partially out of date.
121
122 %package i18ndata
123 Summary:        Database Sources for 'locale'
124 License:        GPL-2.0+ and MIT
125 Group:          Base/Libraries
126 BuildArch:      noarch
127
128 %description i18ndata
129 This package contains the data needed to build the locale data files to
130 use the internationalization features of the GNU libc. It is normally
131 not necessary to install this packages, the data files are already
132 created.
133
134 %package locale
135 Summary:        Locale Data for Localized Programs
136 License:        GPL-2.0+ and MIT and LGPL-2.1+
137 Requires(post): /usr/bin/cat
138 Requires:       glibc = %{version}
139 %description locale
140 Locale data for the internationalisation features of the GNU C library.
141
142 %package profile
143 Summary:        Libc Profiling and Debugging Versions
144 License:        LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
145 Group:          Base/Utilities
146 Requires:       glibc = %{version}
147
148 %description profile
149 This package contains special versions of the GNU C library which are
150 necessary for profiling and debugging.
151
152 %package devel
153 Summary:        Include Files and Libraries Mandatory for Development
154 License:        BSD-3-Clause and LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
155 Requires:       glibc = %{version}
156 Requires:       linux-kernel-headers
157
158 %description devel
159 These libraries are needed to develop programs which use the standard C
160 library.
161
162 %package devel-static
163 Summary:        C library static libraries for -static linking
164 License:        BSD-3-Clause and LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
165 Requires:       %{name}-devel = %{version}
166 # Provide Fedora name for package to make packaging easier
167 Provides:       %{name}-static = %version
168
169 %description devel-static
170 The glibc-devel-static package contains the C library static libraries
171 for -static linking.  You don't need these, unless you link statically,
172 which is highly discouraged.
173
174 %package devel-utils
175 Summary:        Development utilities from GNU C library
176 License:        LGPL-2.1+
177 Requires:       glibc = %{version}
178
179 %description devel-utils
180 The glibc-devel-utils package contains various binaries which can be helpful during program
181 debugging.
182
183 If you are unsure if you need this, don't install this package.
184
185 %package extra
186 Summary:        Extra binaries from GNU C Library
187 License:        LGPL-2.1+
188 Requires:       glibc = %{version}
189
190 %description extra
191 The glibc-extra package contains some extra binaries for glibc that
192 are not essential but recommend to use.
193
194 makedb: A program to create a database for nss
195
196 %package obsolete
197 Summary:        Obsolete Shared Libraries from the GNU C Library
198 License:        LGPL-2.0+
199 Requires:       glibc = %{version}
200
201 %description obsolete
202 This package provides some old libraries from the GNU C Library which
203 are no longer supported. Additional it provides a compatibility library
204 for old binaries linked against glibc 2.0.
205
206 Install this package if you need one of this libraries to get old
207 binaries working, but since this libraries are not supported and there
208 is no gurantee that they work for you, you should try to get newer
209 versions of your software.
210
211 %package testresults
212 Summary:       Testsuite results
213 License:       LGPL-2.1+
214 Group:         Development/Languages
215 %description testresults
216 Results from running the glibc testsuites.
217
218 %{?asan:
219 %ifarch %asan_arch
220 %package asan
221 Summary:     glibc with ASan instrumentation
222 License:     LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
223 Requires:    glibc = %{version}
224
225 %description asan
226 This package provides glibc with ASan instrumentation
227
228 %post asan
229 ln -s --force /%{_lib}/libc-2.24-asan.so /%{_lib}/libc.so.6
230
231 %preun asan
232 ln -s --force /%{_lib}/libc-2.24.so /%{_lib}/libc.so.6
233
234 %endif
235 }
236
237 %prep
238 %setup -n glibc-%{version} -q 
239 cp %{SOURCE1001} .
240
241 %build
242 %{?asan:%gcc_unforce_options}
243 if [ -x /bin/uname.bin ]; then
244         /bin/uname.bin -a
245 else
246         uname -a
247 fi
248 uptime || :
249 ulimit -a
250 nice
251 # We do not want configure to figure out the system its building one
252 # to support a common ground and thus set build and host to the
253 # target_cpu.
254 %ifarch %arm
255 %define target %{_target_cpu}-tizen-linux-gnueabi
256 %else
257 %define target %{_target_cpu}-tizen-linux
258 %endif
259 # Don't use as-needed, it breaks glibc assumptions
260 # Before enabling it, run the testsuite and verify that it
261 # passes completely
262 export LD_AS_NEEDED=0
263 # Adjust glibc version.h
264 echo "#define CONFHOST \"%{target}\"" >> version.h
265 echo "#define GITID \"%{git_id}\"" >> version.h
266 #
267 # Default CFLAGS and Compiler
268 #
269 BuildFlags=$(echo %{optflags} | sed -e "s/-Wp,-D_FORTIFY_SOURCE=2//g" | sed -e "s/-ffast-math//" | sed -e "s/atom/i686/g" | sed -e "s/-fexceptions//" | sed -e "s/-fno-omit-frame-pointer//" )
270 BuildFlags="$BuildFlags -O2 -g -U_FORTIFY_SOURCE"
271 BuildFlags="$(echo $BuildFlags | sed -e 's#-fstack-protector##' -e 's#-ffortify=[0-9]*##')"
272 BuildFlags="$(echo $BuildFlags | sed -e 's/-Wa,-mimplicit-it=thumb//g' | sed -e 's/-mthumb//g')"
273 # Turn off all -Wformat enable flags as there are glibc tests that explicitly
274 # append -Wno-format and with enabled Wformat options that produced warnings
275 # that turns into errors. Remove -Wformat=1|2 or -Wformat-..-arg
276 BuildFlags="$(echo $BuildFlags | sed -re 's/-Wformat((=[1-2])|((-\w+)+))?(\s|$)//g')"
277
278 BuildCC="%__cc"
279 BuildCCplus="%__cxx"
280 add_ons=",libidn"
281
282 BuildFlags="$BuildFlags -g"
283 %if %{disable_assert}
284         BuildFlags="$BuildFlags -DNDEBUG=1"
285 %endif
286 %ifarch %ix86
287         add_ons=$add_ons
288 %endif
289 %ifarch %arm aarch64
290         add_ons=$add_ons
291 %endif
292 %ifarch mipsel
293         # fails to build otherwise - need to recheck and fix
294         %define enable_stackguard_randomization 0
295 %endif
296
297 configure_and_build_glibc() {
298         local dirname="$1"; shift
299         local cflags="$1"; shift
300         local addons="$1"; shift
301         mkdir "cc-$dirname"
302         cd "cc-$dirname"
303         conf_cflags="$cflags -funwind-tables -fPIC"
304         %{?asan: conf_cflags="$conf_cflags -DASAN_INIT_FIRST "}
305
306         profile="--disable-profile"
307 %if %{build_profile}
308         if [ "$dirname" = "base" ] ; then
309             profile="--enable-profile"
310         fi
311 %endif
312         CFLAGS="$conf_cflags" BUILD_CFLAGS="$conf_cflags" \
313         CC="$BuildCC" CXX="$BuildCCplus"  ../configure \
314                 --prefix=%{_prefix} \
315                 --libexecdir=%{_libexecdir} --infodir=%{_infodir} \
316                 --enable-add-ons=$addons \
317                 $profile \
318                 "$@" \
319 %if %{enable_stackguard_randomization}
320                 --enable-stackguard-randomization \
321 %endif
322                 --build=%{target} --host=%{target} \
323 %ifnarch %{multiarcharches}
324                 --disable-multi-arch \
325 %endif
326 %ifarch %{ix86} x86_64 
327                 --disable-mathvec \
328 %endif
329                 --enable-kernel=%{enablekernel} \
330                 --enable-bind-now  --enable-obsolete-rpc \
331                 --disable-nscd \
332                 --disable-experimental-malloc \
333                 libc_cv_pie_default=yes
334         # explicitly set CFLAGS to use the full CFLAGS (not the reduced one for configure)
335         make %{?_smp_mflags} #CFLAGS="$cflags" BUILD_CFLAGS="$cflags"
336         cd ..
337 }
338
339 configure_flags="--prefix=/usr --without-cvs --without-selinux --enable-stackguard-randomization --enable-obsolete-rpc --disable-mathvec"
340
341 configure_flags="$configure_flags --disable-sanity-checks"
342
343 build_asan() {
344   HERE=%{_builddir}/%{name}-%{version}
345   J=${J:-32}
346   GLIBC=$HERE
347   ASAN_BUILD=$HERE/asan-build
348   unset CXXFLAGS
349   unset CFLAGS
350   unset LDFLAGS
351   #chmod +x $HERE/asan-glibc-gcc-wrapper.py
352   #build static wrapper, because we don't want asan to intercept allocators
353   g++ -o gcc-wrapper gcc-wrapper.cc -O3 -funroll-loops -fno-unwind-tables -fno-asynchronous-unwind-tables -fno-exceptions -static
354
355   rm -rf $ASAN_BUILD
356   mkdir -p $ASAN_BUILD
357   cd $ASAN_BUILD
358 #  CC=$HERE/asan-glibc-gcc-wrapper.py $GLIBC/configure $configure_flags
359   CC=$HERE/gcc-wrapper $GLIBC/configure $configure_flags
360
361   # Quick build - builds only libraries, but does not create symlinks.
362   make -r -j $J -C $GLIBC objdir=`pwd` subdir_lib
363   #make -r -j $J -C $GLIBC objdir=`pwd` install_root=$ASAN_INST install-lib
364   cd $HERE
365 }
366
367         #
368         # Build base glibc
369         #
370         configure_and_build_glibc base "$BuildFlags" "$add_ons"
371
372 %{?asan:
373 %ifarch %{asan_arch}
374 build_asan
375 %endif
376 }
377 #
378 # Build html documentation
379 #
380 %if %{build_html}
381 make -C cc-base html
382 %endif
383
384 #
385 # Build glibc_post_upgrade binary
386 #
387 $BuildCC -static %{optflags} -Os $RPM_SOURCE_DIR/glibc_post_upgrade.c -o glibc_post_upgrade \
388      -Lcc-base -Bcc-base/csu \
389     '-DREMOVE_TLS_DIRS' '-DREMOVE_PPC_OPTIMIZE_POWER5' \
390     '-DLIBDIR="/%{_lib}"' '-DGCONV_MODULES_DIR="%{_libdir}/gconv"'
391
392 #
393 # Build testsuite
394 #
395 # #check sections could be redefined/disabled, so keep this inside #build
396
397 %{?glibc_run_tests:
398   export LD_AS_NEEDED=0
399   (make %{?_smp_mflags} -C cc-base check || true) 2>&1 | tee check.log
400 }
401
402
403 #######################################################################
404 ###
405 ### CHECK
406 ###
407 #######################################################################
408
409 %check
410 # The testsuite will fail if asneeded is used
411 export LD_AS_NEEDED=0
412 # This has to pass on all platforms!
413 # Exceptions:
414 # None!
415 make %{?_smp_mflags} -C cc-base check-abi
416
417 #######################################################################
418 ###
419 ### INSTALL
420 ###
421 #######################################################################
422
423 %install
424 # We don't want to strip the .symtab from our libraries in find-debuginfo.sh,
425 # certainly not from libpthread.so.* because it is used by libthread_db to find
426 # some non-exported symbols in order to detect if threading support
427 # should be enabled.  These symbols are _not_ exported, and we can't easily
428 # export them retroactively without changing the ABI.  So we have to
429 # continue to "export" them via .symtab, instead of .dynsym :-(
430 # But we also want to keep .symtab and .strtab of other libraries since some
431 # debugging tools currently require these sections directly inside the main
432 # files - specifically valgrind and PurifyPlus.
433 export STRIP_KEEP_SYMTAB=*.so*
434
435 # Make sure we will create the gconv-modules.cache
436 mkdir -p %{buildroot}%{_libdir}/gconv
437 touch %{buildroot}%{_libdir}/gconv/gconv-modules.cache
438
439 # Install base glibc
440 make %{?_smp_mflags} install_root=%{buildroot} install -C cc-base
441
442 install_optimized_variant() {
443         local dirname="$1"; shift
444         local subdir="$1"; shift
445         local subdir_up="$1"; shift
446
447 cd "cc-$dirname"
448 destdir=$RPM_BUILD_ROOT/%{_lib}/$subdir
449 mkdir -p $destdir
450 # Don't run a complete make install, we know which libraries
451 # we want
452 for lib in libc math/libm nptl/libpthread rt/librt nptl_db/libthread_db
453 do
454   libbase=${lib#*/}
455   libbaseso=$(basename $RPM_BUILD_ROOT/%{_lib}/${libbase}-*.so)
456   # Only install if different from base lib
457   if cmp -s ${lib}.so ../cc-base/${lib}.so; then
458     ln -sf $subdir_up/$libbaseso $destdir/$libbaseso
459   else
460     cp -a ${lib}.so $destdir/$libbaseso
461   fi
462   # Emulate ldconfig
463   ln -sf $libbaseso $destdir/$(basename $RPM_BUILD_ROOT/%{_lib}/${libbase}.so.*)
464 done
465 cd ..
466 }
467
468
469 # Install locales
470 %if %{build_locales}
471         # XXX Do not install locales in parallel!
472         cd cc-base
473         # localedef creates hardlinks to other locales if possible
474         # this will not work if we generate them in parallel.
475         # thus we need to run fdupes on  /usr/lib/locale/
476         # Still, on my system this is a speed advantage:
477         # non-parallel build for install-locales: 9:34mins
478         # parallel build with fdupes: 7:08mins
479         make %{?_smp_mflags} install_root=%{buildroot} localedata/install-locales
480         %fdupes %{buildroot}/usr/lib/locale
481         cd ..
482 %endif
483 # Create file list for glibc-locale package
484 %{find_lang} libc
485
486 # Prepare obsolete/, used only on some architectures:
487 export RPM_BUILD_ROOT
488 %ifarch %ix86
489 mkdir -p %{buildroot}/%{_lib}/obsolete
490 %endif
491
492 # NPTL <bits/stdio-lock.h> is not usable outside of glibc, so include
493 # the generic one (RH#162634)
494 # cp -av bits/stdio-lock.h %{buildroot}%{_includedir}/bits/stdio-lock.h
495
496
497 # Miscelanna:
498
499 install -m 0700 glibc_post_upgrade %{buildroot}%{_sbindir}
500
501 install -m 644 %{SOURCE7} %{buildroot}/etc
502 install -m 644 %{SOURCE5} %{buildroot}/etc
503 install -m 644 posix/gai.conf %{buildroot}/etc
504
505 mkdir -p %{buildroot}/etc/default
506 install -m 644 nis/nss %{buildroot}/etc/default/
507
508 mkdir -p %{buildroot}%{_includedir}/resolv
509 install -m 0644 resolv/mapv4v6addr.h %{buildroot}%{_includedir}/resolv/
510 install -m 0644 resolv/mapv4v6hostent.h %{buildroot}%{_includedir}/resolv/
511
512 %if %{build_html}
513 mkdir -p %{buildroot}%{_datadir}/doc/glibc
514 cp -p cc-base/manual/libc/*.html %{buildroot}%{_datadir}/doc/glibc
515 %endif
516
517
518 #
519 # Create ld.so.conf
520 #
521 cat > %{buildroot}/etc/ld.so.conf <<EOF
522 %if "%{_lib}" == "lib64"
523 /usr/local/lib64
524 %endif
525 /usr/local/lib
526 include /etc/ld.so.conf.d/*.conf
527 # /lib64, /lib, /usr/lib64 and /usr/lib gets added
528 # automatically by ldconfig after parsing this file.
529 # So, they do not need to be listed.
530 EOF
531 # Add ldconfig cache directory for directory ownership
532 mkdir -p %{buildroot}/var/cache/ldconfig
533 # Empty the ld.so.cache:
534 rm -f %{buildroot}/etc/ld.so.cache
535 touch %{buildroot}/etc/ld.so.cache
536
537 # Don't look at ldd! We don't wish a /bin/sh requires
538 chmod 644 %{buildroot}%{_bindir}/ldd
539
540 # Remove timezone data, now coming in standalone package:
541 for i in sbin/sln usr/bin/tzselect usr/sbin/zic usr/sbin/zdump etc/localtime; do
542         rm -f %{buildroot}/$i
543 done
544 rm -rf %{buildroot}%{_datadir}/zoneinfo
545
546 %ifarch armv7hl
547 # Provide compatibility link
548 ln -s ld-%{glibc_major_version}.so %{buildroot}/lib/ld-linux.so.3
549 %endif
550
551 # Move getconf to %{_libexecdir}/getconf/ to avoid cross device link
552 mv %{buildroot}%{_bindir}/getconf %{buildroot}%{_libexecdir}/getconf/getconf
553 ln -s %{_libexecdir}/getconf/getconf %{buildroot}%{_bindir}/getconf
554
555 #######################################################################
556 ###
557 ### ...
558 ###
559 #######################################################################
560
561 %{?asan:
562 %ifarch %{asan_arch}
563 HERE=%{_builddir}/%{name}-%{version}
564 GLIBC=$HERE
565 ASAN_BUILD=$HERE/asan-build
566 cp $ASAN_BUILD/libc.so %{buildroot}/%{_lib}/libc-2.24-asan.so
567 %endif
568 }
569
570 %{?glibc_run_tests:
571   mkdir testresults
572   cp --parents $(find cc-base -name "*tests.sum") testresults/
573   cp check.log testresults/
574   chmod 644 $(find testresults/ -type f)
575 }
576
577 %post -p %{_sbindir}/glibc_post_upgrade
578
579 %postun -p /sbin/ldconfig
580
581 %post locale
582 for l in /usr/share/locale/locale.alias %{_libdir}/gconv/gconv-modules; do
583         [ -d "$l.d" ] || continue
584         echo "###X# The following is autogenerated from extra files in the .d directory:" >>"$l"
585         cat "$l.d"/* >>"$l"
586 done
587 /usr/sbin/iconvconfig
588
589 %post info
590 %install_info --info-dir=%{_infodir} %{_infodir}/libc.info.gz
591
592 %postun info
593 %install_info_delete --info-dir=%{_infodir} %{_infodir}/libc.info.gz
594
595 %files
596 %manifest %{name}.manifest
597 # glibc
598 %defattr(-,root,root)
599 %license LICENSES COPYING COPYING.LIB
600 %config(noreplace) /etc/bindresvport.blacklist
601 %config /etc/ld.so.conf
602 %attr(0644,root,root) %verify(not md5 size mtime) %ghost %config(missingok,noreplace) /etc/ld.so.cache
603 %config(noreplace) /etc/rpc
604 %verify(not md5 size mtime) %config(noreplace) /etc/nsswitch.conf
605 %verify(not md5 size mtime) %config(noreplace) /etc/gai.conf
606 %config(noreplace) /etc/default/nss
607 /%{_lib}/ld-%{glibc_major_version}.so
608
609 # Each architecture has a different name for the dynamic linker:
610 %ifarch %arm
611 %ifarch armv7hl
612 /%{_lib}/ld-linux-armhf.so.3
613 # Keep compatibility link
614 /%{_lib}/ld-linux.so.3
615 %else
616 /%{_lib}/ld-linux.so.3
617 %endif
618 %endif
619 %ifarch x86_64
620 /%{_lib}/ld-linux-x86-64.so.2
621 %endif
622 %ifarch %ix86 %sparc
623 /%{_lib}/ld-linux.so.2
624 %endif
625 %ifarch aarch64
626 /lib/ld-linux-aarch64.so.1
627 /%{_lib}/ld-linux-aarch64.so.1
628 %endif
629
630 /%{_lib}/libanl-%{glibc_major_version}.so
631 /%{_lib}/libanl.so.1
632 /%{_lib}/libc-%{glibc_major_version}.so
633 /%{_lib}/libc.so.6*
634 /%{_lib}/libcrypt-%{glibc_major_version}.so
635 /%{_lib}/libcrypt.so.1
636 /%{_lib}/libdl-%{glibc_major_version}.so
637 /%{_lib}/libdl.so.2*
638 /%{_lib}/libm-%{glibc_major_version}.so
639 /%{_lib}/libm.so.6*
640 /%{_lib}/libnsl-%{glibc_major_version}.so
641 /%{_lib}/libnsl.so.1
642 /%{_lib}/libnss_compat-%{glibc_major_version}.so
643 /%{_lib}/libnss_compat.so.2
644 /%{_lib}/libnss_db-%{glibc_major_version}.so
645 /%{_lib}/libnss_db.so.2
646 /%{_lib}/libnss_dns-%{glibc_major_version}.so
647 /%{_lib}/libnss_dns.so.2
648 /%{_lib}/libnss_files-%{glibc_major_version}.so
649 /%{_lib}/libnss_files.so.2
650 /%{_lib}/libnss_optfiles-%{glibc_major_version}.so
651 /%{_lib}/libnss_optfiles.so.2
652 /%{_lib}/libnss_hesiod-%{glibc_major_version}.so
653 /%{_lib}/libnss_hesiod.so.2
654 /%{_lib}/libpthread-%{glibc_major_version}.so
655 /%{_lib}/libpthread.so.0
656 /%{_lib}/libthread_db-1.0.so
657 /%{_lib}/libthread_db.so.1
658 /%{_lib}/libresolv-%{glibc_major_version}.so
659 /%{_lib}/libresolv.so.2
660 /%{_lib}/librt-%{glibc_major_version}.so
661 /%{_lib}/librt.so.1
662 /%{_lib}/libutil-%{glibc_major_version}.so
663 /%{_lib}/libutil.so.1
664 %define optimized_libs() \
665         %dir %attr(0755,root,root) /%{_lib}/%1\
666         /%{_lib}/%1/libc-%{glibc_major_version}.so\
667         /%{_lib}/%1/libc.so.6*\
668         /%{_lib}/%1/libm-%{glibc_major_version}.so\
669         /%{_lib}/%1/libm.so.6*\
670         /%{_lib}/%1/libpthread-%{glibc_major_version}.so\
671         /%{_lib}/%1/libpthread.so.0\
672         /%{_lib}/%1/librt-%{glibc_major_version}.so\
673         /%{_lib}/%1/librt.so.1\
674         /%{_lib}/%1/libthread_db-1.0.so\
675         /%{_lib}/%1/libthread_db.so.1
676
677 %dir %attr(0700,root,root) /var/cache/ldconfig
678 /sbin/ldconfig
679 %{_bindir}/gencat
680 %{_bindir}/getconf
681 %{_bindir}/getent
682 %{_bindir}/iconv
683 %attr(755,root,root) %{_bindir}/ldd
684 %ifarch %ix86 sparc sparcv9
685         %{_bindir}/lddlibc4
686 %endif
687 %{_bindir}/locale
688 %{_bindir}/localedef
689 %dir %attr(0755,root,root) %{_libexecdir}/getconf
690 %{_libexecdir}/getconf/*
691 %{_sbindir}/glibc_post_upgrade
692 %{_sbindir}/iconvconfig
693 /%{_lib}/libBrokenLocale-%{glibc_major_version}.so
694 /%{_lib}/libBrokenLocale.so.1
695
696 %ifarch %ix86
697
698 %files obsolete
699 %manifest %{name}.manifest
700 %license COPYING.LIB
701 %defattr (755,root,root,755)
702 %dir /%{_lib}/obsolete/
703         #%dir /%{_lib}/obsolete/noversion
704         #/%{_lib}/obsolete/noversion/libNoVersion-%{glibc_major_version}.so
705         #/%{_lib}/obsolete/noversion/libNoVersion.so.1
706 %endif
707
708 %files locale -f libc.lang
709 %manifest %{name}.manifest
710 %license COPYING COPYING.LIB
711 %defattr(-,root,root)
712 %{_datadir}/locale/locale.alias
713 %if %{build_locales}
714 /usr/lib/locale/*
715 %endif
716 %{_libdir}/gconv
717
718 %{?asan:
719 %ifarch %{asan_arch}
720 %files asan
721 %manifest %{name}.manifest
722 /%{_lib}/libc-2.24-asan.so
723 %endif
724 }
725
726 %files devel
727 %manifest %{name}.manifest
728 %defattr(-,root,root)
729 %license COPYING COPYING.LIB 
730 %doc NEWS README
731 %{_bindir}/rpcgen
732 %{_includedir}/*
733 %{_libdir}/*.o
734 %{_libdir}/*.so
735 # These static libraries are needed even for shared builds
736 %{_libdir}/libc_nonshared.a
737 %{_libdir}/libg.a
738 %ifarch ppc ppc64 s390 s390x sparc sparcv8 sparcv9 sparcv9v
739 # This is not built on sparc64.
740         %{_libdir}/libnldbl_nonshared.a
741 %endif
742 %{_libdir}/libmcheck.a
743 %{_libdir}/librpcsvc.a
744
745 %files devel-static
746 %manifest %{name}.manifest
747 %defattr(-,root,root)
748 %{_libdir}/libBrokenLocale.a
749 %{_libdir}/libanl.a
750 %{_libdir}/libc.a
751 %{_libdir}/libcrypt.a
752 %{_libdir}/libdl.a
753 %{_libdir}/libm.a
754 %{_libdir}/libpthread.a
755 %{_libdir}/libresolv.a
756 %{_libdir}/librt.a
757 %{_libdir}/libutil.a
758
759 %files info
760 %manifest %{name}.manifest
761 %defattr(-,root,root)
762 %doc %{_infodir}/libc.info.gz
763 %doc %{_infodir}/libc.info-?.gz
764 %doc %{_infodir}/libc.info-??.gz
765
766 %if %{build_html}
767 %files html
768 %manifest %{name}.manifest
769 %defattr(-,root,root)
770 %doc %{_prefix}/share/doc/glibc
771 %endif
772
773 %files i18ndata
774 %manifest %{name}.manifest
775 %defattr(-,root,root)
776 %{_prefix}/share/i18n
777
778 %if %{build_profile}
779 %files profile
780 %manifest %{name}.manifest
781 %license COPYING COPYING.LIB
782 %defattr(-,root,root)
783 %{_libdir}/libc_p.a
784 %{_libdir}/libBrokenLocale_p.a
785 %{_libdir}/libanl_p.a
786 %{_libdir}/libm_p.a
787 %{_libdir}/libcrypt_p.a
788 %{_libdir}/libpthread_p.a
789 %{_libdir}/libresolv_p.a
790 %{_libdir}/librt_p.a
791 %{_libdir}/librpcsvc_p.a
792 %{_libdir}/libutil_p.a
793 %{_libdir}/libdl_p.a
794 %endif
795
796 %files devel-utils
797 %manifest %{name}.manifest
798 %defattr(-,root,root)
799 /%{_lib}/libmemusage.so
800 /%{_lib}/libpcprofile.so
801 /%{_libdir}/libBrokenLocale.so
802 /%{_lib}/libSegFault.so
803 /%{_lib}/libthread_db-1.0.so
804 /%{_lib}/libthread_db.so.1
805 /%{_libdir}/libthread_db.so
806 %dir /%{_libdir}/audit
807 /%{_libdir}/audit/sotruss-lib.so
808 # These need gd-devel for building
809 # %%{_bindir}/memusage
810 # %%{_bindir}/memusagestat
811 %{_bindir}/mtrace
812 %{_bindir}/pcprofiledump
813 %{_bindir}/sotruss
814 %{_bindir}/xtrace
815 %{_bindir}/pldd
816 %{_bindir}/catchsegv
817 %{_bindir}/sprof
818
819 %files extra
820 %manifest %{name}.manifest
821 %license COPYING.LIB
822 %defattr(-,root,root)
823 %{_bindir}/makedb
824 /var/db/Makefile
825
826 %{?glibc_run_tests:
827 %files testresults
828 %defattr(-,root,root)
829 %doc testresults/check.log
830 %doc testresults/*
831 }
832
833 %docs_package