packaging: Switch off ASan
[platform/upstream/glibc.git] / packaging / glibc.spec
1 #
2 # spec file for package glibc
3 #
4 # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14
15 # This will avoid building some parts of glibc
16 %bcond_with    fast_build
17
18 Name:           glibc
19 Summary:        Standard Shared Libraries (from the GNU C Library)
20 License:        LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
21 Group:          Base/Libraries
22 BuildRequires:  fdupes
23 BuildRequires:  makeinfo
24 BuildRequires:  xz
25 BuildRequires:  gcc-c++
26 BuildRequires:  gettext-tools
27 BuildRequires:  libstdc++-devel
28 #BuildRequires:  pkgconfig(systemd)
29
30 %define _filter_GLIBC_PRIVATE 1
31 %if %_target_cpu == "i686"
32 # For i686 let's only build what's different from i586, so
33 # no need to build documentation
34 %define build_profile 1
35 %define build_locales 0
36 %define build_html 0
37 %else
38 %if %{with fast_build}
39 %define build_profile 0
40 %define build_locales 0
41 %define build_html 0
42 %else
43 # Default:
44 %define build_profile 1
45 %define build_locales 0
46 %define build_html 1
47 %endif
48 %endif
49
50 %define disable_assert 0
51 %define enable_stackguard_randomization 1
52 %define multiarcharches %{ix86} x86_64
53
54 %ifarch x86_64
55 %define enablekernel 2.6.16
56 %else
57 %define enablekernel 2.6.16
58 %endif
59 Conflicts:      kernel < %{enablekernel}
60 %ifarch armv7l armv7hl
61 # The old runtime linker link gets not provided by rpm find.provides, but it exists
62 Provides:       ld-linux.so.3
63 Provides:       ld-linux.so.3(GLIBC_2.4)
64 %endif
65 Version:        2.24
66 Release:        0
67 %define glibc_major_version 2.24
68 %define git_id 4e42b5b8f89f
69
70 Url:            http://www.gnu.org/software/libc/libc.html
71 Source:         glibc-%{version}.tar.xz
72 Source5:        nsswitch.conf
73 Source7:        bindresvport.blacklist
74 Source8:        glibc_post_upgrade.c
75 Source9:        glibc.rpmlintrc
76 Source10:       baselibs.conf
77 # For systemd 
78 Source1001:     glibc.manifest
79
80 Requires(pre):  filesystem
81 Provides:       rtld(GNU_HASH)
82
83 %description
84 The GNU C Library provides the most important standard libraries used
85 by nearly all programs: the standard C library, the standard math
86 library, and the POSIX thread library. A system is not functional
87 without these libraries.
88
89 %package info
90 Summary:        Info Files for the GNU C Library
91 License:        GFDL-1.1
92 Group:          Documentation
93 BuildArch:      noarch
94
95 %description info
96 This package contains the documentation for the GNU C library stored as
97 info files. Due to a lack of resources, this documentation is not
98 complete and is partially out of date.
99
100 %package html
101 Summary:        HTML Documentation for the GNU C Library
102 License:        GFDL-1.1
103 Group:          Documentation
104 BuildArch:      noarch
105
106 %description html
107 This package contains the HTML documentation for the GNU C library. Due
108 to a lack of resources, this documentation is not complete and is
109 partially out of date.
110
111 %package i18ndata
112 Summary:        Database Sources for 'locale'
113 License:        GPL-2.0+ and MIT
114 Group:          Base/Libraries
115 BuildArch:      noarch
116
117 %description i18ndata
118 This package contains the data needed to build the locale data files to
119 use the internationalization features of the GNU libc. It is normally
120 not necessary to install this packages, the data files are already
121 created.
122
123 %package locale
124 Summary:        Locale Data for Localized Programs
125 License:        GPL-2.0+ and MIT and LGPL-2.1+
126 Requires(post): /usr/bin/cat
127 Requires:       glibc = %{version}
128 %description locale
129 Locale data for the internationalisation features of the GNU C library.
130
131 %package profile
132 Summary:        Libc Profiling and Debugging Versions
133 License:        LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
134 Group:          Base/Utilities
135 Requires:       glibc = %{version}
136
137 %description profile
138 This package contains special versions of the GNU C library which are
139 necessary for profiling and debugging.
140
141 %package devel
142 Summary:        Include Files and Libraries Mandatory for Development
143 License:        BSD-3-Clause and LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
144 Requires:       glibc = %{version}
145 Requires:       linux-kernel-headers
146
147 %description devel
148 These libraries are needed to develop programs which use the standard C
149 library.
150
151 %package devel-static
152 Summary:        C library static libraries for -static linking
153 License:        BSD-3-Clause and LGPL-2.1+ and LGPL-2.1+-with-GCC-exception and GPL-2.0+
154 Requires:       %{name}-devel = %{version}
155 # Provide Fedora name for package to make packaging easier
156 Provides:       %{name}-static = %version
157
158 %description devel-static
159 The glibc-devel-static package contains the C library static libraries
160 for -static linking.  You don't need these, unless you link statically,
161 which is highly discouraged.
162
163 %package devel-utils
164 Summary:        Development utilities from GNU C library
165 License:        LGPL-2.1+
166 Requires:       glibc = %{version}
167
168 %description devel-utils
169 The glibc-devel-utils package contains various binaries which can be helpful during program
170 debugging.
171
172 If you are unsure if you need this, don't install this package.
173
174 %package extra
175 Summary:        Extra binaries from GNU C Library
176 License:        LGPL-2.1+
177 Requires:       glibc = %{version}
178
179 %description extra
180 The glibc-extra package contains some extra binaries for glibc that
181 are not essential but recommend to use.
182
183 makedb: A program to create a database for nss
184
185 %package obsolete
186 Summary:        Obsolete Shared Libraries from the GNU C Library
187 License:        LGPL-2.0+
188 Requires:       glibc = %{version}
189
190 %description obsolete
191 This package provides some old libraries from the GNU C Library which
192 are no longer supported. Additional it provides a compatibility library
193 for old binaries linked against glibc 2.0.
194
195 Install this package if you need one of this libraries to get old
196 binaries working, but since this libraries are not supported and there
197 is no gurantee that they work for you, you should try to get newer
198 versions of your software.
199
200 %prep
201 %setup -n glibc-%{version} -q 
202 cp %{SOURCE1001} .
203
204 %build
205 %{?asan:%gcc_unforce_options}
206 if [ -x /bin/uname.bin ]; then
207         /bin/uname.bin -a
208 else
209         uname -a
210 fi
211 uptime || :
212 ulimit -a
213 nice
214 # We do not want configure to figure out the system its building one
215 # to support a common ground and thus set build and host to the
216 # target_cpu.
217 %ifarch %arm
218 %define target %{_target_cpu}-tizen-linux-gnueabi
219 %else
220 %define target %{_target_cpu}-tizen-linux
221 %endif
222 # Don't use as-needed, it breaks glibc assumptions
223 # Before enabling it, run the testsuite and verify that it
224 # passes completely
225 export LD_AS_NEEDED=0
226 # Adjust glibc version.h
227 echo "#define CONFHOST \"%{target}\"" >> version.h
228 echo "#define GITID \"%{git_id}\"" >> version.h
229 #
230 # Default CFLAGS and Compiler
231 #
232 BuildFlags=$(echo %{optflags} | sed -e "s/-Wp,-D_FORTIFY_SOURCE=2//g" | sed -e "s/-ffast-math//" | sed -e "s/atom/i686/g" | sed -e "s/-fexceptions//" | sed -e "s/-fno-omit-frame-pointer//" )
233 BuildFlags="$BuildFlags -O2 -g -U_FORTIFY_SOURCE"
234 BuildFlags="$(echo $BuildFlags | sed -e 's#-fstack-protector##' -e 's#-ffortify=[0-9]*##')"
235 BuildFlags="$(echo $BuildFlags | sed -e 's/-Wa,-mimplicit-it=thumb//g' | sed -e 's/-mthumb//g')"
236 BuildCC="%__cc"
237 BuildCCplus="%__cxx"
238 add_ons=",libidn"
239
240
241 BuildFlags="$BuildFlags -g"
242 %if %{disable_assert}
243         BuildFlags="$BuildFlags -DNDEBUG=1"
244 %endif
245 %ifarch %ix86
246         add_ons=$add_ons
247 %endif
248 %ifarch %arm aarch64
249         add_ons=$add_ons
250 %endif
251 %ifarch mipsel
252         # fails to build otherwise - need to recheck and fix
253         %define enable_stackguard_randomization 0
254 %endif
255
256 configure_and_build_glibc() {
257         local dirname="$1"; shift
258         local cflags="$1"; shift
259         local addons="$1"; shift
260         mkdir "cc-$dirname"
261         cd "cc-$dirname"
262         conf_cflags="$cflags -funwind-tables"
263
264         profile="--disable-profile"
265 %if %{build_profile}
266         if [ "$dirname" = "base" ] ; then
267             profile="--enable-profile"
268         fi
269 %endif
270         CFLAGS="$conf_cflags" BUILD_CFLAGS="$conf_cflags" \
271         CC="$BuildCC" CXX="$BuildCCplus"  ../configure \
272                 --prefix=%{_prefix} \
273                 --libexecdir=%{_libexecdir} --infodir=%{_infodir} \
274                 --enable-add-ons=$addons \
275                 $profile \
276                 "$@" \
277 %if %{enable_stackguard_randomization}
278                 --enable-stackguard-randomization \
279 %endif
280                 --build=%{target} --host=%{target} \
281 %ifnarch %{multiarcharches}
282                 --disable-multi-arch \
283 %endif
284 %ifarch %{ix86} x86_64 
285                 --disable-mathvec \
286 %endif
287                 --enable-kernel=%{enablekernel} \
288                 --enable-bind-now  --enable-obsolete-rpc \
289                 --disable-nscd
290         # explicitly set CFLAGS to use the full CFLAGS (not the reduced one for configure)
291         make %{?_smp_mflags} #CFLAGS="$cflags" BUILD_CFLAGS="$cflags"
292         cd ..
293 }
294
295         #
296         # Build base glibc
297         #
298         configure_and_build_glibc base "$BuildFlags" "$add_ons"
299
300 #
301 # Build html documentation
302 #
303 %if %{build_html}
304 make -C cc-base html
305 %endif
306
307 #
308 # Build glibc_post_upgrade binary
309 #
310 $BuildCC -static %{optflags} -Os $RPM_SOURCE_DIR/glibc_post_upgrade.c -o glibc_post_upgrade \
311      -Lcc-base -Bcc-base/csu \
312     '-DREMOVE_TLS_DIRS' '-DREMOVE_PPC_OPTIMIZE_POWER5' \
313     '-DLIBDIR="/%{_lib}"' '-DGCONV_MODULES_DIR="%{_libdir}/gconv"'
314
315
316 #######################################################################
317 ###
318 ### CHECK
319 ###
320 #######################################################################
321
322 %check
323 # The testsuite will fail if asneeded is used
324 export LD_AS_NEEDED=0
325 # This has to pass on all platforms!
326 # Exceptions:
327 # None!
328 make %{?_smp_mflags} -C cc-base check-abi
329
330 #######################################################################
331 ###
332 ### INSTALL
333 ###
334 #######################################################################
335
336 %install
337 # We don't want to strip the .symtab from our libraries in find-debuginfo.sh,
338 # certainly not from libpthread.so.* because it is used by libthread_db to find
339 # some non-exported symbols in order to detect if threading support
340 # should be enabled.  These symbols are _not_ exported, and we can't easily
341 # export them retroactively without changing the ABI.  So we have to
342 # continue to "export" them via .symtab, instead of .dynsym :-(
343 # But we also want to keep .symtab and .strtab of other libraries since some
344 # debugging tools currently require these sections directly inside the main
345 # files - specifically valgrind and PurifyPlus.
346 export STRIP_KEEP_SYMTAB=*.so*
347
348 # Make sure we will create the gconv-modules.cache
349 mkdir -p %{buildroot}%{_libdir}/gconv
350 touch %{buildroot}%{_libdir}/gconv/gconv-modules.cache
351
352 # Install base glibc
353 make %{?_smp_mflags} install_root=%{buildroot} install -C cc-base
354
355 install_optimized_variant() {
356         local dirname="$1"; shift
357         local subdir="$1"; shift
358         local subdir_up="$1"; shift
359
360 cd "cc-$dirname"
361 destdir=$RPM_BUILD_ROOT/%{_lib}/$subdir
362 mkdir -p $destdir
363 # Don't run a complete make install, we know which libraries
364 # we want
365 for lib in libc math/libm nptl/libpthread rt/librt nptl_db/libthread_db
366 do
367   libbase=${lib#*/}
368   libbaseso=$(basename $RPM_BUILD_ROOT/%{_lib}/${libbase}-*.so)
369   # Only install if different from base lib
370   if cmp -s ${lib}.so ../cc-base/${lib}.so; then
371     ln -sf $subdir_up/$libbaseso $destdir/$libbaseso
372   else
373     cp -a ${lib}.so $destdir/$libbaseso
374   fi
375   # Emulate ldconfig
376   ln -sf $libbaseso $destdir/$(basename $RPM_BUILD_ROOT/%{_lib}/${libbase}.so.*)
377 done
378 cd ..
379 }
380
381
382 # Install locales
383 %if %{build_locales}
384         # XXX Do not install locales in parallel!
385         cd cc-base
386         # localedef creates hardlinks to other locales if possible
387         # this will not work if we generate them in parallel.
388         # thus we need to run fdupes on  /usr/lib/locale/
389         # Still, on my system this is a speed advantage:
390         # non-parallel build for install-locales: 9:34mins
391         # parallel build with fdupes: 7:08mins
392         make %{?_smp_mflags} install_root=%{buildroot} localedata/install-locales
393         %fdupes %{buildroot}/usr/lib/locale
394         cd ..
395 %endif
396 # Create file list for glibc-locale package
397 %{find_lang} libc
398
399 # Prepare obsolete/, used only on some architectures:
400 export RPM_BUILD_ROOT
401 %ifarch %ix86
402 mkdir -p %{buildroot}/%{_lib}/obsolete
403 %endif
404
405 # NPTL <bits/stdio-lock.h> is not usable outside of glibc, so include
406 # the generic one (RH#162634)
407 # cp -av bits/stdio-lock.h %{buildroot}%{_includedir}/bits/stdio-lock.h
408
409
410 # Miscelanna:
411
412 install -m 0700 glibc_post_upgrade %{buildroot}%{_sbindir}
413
414 install -m 644 %{SOURCE7} %{buildroot}/etc
415 install -m 644 %{SOURCE5} %{buildroot}/etc
416 install -m 644 posix/gai.conf %{buildroot}/etc
417
418 mkdir -p %{buildroot}/etc/default
419 install -m 644 nis/nss %{buildroot}/etc/default/
420
421 mkdir -p %{buildroot}%{_includedir}/resolv
422 install -m 0644 resolv/mapv4v6addr.h %{buildroot}%{_includedir}/resolv/
423 install -m 0644 resolv/mapv4v6hostent.h %{buildroot}%{_includedir}/resolv/
424
425 %if %{build_html}
426 mkdir -p %{buildroot}%{_datadir}/doc/glibc
427 cp -p cc-base/manual/libc/*.html %{buildroot}%{_datadir}/doc/glibc
428 %endif
429
430
431 #
432 # Create ld.so.conf
433 #
434 cat > %{buildroot}/etc/ld.so.conf <<EOF
435 %if "%{_lib}" == "lib64"
436 /usr/local/lib64
437 %endif
438 /usr/local/lib
439 include /etc/ld.so.conf.d/*.conf
440 # /lib64, /lib, /usr/lib64 and /usr/lib gets added
441 # automatically by ldconfig after parsing this file.
442 # So, they do not need to be listed.
443 EOF
444 # Add ldconfig cache directory for directory ownership
445 mkdir -p %{buildroot}/var/cache/ldconfig
446 # Empty the ld.so.cache:
447 rm -f %{buildroot}/etc/ld.so.cache
448 touch %{buildroot}/etc/ld.so.cache
449
450 # Don't look at ldd! We don't wish a /bin/sh requires
451 chmod 644 %{buildroot}%{_bindir}/ldd
452
453 # Remove timezone data, now coming in standalone package:
454 for i in sbin/sln usr/bin/tzselect usr/sbin/zic usr/sbin/zdump etc/localtime; do
455         rm -f %{buildroot}/$i
456 done
457 rm -rf %{buildroot}%{_datadir}/zoneinfo
458
459 %ifarch armv7hl
460 # Provide compatibility link
461 ln -s ld-%{glibc_major_version}.so %{buildroot}/lib/ld-linux.so.3
462 %endif
463
464 # Move getconf to %{_libexecdir}/getconf/ to avoid cross device link
465 mv %{buildroot}%{_bindir}/getconf %{buildroot}%{_libexecdir}/getconf/getconf
466 ln -s %{_libexecdir}/getconf/getconf %{buildroot}%{_bindir}/getconf
467
468 #######################################################################
469 ###
470 ### ...
471 ###
472 #######################################################################
473
474 %post -p %{_sbindir}/glibc_post_upgrade
475
476 %postun -p /sbin/ldconfig
477
478 %post locale
479 for l in /usr/share/locale/locale.alias %{_libdir}/gconv/gconv-modules; do
480         [ -d "$l.d" ] || continue
481         echo "###X# The following is autogenerated from extra files in the .d directory:" >>"$l"
482         cat "$l.d"/* >>"$l"
483 done
484 /usr/sbin/iconvconfig
485
486 %post info
487 %install_info --info-dir=%{_infodir} %{_infodir}/libc.info.gz
488
489 %postun info
490 %install_info_delete --info-dir=%{_infodir} %{_infodir}/libc.info.gz
491
492 %files
493 %manifest %{name}.manifest
494 # glibc
495 %defattr(-,root,root)
496 %license LICENSES COPYING COPYING.LIB
497 %config(noreplace) /etc/bindresvport.blacklist
498 %config /etc/ld.so.conf
499 %attr(0644,root,root) %verify(not md5 size mtime) %ghost %config(missingok,noreplace) /etc/ld.so.cache
500 %config(noreplace) /etc/rpc
501 %verify(not md5 size mtime) %config(noreplace) /etc/nsswitch.conf
502 %verify(not md5 size mtime) %config(noreplace) /etc/gai.conf
503 %config(noreplace) /etc/default/nss
504 /%{_lib}/ld-%{glibc_major_version}.so
505
506 # Each architecture has a different name for the dynamic linker:
507 %ifarch %arm
508 %ifarch armv7hl
509 /%{_lib}/ld-linux-armhf.so.3
510 # Keep compatibility link
511 /%{_lib}/ld-linux.so.3
512 %else
513 /%{_lib}/ld-linux.so.3
514 %endif
515 %endif
516 %ifarch x86_64
517 /%{_lib}/ld-linux-x86-64.so.2
518 %endif
519 %ifarch %ix86 %sparc
520 /%{_lib}/ld-linux.so.2
521 %endif
522 %ifarch aarch64
523 /lib/ld-linux-aarch64.so.1
524 /%{_lib}/ld-linux-aarch64.so.1
525 %endif
526
527 /%{_lib}/libanl-%{glibc_major_version}.so
528 /%{_lib}/libanl.so.1
529 /%{_lib}/libc-%{glibc_major_version}.so
530 /%{_lib}/libc.so.6*
531 /%{_lib}/libcidn-%{glibc_major_version}.so
532 /%{_lib}/libcidn.so.1
533 /%{_lib}/libcrypt-%{glibc_major_version}.so
534 /%{_lib}/libcrypt.so.1
535 /%{_lib}/libdl-%{glibc_major_version}.so
536 /%{_lib}/libdl.so.2*
537 /%{_lib}/libm-%{glibc_major_version}.so
538 /%{_lib}/libm.so.6*
539 /%{_lib}/libnsl-%{glibc_major_version}.so
540 /%{_lib}/libnsl.so.1
541 /%{_lib}/libnss_compat-%{glibc_major_version}.so
542 /%{_lib}/libnss_compat.so.2
543 /%{_lib}/libnss_db-%{glibc_major_version}.so
544 /%{_lib}/libnss_db.so.2
545 /%{_lib}/libnss_dns-%{glibc_major_version}.so
546 /%{_lib}/libnss_dns.so.2
547 /%{_lib}/libnss_files-%{glibc_major_version}.so
548 /%{_lib}/libnss_files.so.2
549 /%{_lib}/libnss_hesiod-%{glibc_major_version}.so
550 /%{_lib}/libnss_hesiod.so.2
551 /%{_lib}/libnss_nis-%{glibc_major_version}.so
552 /%{_lib}/libnss_nis.so.2
553 /%{_lib}/libnss_nisplus-%{glibc_major_version}.so
554 /%{_lib}/libnss_nisplus.so.2
555 /%{_lib}/libpthread-%{glibc_major_version}.so
556 /%{_lib}/libpthread.so.0
557 /%{_lib}/libthread_db-1.0.so
558 /%{_lib}/libthread_db.so.1
559 /%{_lib}/libresolv-%{glibc_major_version}.so
560 /%{_lib}/libresolv.so.2
561 /%{_lib}/librt-%{glibc_major_version}.so
562 /%{_lib}/librt.so.1
563 /%{_lib}/libutil-%{glibc_major_version}.so
564 /%{_lib}/libutil.so.1
565 %define optimized_libs() \
566         %dir %attr(0755,root,root) /%{_lib}/%1\
567         /%{_lib}/%1/libc-%{glibc_major_version}.so\
568         /%{_lib}/%1/libc.so.6*\
569         /%{_lib}/%1/libm-%{glibc_major_version}.so\
570         /%{_lib}/%1/libm.so.6*\
571         /%{_lib}/%1/libpthread-%{glibc_major_version}.so\
572         /%{_lib}/%1/libpthread.so.0\
573         /%{_lib}/%1/librt-%{glibc_major_version}.so\
574         /%{_lib}/%1/librt.so.1\
575         /%{_lib}/%1/libthread_db-1.0.so\
576         /%{_lib}/%1/libthread_db.so.1
577
578 %dir %attr(0700,root,root) /var/cache/ldconfig
579 /sbin/ldconfig
580 %{_bindir}/gencat
581 %{_bindir}/getconf
582 %{_bindir}/getent
583 %{_bindir}/iconv
584 %attr(755,root,root) %{_bindir}/ldd
585 %ifarch %ix86 sparc sparcv9
586         %{_bindir}/lddlibc4
587 %endif
588 %{_bindir}/locale
589 %{_bindir}/localedef
590 %dir %attr(0755,root,root) %{_libexecdir}/getconf
591 %{_libexecdir}/getconf/*
592 %{_sbindir}/glibc_post_upgrade
593 %{_sbindir}/iconvconfig
594 /%{_lib}/libBrokenLocale-%{glibc_major_version}.so
595 /%{_lib}/libBrokenLocale.so.1
596
597 %ifarch %ix86
598
599 %files obsolete
600 %manifest %{name}.manifest
601 %license COPYING.LIB
602 %defattr (755,root,root,755)
603 %dir /%{_lib}/obsolete/
604         #%dir /%{_lib}/obsolete/noversion
605         #/%{_lib}/obsolete/noversion/libNoVersion-%{glibc_major_version}.so
606         #/%{_lib}/obsolete/noversion/libNoVersion.so.1
607 %endif
608
609 %files locale -f libc.lang
610 %manifest %{name}.manifest
611 %license COPYING COPYING.LIB
612 %defattr(-,root,root)
613 %{_datadir}/locale/locale.alias
614 %if %{build_locales}
615 /usr/lib/locale/*
616 %endif
617 %{_libdir}/gconv
618
619 %files devel
620 %manifest %{name}.manifest
621 %defattr(-,root,root)
622 %license COPYING COPYING.LIB 
623 %doc NEWS README BUGS CONFORMANCE
624 %{_bindir}/rpcgen
625 %{_includedir}/*
626 %{_libdir}/*.o
627 %{_libdir}/*.so
628 # These static libraries are needed even for shared builds
629 %{_libdir}/libc_nonshared.a
630 %{_libdir}/libg.a
631 %{_libdir}/libieee.a
632 %ifarch ppc ppc64 s390 s390x sparc sparcv8 sparcv9 sparcv9v
633 # This is not built on sparc64.
634         %{_libdir}/libnldbl_nonshared.a
635 %endif
636 %{_libdir}/libmcheck.a
637 %{_libdir}/libpthread_nonshared.a
638 %{_libdir}/librpcsvc.a
639
640 %files devel-static
641 %manifest %{name}.manifest
642 %defattr(-,root,root)
643 %{_libdir}/libBrokenLocale.a
644 %{_libdir}/libanl.a
645 %{_libdir}/libc.a
646 %{_libdir}/libcrypt.a
647 %{_libdir}/libdl.a
648 %{_libdir}/libm.a
649 %{_libdir}/libnsl.a
650 %{_libdir}/libpthread.a
651 %{_libdir}/libresolv.a
652 %{_libdir}/librt.a
653 %{_libdir}/libutil.a
654
655 %files info
656 %manifest %{name}.manifest
657 %defattr(-,root,root)
658 %doc %{_infodir}/libc.info.gz
659 %doc %{_infodir}/libc.info-?.gz
660 %doc %{_infodir}/libc.info-??.gz
661
662 %if %{build_html}
663 %files html
664 %manifest %{name}.manifest
665 %defattr(-,root,root)
666 %doc %{_prefix}/share/doc/glibc
667 %endif
668
669 %files i18ndata
670 %manifest %{name}.manifest
671 %defattr(-,root,root)
672 %{_prefix}/share/i18n
673
674 %if %{build_profile}
675 %files profile
676 %manifest %{name}.manifest
677 %license COPYING COPYING.LIB
678 %defattr(-,root,root)
679 %{_libdir}/libc_p.a
680 %{_libdir}/libBrokenLocale_p.a
681 %{_libdir}/libanl_p.a
682 %{_libdir}/libm_p.a
683 %{_libdir}/libcrypt_p.a
684 %{_libdir}/libpthread_p.a
685 %{_libdir}/libresolv_p.a
686 %{_libdir}/libnsl_p.a
687 %{_libdir}/librt_p.a
688 %{_libdir}/librpcsvc_p.a
689 %{_libdir}/libutil_p.a
690 %{_libdir}/libdl_p.a
691 %endif
692
693 %files devel-utils
694 %manifest %{name}.manifest
695 %defattr(-,root,root)
696 /%{_lib}/libmemusage.so
697 /%{_lib}/libpcprofile.so
698 /%{_libdir}/libBrokenLocale.so
699 /%{_lib}/libSegFault.so
700 /%{_lib}/libthread_db-1.0.so
701 /%{_lib}/libthread_db.so.1
702 /%{_libdir}/libthread_db.so
703 %dir /%{_libdir}/audit
704 /%{_libdir}/audit/sotruss-lib.so
705 # These need gd-devel for building
706 # %%{_bindir}/memusage
707 # %%{_bindir}/memusagestat
708 %{_bindir}/mtrace
709 %{_bindir}/pcprofiledump
710 %{_bindir}/sotruss
711 %{_bindir}/xtrace
712 %{_bindir}/pldd
713 %{_bindir}/catchsegv
714 %{_bindir}/sprof
715
716 %files extra
717 %manifest %{name}.manifest
718 %license COPYING.LIB
719 %defattr(-,root,root)
720 %{_bindir}/makedb
721 /var/db/Makefile
722
723
724 %docs_package