Glib is upgraded(2.28.6->2.32.3), python-xml dependancy added
[external/glib2.0.git] / packaging / glib2.spec
1 Summary: A library of handy utility functions
2 Name: glib2
3 Version: 2.32.3
4 Release: 1%{?dist}
5 License: LGPLv2+
6 Group: System/Libraries
7 URL: http://www.gtk.org
8 Source: %{name}-%{version}.tar.gz
9 #Source: http://download.gnome.org/sources/glib/2.32/%{name}-%{version}.tar.gz
10
11 BuildRequires: pkgconfig 
12 BuildRequires: gettext-tools
13 BuildRequires: libattr-devel
14 BuildRequires: zlib-devel
15 BuildRequires: python
16 BuildRequires: python-xml
17 BuildRequires: libffi-devel
18 BuildRequires: elfutils-libelf-devel
19
20 %description
21 GLib is the low-level core library that forms the basis for projects
22 such as GTK+ and GNOME. It provides data structure handling for C,
23 portability wrappers, and interfaces for such runtime functionality
24 as an event loop, threads, dynamic loading, and an object system.
25
26
27 %package devel
28 Summary: A library of handy utility functions
29 Group: Development/Libraries
30 Requires: pkgconfig 
31 Requires: %{name} = %{version}-%{release}
32
33 %description devel
34 The glib2-devel package includes the header files for the GLib library.
35
36 # anaconda needs static libs, see RH bug #193143
37 %package static
38 Summary: A library of handy utility functions
39 Group: Development/Libraries
40 Requires: %{name}-devel = %{version}-%{release}
41
42 %description static
43 The glib2-static package includes static libraries of the GLib library.
44
45
46 %prep
47 %setup -q
48
49 %build
50 %configure --disable-gtk-doc --enable-static --disable-selinux --disable-visibility --enable-debug=yes
51
52 make %{?_smp_mflags}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 make install DESTDIR=$RPM_BUILD_ROOT
57
58 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
59 rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.{a,la}
60 rm -f $RPM_BUILD_ROOT%{_datadir}/glib-2.0/gdb/*.{pyc,pyo}
61 rm -f $RPM_BUILD_ROOT%{_libdir}/gdbus-codegen/*.{pyc,pyo}
62
63 touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
64
65 # MeeGo does not provide bash completion
66 rm -rf ${RPM_BUILD_ROOT}%{_sysconfdir}/bash_completion.d
67
68 %find_lang glib20
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post -p /sbin/ldconfig
74
75 %postun -p /sbin/ldconfig
76
77 %files -f glib20.lang
78 %defattr(-, root, root, -)
79 %doc AUTHORS COPYING NEWS README
80 %{_libdir}/libglib-2.0.so.*
81 %{_libdir}/libgthread-2.0.so.*
82 %{_libdir}/libgmodule-2.0.so.*
83 %{_libdir}/libgobject-2.0.so.*
84 %{_libdir}/libgio-2.0.so.*
85 %dir %{_datadir}/glib-2.0
86 %dir %{_datadir}/glib-2.0/schemas
87 %dir %{_libdir}/gio
88 %dir %{_libdir}/gio/modules
89 %ghost %{_libdir}/gio/modules/giomodule.cache
90 %{_bindir}/gio-querymodules*
91 %{_bindir}/glib-compile-schemas
92 %{_bindir}/gsettings
93 %{_bindir}/gdbus
94 %doc %{_mandir}/man1/gio-querymodules.1.gz
95 %doc %{_mandir}/man1/glib-compile-schemas.1.gz
96 %doc %{_mandir}/man1/gsettings.1.gz
97 %doc %{_mandir}/man1/gdbus.1.gz
98
99 %files devel
100 %defattr(-, root, root, -)
101 %{_libdir}/lib*.so
102 %{_libdir}/glib-2.0
103 %{_includedir}/*
104 %{_datadir}/aclocal/*
105 %{_libdir}/pkgconfig/*
106 %{_datadir}/glib-2.0/gdb
107 %{_datadir}/glib-2.0/gettext
108 %{_datadir}/glib-2.0/schemas/gschema.dtd
109 %{_bindir}/glib-genmarshal
110 %{_bindir}/glib-gettextize
111 %{_bindir}/glib-mkenums
112 %{_bindir}/gobject-query
113 %{_bindir}/gtester
114 %{_bindir}/gdbus-codegen
115 %{_bindir}/glib-compile-resources
116 %{_bindir}/gresource
117 %{_libdir}/gdbus-2.0/codegen
118 %attr (0755, root, root) %{_bindir}/gtester-report
119 %doc %{_datadir}/gtk-doc/html/*
120 %doc %{_mandir}/man1/glib-genmarshal.1.gz
121 %doc %{_mandir}/man1/glib-gettextize.1.gz
122 %doc %{_mandir}/man1/glib-mkenums.1.gz
123 %doc %{_mandir}/man1/gobject-query.1.gz
124 %doc %{_mandir}/man1/gtester-report.1.gz
125 %doc %{_mandir}/man1/gtester.1.gz
126 %doc %{_mandir}/man1/gdbus-codegen.1.gz
127 %doc %{_mandir}/man1/glib-compile-resources.1.gz
128 %doc %{_mandir}/man1/gresource.1.gz
129 %{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
130 %{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
131
132 %files static
133 %defattr(-, root, root, -)
134 %{_libdir}/lib*.a
135