239cb56a5854b6c3d246ed255eb04fda1d21222d
[external/glib2.0.git] / packaging / glib2.spec
1 Summary: A library of handy utility functions
2 Name: glib2
3 Version: 2.32.3
4 Release: 1%{?dist}
5 License: LGPLv2+
6 Group: System/Libraries
7 URL: http://www.gtk.org
8 Source: %{name}-%{version}.tar.gz
9 #Source: http://download.gnome.org/sources/glib/2.32/%{name}-%{version}.tar.gz
10
11 BuildRequires: pkgconfig 
12 BuildRequires: gettext-tools
13 BuildRequires: libattr-devel
14 BuildRequires: zlib-devel
15 BuildRequires: python-devel
16 BuildRequires: libffi-devel
17 BuildRequires: elfutils-libelf-devel
18
19 %description
20 GLib is the low-level core library that forms the basis for projects
21 such as GTK+ and GNOME. It provides data structure handling for C,
22 portability wrappers, and interfaces for such runtime functionality
23 as an event loop, threads, dynamic loading, and an object system.
24
25
26 %package devel
27 Summary: A library of handy utility functions
28 Group: Development/Libraries
29 Requires: pkgconfig 
30 Requires: %{name} = %{version}-%{release}
31
32 %description devel
33 The glib2-devel package includes the header files for the GLib library.
34
35 # anaconda needs static libs, see RH bug #193143
36 %package static
37 Summary: A library of handy utility functions
38 Group: Development/Libraries
39 Requires: %{name}-devel = %{version}-%{release}
40
41 %description static
42 The glib2-static package includes static libraries of the GLib library.
43
44
45 %prep
46 %setup -q
47
48 %build
49 %configure --disable-gtk-doc --enable-static --disable-selinux --disable-visibility --enable-debug=yes
50
51 make %{?_smp_mflags}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 make install DESTDIR=$RPM_BUILD_ROOT
56
57 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
58 rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.{a,la}
59 rm -f $RPM_BUILD_ROOT%{_datadir}/glib-2.0/gdb/*.{pyc,pyo}
60 rm -f $RPM_BUILD_ROOT%{_libdir}/gdbus-codegen/*.{pyc,pyo}
61
62 touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
63
64 # MeeGo does not provide bash completion
65 rm -rf ${RPM_BUILD_ROOT}%{_sysconfdir}/bash_completion.d
66
67 %find_lang glib20
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post -p /sbin/ldconfig
73
74 %postun -p /sbin/ldconfig
75
76 %files -f glib20.lang
77 %defattr(-, root, root, -)
78 %doc AUTHORS COPYING NEWS README
79 %{_libdir}/libglib-2.0.so.*
80 %{_libdir}/libgthread-2.0.so.*
81 %{_libdir}/libgmodule-2.0.so.*
82 %{_libdir}/libgobject-2.0.so.*
83 %{_libdir}/libgio-2.0.so.*
84 %dir %{_datadir}/glib-2.0
85 %dir %{_datadir}/glib-2.0/schemas
86 %dir %{_libdir}/gio
87 %dir %{_libdir}/gio/modules
88 %ghost %{_libdir}/gio/modules/giomodule.cache
89 %{_bindir}/gio-querymodules*
90 %{_bindir}/glib-compile-schemas
91 %{_bindir}/gsettings
92 %{_bindir}/gdbus
93 %doc %{_mandir}/man1/gio-querymodules.1.gz
94 %doc %{_mandir}/man1/glib-compile-schemas.1.gz
95 %doc %{_mandir}/man1/gsettings.1.gz
96 %doc %{_mandir}/man1/gdbus.1.gz
97
98 %files devel
99 %defattr(-, root, root, -)
100 %{_libdir}/lib*.so
101 %{_libdir}/glib-2.0
102 %{_includedir}/*
103 %{_datadir}/aclocal/*
104 %{_libdir}/pkgconfig/*
105 %{_datadir}/glib-2.0/gdb
106 %{_datadir}/glib-2.0/gettext
107 %{_datadir}/glib-2.0/schemas/gschema.dtd
108 %{_bindir}/glib-genmarshal
109 %{_bindir}/glib-gettextize
110 %{_bindir}/glib-mkenums
111 %{_bindir}/gobject-query
112 %{_bindir}/gtester
113 %{_bindir}/gdbus-codegen
114 %{_bindir}/glib-compile-resources
115 %{_bindir}/gresource
116 %{_libdir}/gdbus-2.0/codegen
117 %attr (0755, root, root) %{_bindir}/gtester-report
118 %doc %{_datadir}/gtk-doc/html/*
119 %doc %{_mandir}/man1/glib-genmarshal.1.gz
120 %doc %{_mandir}/man1/glib-gettextize.1.gz
121 %doc %{_mandir}/man1/glib-mkenums.1.gz
122 %doc %{_mandir}/man1/gobject-query.1.gz
123 %doc %{_mandir}/man1/gtester-report.1.gz
124 %doc %{_mandir}/man1/gtester.1.gz
125 %doc %{_mandir}/man1/gdbus-codegen.1.gz
126 %doc %{_mandir}/man1/glib-compile-resources.1.gz
127 %doc %{_mandir}/man1/gresource.1.gz
128 %{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
129 %{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
130
131 %files static
132 %defattr(-, root, root, -)
133 %{_libdir}/lib*.a
134