update latest
[external/giflib.git] / packaging / giflib.spec
1 #sbs-git:slp/unmodified/giflib giflib 4.1.6 61596465721e29cdfae7e6237b2a148e04006a6c
2 Summary: Library for manipulating GIF format image files
3 Name: giflib
4 Version: 4.1.6
5 Release: 9
6 License: MIT
7 URL: http://sourceforge.net/projects/giflib/
8 Source0: http://downloads.sourceforge.net/giflib/%{name}-%{version}.tar.gz
9 Group: System/Libraries
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11 BuildRequires: pkgconfig(x11)
12 BuildRequires: pkgconfig(ice)
13 BuildRequires: pkgconfig(sm)
14 BuildRequires: pkgconfig(xv)
15
16 Obsoletes: libungif <= %{version}-%{release}
17 Provides: libungif <= %{version}-%{release}
18
19 %description
20 The giflib package contains a shared library of functions for
21 loading and saving GIF format image files.  It is API and ABI compatible
22 with libungif, the library which supported uncompressed GIFs while the
23 Unisys LZW patent was in effect.
24
25 Install the giflib package if you need to write programs that use GIF files.
26 You should also install the giflib-utils package if you need some simple
27 utilities to manipulate GIFs.
28
29 %package devel
30 Summary: Development tools for programs which will use the libungif library
31 Group: Development/Libraries
32 Requires: %{name} = %{version}-%{release}
33 Provides: libungif-devel <= %{version}-%{release}
34 Obsoletes: libungif-devel <= %{version}-%{release}
35
36 %description devel
37 This package contains the static libraries, header files and
38 documentation necessary for development of programs that will use the
39 giflib library to load and save GIF format image files.
40
41 You should install this package if you need to develop programs which
42 will use giflib library functions.  You'll also need to install the
43 giflib package.
44
45 %package utils
46 Summary: Programs for manipulating GIF format image files
47 Group: Applications/Multimedia
48 Requires: %{name} = %{version}-%{release}
49 Obsoletes: libungif-progs <= %{version}-%{release}
50
51 %description utils
52 The giflib-utils package contains various programs for manipulating
53 GIF format image files.
54
55 Install this package if you need to manipulate GIF format image files.
56 You'll also need to install the giflib package.
57
58 %prep
59 %setup -q
60
61 %build
62 %configure
63 make %{?_smp_mflags} all
64
65 MAJOR=`echo '%{version}' | sed 's/\([0-9]\+\)\..*/\1/'`
66 %{__cc} $RPM_OPT_FLAGS -shared -Wl,-soname,libungif.so.$MAJOR -Llib/.libs -lgif -o libungif.so.%{version}
67
68 %install
69 rm -rf ${RPM_BUILD_ROOT}
70
71 %make_install
72
73 install -m 0755 -p libungif.so.%{version} $RPM_BUILD_ROOT%{_libdir}
74 ln -sf libungif.so.%{version} ${RPM_BUILD_ROOT}%{_libdir}/libungif.so.4
75 ln -sf libungif.so.4 ${RPM_BUILD_ROOT}%{_libdir}/libungif.so
76
77
78 %clean
79 rm -rf ${RPM_BUILD_ROOT}
80
81 %post -p /sbin/ldconfig
82
83 %postun -p /sbin/ldconfig
84
85 %files 
86 %{_libdir}/lib*.so.*
87
88 %files devel
89 %{_libdir}/lib*.so
90 %{_includedir}/*.h
91
92 %files utils
93 %{_bindir}/*