Add armoring option
[platform/upstream/giflib.git] / packaging / giflib.spec
1 %bcond_with wayland
2 %bcond_with x
3 Name:           giflib
4 Version:        5.2.1
5 Release:        1
6 License:        MIT
7 Summary:        Library for manipulating GIF format image files
8 Url:            http://sourceforge.net/projects/giflib/
9 Group:          System/Libraries
10 Source0:        http://downloads.sourceforge.net/giflib/%{name}-%{version}.tar.bz2
11 Source1001:     giflib.manifest
12 %if %{with x}
13 BuildRequires:  pkgconfig(x11)
14 BuildRequires:  pkgconfig(xv)
15 BuildRequires:  pkgconfig(ice)
16 BuildRequires:  pkgconfig(sm)
17 %endif
18
19 %description
20 The giflib package contains a shared library of functions for
21 loading and saving GIF format image files.  It is API and ABI compatible
22 with libungif, the library which supported uncompressed GIFs while the
23 Unisys LZW patent was in effect.
24
25 Install the giflib package if you need to write programs that use GIF files.
26 You should also install the giflib-utils package if you need some simple
27 utilities to manipulate GIFs.
28
29 %package devel
30 Summary:        Development tools for programs which will use the libungif library
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}
33
34 %description devel
35 This package contains the static libraries, header files and
36 documentation necessary for development of programs that will use the
37 giflib library to load and save GIF format image files.
38
39 You should install this package if you need to develop programs which
40 will use giflib library functions.  You'll also need to install the
41 giflib package.
42
43 # It is necessary to check if this package is needed.
44 %package utils
45 Summary:        Programs for manipulating GIF format image files
46 Group:          Applications/Multimedia
47 Requires:       %{name} = %{version}
48
49 %description utils
50 The giflib-utils package contains various programs for manipulating
51 GIF format image files.
52
53 Install this package if you need to manipulate GIF format image files.
54 You'll also need to install the giflib package.
55
56 %prep
57 %setup -q
58 cp %{SOURCE1001} .
59
60 %build
61 make libgif.so libutil.so DESTDIR=$RPM_BUILD_ROOT PREFIX=/usr LIBDIR=%{_libdir} __TIZEN__=true
62
63 %install
64 make install-lib install-include install-bin DESTDIR=$RPM_BUILD_ROOT PREFIX=/usr LIBDIR=%{_libdir}
65
66 install -m 0755 -p libutil.so %{buildroot}%{_libdir}/libgifutil.so.7.1.0
67 ln -sf libgifutil.so.7.1.0 %{buildroot}%{_libdir}/libgifutil.so.7
68 ln -sf libgifutil.so.7 %{buildroot}%{_libdir}/libgifutil.so
69
70 %clean
71 make clean
72
73 %post -p /sbin/ldconfig
74
75 %postun -p /sbin/ldconfig
76
77 %files
78 %manifest %{name}.manifest
79 %license COPYING
80 %{_libdir}/lib*.so.*
81
82 %files devel
83 %manifest %{name}.manifest
84 %{_libdir}/lib*.so
85 %{_includedir}/*.h
86
87 %files utils
88 %manifest %{name}.manifest
89 %{_bindir}/*