tizen 2.4 release
[framework/location/geofence-dbus.git] / packaging / geofence-dbus.spec
1 Name: geofence-dbus
2 Summary: Dbus interface for Geofence service
3 Version: 0.3.0
4 Release:    1
5 Group:      Framework/Location
6 License:    Apache-2.0
7 Source0:    geofence-dbus-%{version}.tar.gz
8
9 %if "%{?tizen_profile_name}" == "tv"
10 ExcludeArch: %{arm} %ix86 x86_64
11 %endif
12
13 Requires(post): /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15 BuildRequires:  cmake
16 BuildRequires:  pkgconfig(glib-2.0)
17 BuildRequires:  pkgconfig(gobject-2.0)
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(gio-2.0)
20 BuildRequires:  pkgconfig(gio-unix-2.0)
21 BuildRequires:  pkgconfig(capi-base-common)
22
23 %description
24 Geofence dbus interface
25
26 %package -n libgeofence-dbus
27 Summary:    Geofence dbus library
28 Group:      TO_BE/FILLED_IN
29 Requires(post): sys-assert
30
31 %description -n libgeofence-dbus
32 Geofence client API library
33
34 %package -n libgeofence-dbus-devel
35 Summary:    Telephony client API (devel)
36 Group:      Development/Libraries
37 Requires:   libgeofence-dbus = %{version}-%{release}
38
39 %description -n libgeofence-dbus-devel
40 Geofence client API library (devel)
41
42
43 %prep
44 %setup -q
45
46
47 %build
48 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
49 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
50 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
51 export CFLAGS+=" -Wno-unused-local-typedefs "
52 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
53
54 make %{?jobs:-j%jobs}
55
56 %install
57 rm -rf %{buildroot}
58 %make_install
59
60 %post -p /sbin/ldconfig
61
62 %postun -p /sbin/ldconfig
63
64
65 %files -n libgeofence-dbus
66 %manifest libgeofence-dbus.manifest
67 %defattr(-,root,root,-)
68 #%doc COPYING
69 %{_libdir}/*.so.*
70 %{_prefix}/etc/dbus-1/system.d/*
71
72 %files -n libgeofence-dbus-devel
73 %defattr(-,root,root,-)
74 %{_includedir}/geofence-dbus/*.h
75 %{_libdir}/pkgconfig/*.pc
76 %{_libdir}/*.so