c84ae42af83275c90b5cfb64b0fd97f08ba983a3
[platform/upstream/gdb.git] / packaging / gdb.spec
1 Name:           gdb
2 Version:        7.10.1
3 Release:        0
4 License:        GPL-3.0+
5 Summary:        A GNU source-level debugger for C, C++, Java and other languages
6 Url:            http://gnu.org/software/gdb/
7 Group:          Development/Toolchain
8 Source:         ftp://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.xz
9 Source1001:     gdb.manifest
10 %define gdb_src gdb-%{version}
11 %define gdb_build build-%{_target_platform}
12 Requires:       python
13 BuildRequires:  bison
14 BuildRequires:  expat-devel
15 BuildRequires:  flex
16 BuildRequires:  gettext
17 BuildRequires:  python-devel
18 BuildRequires:  gcc-c++
19 BuildRequires:  ncurses-devel
20 BuildRequires:  rpm-devel
21 BuildRequires:  makeinfo
22
23 %description
24 GDB, the GNU debugger, allows you to debug programs written in C, C++,
25 Java, and other languages, by executing them in a controlled fashion
26 and printing their data.
27
28 %package devel
29 Summary:        Development files for gdb
30
31 %description devel
32 Development files for gdb.
33
34 %package server
35 Summary:        A standalone server for GDB (the GNU source-level debugger)
36
37 %description server
38 GDB, the GNU debugger, allows you to debug programs written in C, C++,
39 Java, and other languages, by executing them in a controlled fashion
40 and printing their data.
41
42 This package provides a program that allows you to run GDB on a different machine than the one which is running the program being debugged.
43
44 %prep
45 %setup -q
46 cp %{SOURCE1001} .
47
48 # Remove the info and other generated files added by the FSF release
49 # process.
50 rm -f libdecnumber/gstdint.h
51 rm -f bfd/doc/*.info
52 rm -f bfd/doc/*.info-*
53 rm -f gdb/doc/*.info
54 rm -f gdb/doc/*.info-*
55
56 %build
57 %configure                                              \
58         --with-gdb-datadir=%{_datadir}/gdb              \
59         --enable-gdb-build-warnings=,-Wno-unused        \
60         --disable-werror                                \
61         --with-separate-debug-dir=/usr/lib/debug        \
62         --disable-sim                                   \
63         --disable-rpath                                 \
64         --with-expat                                    \
65         --enable-64-bit-bfd                             \
66         --enable-static --disable-shared --enable-debug
67
68 make %{?_smp_mflags}
69
70
71 %install
72 %make_install
73
74 %find_lang opcodes
75 %find_lang bfd
76 mv opcodes.lang %{name}.lang
77 cat bfd.lang >> %{name}.lang
78
79 %docs_package
80
81 %lang_package
82
83 %files
84 %defattr(-,root,root)
85 %manifest %{name}.manifest
86 %license COPYING COPYING.LIB
87 %{_bindir}/*
88 %{_datadir}/gdb
89
90 %files server
91 %manifest %{name}.manifest
92 %defattr(-,root,root)
93 %{_bindir}/gdbserver
94 %{_mandir}/*/gdbserver.1*
95 %ifarch %{ix86} x86_64
96 %{_libdir}/libinproctrace.so
97 %endif
98
99 %files devel
100 %manifest %{name}.manifest
101 %{_includedir}/*.h
102 %{_includedir}/gdb/*.h