Update to 7.5.1
[platform/upstream/gdb.git] / packaging / gdb.spec
1 Name:           gdb
2 Version:        7.5.1
3 Release:        0
4 License:        GPL-3.0+
5 Summary:        A GNU source-level debugger for C, C++, Java and other languages
6 Url:            http://gnu.org/software/gdb/
7 Group:          Development/Toolchain
8 Source:         ftp://ftp.gnu.org/gnu/gdb/gdb-%{version}.tar.bz2
9 Source1001:     gdb.manifest
10 %define gdb_src gdb-%{version}
11 %define gdb_build build-%{_target_platform}
12
13 BuildRequires:  bison
14 BuildRequires:  expat-devel
15 BuildRequires:  flex
16 BuildRequires:  gettext
17 BuildRequires:  python-devel
18 BuildRequires:  gcc-c++
19 BuildRequires:  ncurses-devel
20 BuildRequires:  readline-devel
21 BuildRequires:  rpm-devel
22 BuildRequires:  makeinfo
23
24 %description
25 GDB, the GNU debugger, allows you to debug programs written in C, C++,
26 Java, and other languages, by executing them in a controlled fashion
27 and printing their data.
28
29 %package devel
30 Summary:        Development files for gdb
31
32 %description devel
33 Development files for gdb.
34
35 %package server
36 Summary:        A standalone server for GDB (the GNU source-level debugger)
37
38 %description server
39 GDB, the GNU debugger, allows you to debug programs written in C, C++,
40 Java, and other languages, by executing them in a controlled fashion
41 and printing their data.
42
43 This package provides a program that allows you to run GDB on a different machine than the one which is running the program being debugged.
44
45 %prep
46 %setup -q 
47 cp %{SOURCE1001} .
48
49 # Remove the info and other generated files added by the FSF release
50 # process.
51 rm -f libdecnumber/gstdint.h
52 rm -f bfd/doc/*.info
53 rm -f bfd/doc/*.info-*
54 rm -f gdb/doc/*.info
55 rm -f gdb/doc/*.info-*
56
57 %build
58 %configure                                              \
59         --with-gdb-datadir=%{_datadir}/gdb              \
60         --enable-gdb-build-warnings=,-Wno-unused        \
61         --disable-werror                                \
62         --with-separate-debug-dir=/usr/lib/debug        \
63         --disable-sim                                   \
64         --disable-rpath                                 \
65         --with-system-readline                          \
66         --with-expat                                    \
67         --disable-tui                                   \
68         --enable-64-bit-bfd                             \
69         --enable-static --disable-shared --enable-debug
70
71 make %{?_smp_mflags}
72
73
74 %install
75 %make_install
76
77 %find_lang opcodes
78 %find_lang bfd
79 mv opcodes.lang %{name}.lang
80 cat bfd.lang >> %{name}.lang
81
82 %docs_package
83
84 %lang_package
85
86 %files
87 %defattr(-,root,root)
88 %manifest %{name}.manifest
89 %license COPYING COPYING.LIB 
90 %{_bindir}/*
91 %{_datadir}/gdb
92
93 %files server
94 %manifest %{name}.manifest
95 %defattr(-,root,root)
96 %{_bindir}/gdbserver
97 %{_mandir}/*/gdbserver.1*
98 %ifarch %{ix86} x86_64
99 %{_libdir}/libinproctrace.so
100 %endif
101
102 %files devel
103 %manifest %{name}.manifest
104 %{_includedir}/*.h
105 %{_includedir}/gdb/*.h