add packaging
[platform/upstream/gcc48.git] / packaging / gcc47-testresults.spec
1 %define building_testsuite 1
2 %define run_tests 1
3 %define fast_build 1
4
5 # Ada currently fails to build on a few platforms, enable it only
6 # on those that work
7 # Note that AdaCore only supports %ix86, x86_64 and ia64
8 %ifarch %ix86 x86_64
9 %define build_ada !0%{?building_libjava:1}%{?building_libffi:1}
10 %else
11 %define build_ada 0
12 %endif
13
14 %define quadmath_arch %ix86 x86_64 ia64
15
16 # We don't want to build java
17 %ifarch mips
18 %define build_java 0
19 %define build_libjava 0
20 %else
21 %define build_java 1
22 %define build_libjava 0%{?building_libjava:1}%{?building_libffi:1}%{?building_testsuite:1}
23 %endif
24
25 %define build_cp 1
26 %define build_fortran 1
27 %define build_objc 1
28 %define build_objcp !0%{?building_libjava:1}%{?building_libffi:1}
29 %define build_with_mudflap 0
30
31 %if %{build_objcp}
32 %define build_cp 1
33 %define build_objc 1
34 %endif
35
36 %if %{build_libjava}
37 %define build_cp 1
38 %endif
39
40 # For optional compilers only build C, C++ and Fortran
41 ##%if 0%{?build_optional_compiler:1}%{?build_optional_compiler_languages:1}
42 %if 0%{!?building_libffi:1}
43 %define build_ada 0
44 %define build_java 0
45 %define build_libjava 0
46 %define build_objc 1
47 %define build_objcp 1
48 %endif
49
50
51 Name: gcc47-testresults
52 BuildRequires: bison
53 BuildRequires: flex
54 BuildRequires: gettext-tools
55 BuildRequires: makeinfo
56 BuildRequires: glibc-devel-32bit
57 BuildRequires: mpc-devel
58 BuildRequires: mpfr-devel
59 BuildRequires: perl
60 BuildRequires: texinfo
61 BuildRequires: zlib-devel
62 %ifarch %ix86 x86_64 %arm
63 BuildRequires: cloog-devel
64 BuildRequires: ppl-devel
65 %endif
66 %if %{build_ada}
67 %define hostsuffix -4.7
68 BuildRequires: gcc47-ada
69 %endif
70 %if 0%{?building_libjava:1}%{?building_testsuite:1}
71 BuildRequires: fastjar
72 BuildRequires: unzip
73 %endif
74 %if 0%{?building_libffi:1}
75 BuildRequires: pkg-config
76 %endif
77 %ifarch ia64
78 BuildRequires: libunwind-devel
79 %endif
80 %if 0%{?run_tests:1}
81 BuildRequires: dejagnu
82 BuildRequires: expect
83 BuildRequires: gdb
84 %endif
85
86 # Define version number of libgcc_s
87 %ifarch hppa
88 %define libgcc_s 4
89 %else
90 %define libgcc_s 1
91 %endif
92 %ifarch ppc
93 # We support building the nof libraries, but don't want this in the
94 # regular rpms
95 %define build_nof 0
96 %else
97 %define build_nof 0
98 %endif
99
100 %define separate_bi32 0
101 %define separate_bi64 0
102 %ifarch x86_64 
103 %define separate_bi32 1
104 %endif
105
106 # Define two macros to trigger -32bit or -64bit package variants
107 %define separate_biarch 0
108 %if %{separate_bi32}
109 %define separate_biarch 1
110 %define separate_biarch_suffix -32bit
111 %endif
112 %if %{separate_bi64}
113 %define separate_biarch 1
114 %define separate_biarch_suffix -64bit
115 %endif
116
117 %ifarch x86_64
118 # 64-bit is primary build target
119 %define build_primary_64bit 1
120 %else
121 %define build_primary_64bit 0
122 %endif
123
124 %define biarch_libjava 0
125
126 # COMMON-BEGIN
127 %define biarch_targets x86_64 
128
129 URL:          http://gcc.gnu.org/
130 Version: 4.7.2
131 Release:      1
132 %define gcc_version %(echo %version | sed 's/_.*//')
133 %define gcc_dir_version %(echo %gcc_version | cut -d '.' -f 1-2)
134 %define snapshot_date %(echo %version | sed 's/[34]\.[0-9]\.[0-6]//' | sed 's/_/-/')
135 %define binsuffix -4.7
136 # COMMON-END
137
138 %if !0%{?building_libjava:1}%{?building_libffi:1}%{?building_testsuite:1}
139 Requires: binutils glibc-devel
140 Requires: cpp47 = %{version}-%{release}
141 %if 0%{!?build_optional_compiler:1}
142 Requires: libgcc%{libgcc_s} >= %{version}-%{release}
143 Requires: libgomp1 >= %{version}-%{release}
144 %if %{build_with_mudflap}
145 Requires: libmudflap0 >= %{version}-%{release}
146 Requires: libmudflapth0 >= %{version}-%{release}
147 %endif
148 %else
149 Requires: libgcc47 = %{version}-%{release}
150 Requires: libgomp47 = %{version}-%{release}
151 %endif
152 %endif
153
154 # COMMON-BEGIN
155 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
156 #Source:                gcc-%{gcc_version}%{snapshot_date}.tar.bz2
157 Source:     gcc-%{version}.tar.bz2
158
159 Source1:        change_spec
160 Source2:        libgcj47-rpmlintrc
161 Source3:        gcc47-rpmlintrc
162 Source4:        ecj.jar
163 Source6:        baselibs.conf
164 # Patches auto-generated by git-buildpackage:
165 Patch0:     0001-dir-version.patch
166
167 Summary:      Testsuite results
168 License:        SUSE-Public-Domain
169 Group:        Development/Languages/C and C++
170
171 %description 
172 Results from running the gcc and target library testsuites.
173
174
175 # COMMON-BEGIN
176
177 # Define the canonical target and host architecture
178 #   %gcc_target_arch  is supposed to be the full target triple
179 #   %TARGET_ARCH      is the canonicalized CPU part
180 #   %CONFIGURE_TARGET is the target triple used for --target=
181 %if 0%{?gcc_target_arch:1}
182 %define CONFIGURE_TARGET %{gcc_target_arch}
183 %define TARGET_ARCH %(echo %{gcc_target_arch} | cut -d - -f 1 | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
184 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "i586"
185 %define CONFIGURE_TARGET i586-tizen-linux
186 %endif
187 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7l"
188 %define CONFIGURE_TARGET armv7l-tizen-linux-gnueabi
189 %endif
190 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7hl"
191 %define CONFIGURE_TARGET armv7hl-tizen-linux-gnueabi
192 %endif
193 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv7el"
194 %define CONFIGURE_TARGET armv7el-tizen-linux-gnueabi
195 %endif
196 %if 0%{?gcc_icecream:1} && %{TARGET_ARCH} == "armv5el"
197 %define CONFIGURE_TARGET armv5el-tizen-linux-gnueabi
198 %endif
199 %else
200 %define TARGET_ARCH %(echo %{_target_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
201 %endif
202 %define HOST_ARCH %(echo %{_host_cpu} | sed -e "s/i.86/i586/;s/ppc/powerpc/;s/sparc64.*/sparc64/;s/sparcv.*/sparc/;")
203
204 %define biarch %(case " %{biarch_targets} " in (*" %{TARGET_ARCH} "*) echo 1;; (*) echo 0;; esac)
205
206 %ifarch %arm
207 %define GCCDIST %{HOST_ARCH}-tizen-linux-gnueabi
208 %else
209 %define GCCDIST %{HOST_ARCH}-tizen-linux
210 %endif
211
212 %define libsubdir %{_libdir}/gcc/%{GCCDIST}/%{gcc_dir_version}
213 %define gxxinclude %{_prefix}/include/c++/%{gcc_dir_version}
214
215 # COMMON-END
216
217 # Versionspecific directories
218 %define versmainlibdir %{libsubdir}
219 %define versmainlibdirbi32 %{libsubdir}/32
220 %define versmainlibdirbi64 %{libsubdir}/64
221 %if %{build_primary_64bit}
222 %define versmainlibdirbi %{versmainlibdirbi32}
223 %else
224 %define versmainlibdirbi %{versmainlibdirbi64}
225 %endif
226
227 %if 0%{?build_optional_compiler:1}
228 %define mainlibdir %{versmainlibdir}
229 %define mainlibdirbi32 %{versmainlibdirbi32}
230 %define mainlibdirbi64 %{versmainlibdirbi64}
231 %define noflibdir %{versnoflibdir}
232 %define mainlibdirbi %{versmainlibdirbi}
233 %else
234 %define mainlibdir %{_libdir}
235 %define mainlibdirbi32 %{_prefix}/lib
236 %define mainlibdirbi64 %{_prefix}/lib64
237 %define noflibdir %{_prefix}/lib/nof
238 %if %{build_primary_64bit}
239 %define mainlibdirbi %{mainlibdirbi32}
240 %else
241 %define mainlibdirbi %{mainlibdirbi64}
242 %endif
243 %endif
244
245
246 # Now define a few macros that make it easy to package libs and
247 # related files just to the right package, without caring for the
248 # exact path the files are in.
249 #   %mainlib  package X from all dirs that belong to the main package
250 #   %biarchlib   package X from all dirs that belong to the -32/64bit package
251 # by default, nof libs go where the 32bit libs go.
252 %if %{build_nof}
253 %define mainlib() %{mainlibdir}/%1\
254 %{noflibdir}/%1\
255 %{nil}
256 %else
257 %define mainlib() %{mainlibdir}/%1\
258 %{nil}
259 %endif
260 %define biarchlib() %{nil}
261 %if %{biarch}
262 %if !%{separate_biarch}
263 %if %{build_nof}
264 %define mainlib() %{mainlibdir}/%1\
265 %{mainlibdirbi}/%1\
266 %{noflibdir}/%1\
267 %{nil}
268 %else
269 %define mainlib() %{mainlibdir}/%1\
270 %{mainlibdirbi}/%1\
271 %{nil}
272 %endif
273 %else
274 %if %{build_nof}
275 %define biarchlib() %{mainlibdirbi}/%1\
276 %{noflibdir}/%1\
277 %{nil}
278 %define mainlib() %{mainlibdir}/%1\
279 %{nil}
280 %else
281 %define biarchlib() %{mainlibdirbi}/%1\
282 %{nil}
283 %endif
284 %endif
285 %endif
286
287 %if %{build_nof}
288 %define versmainlib() %{versmainlibdir}/%1\
289 %{versnoflibdir}/%1\
290 %{nil}
291 %else
292 %define versmainlib() %{versmainlibdir}/%1\
293 %{nil}
294 %endif
295 %define versbiarchlib() %{nil}
296 %if %{biarch}
297 %if !%{separate_biarch}
298 %if %{build_nof}
299 %define versmainlib() %{versmainlibdir}/%1\
300 %{versmainlibdirbi}/%1\
301 %{versnoflibdir}/%1\
302 %{nil}
303 %else
304 %define versmainlib() %{versmainlibdir}/%1\
305 %{versmainlibdirbi}/%1\
306 %{nil}
307 %endif
308 %else
309 %if %{build_nof}
310 %define versbiarchlib() %{versmainlibdirbi}/%1\
311 %{versnoflibdir}/%1\
312 %{nil}
313 %define versmainlib() %{versmainlibdir}/%1\
314 %{nil}
315 %else
316 %define versbiarchlib() %{versmainlibdirbi}/%1\
317 %{nil}
318 %endif
319 %endif
320 %endif
321
322
323 # COMMON-BEGIN
324
325 %prep
326 #%setup -q -n gcc-%{gcc_version}%{snapshot_date}
327 %setup -q -n gcc-%{version}
328 # 0001-dir-version.patch
329 %patch0 -p1
330
331 %build
332 # Avoid rebuilding of generated files
333 contrib/gcc_update --touch
334 # Avoid fucking up testsuite results with Java and indirect dispatch
335 export LD_AS_NEEDED=0
336 # Split version file into version used for directories (X.Y) and
337 # version to report with --version (X.Y.Z).
338 # See also gcc-dir-version.patch.
339 # Also decrement the patchlevel version by one
340 if test `cat gcc/DEV-PHASE` == "prerelease"; then
341   ( cat gcc/BASE-VER | cut -d '.' -f 1-2 | tr -d '\n'; echo -n .; cat gcc/BASE-VER | cut -d '.' -f 3 | tr '0123456789' '0012345678' ) > gcc/FULL-VER
342 else
343   mv gcc/BASE-VER gcc/FULL-VER
344 fi
345 cat gcc/FULL-VER | cut -d '.' -f 1-2 > gcc/BASE-VER
346
347 rm -rf obj-%{GCCDIST}
348 mkdir obj-%{GCCDIST}
349 cd obj-%{GCCDIST}
350 RPM_OPT_FLAGS="$RPM_OPT_FLAGS -U_FORTIFY_SOURCE"
351 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-fno-rtti//g' -e 's/-fno-exceptions//g' -e 's/-Wmissing-format-attribute//g' -e 's/-fstack-protector//g' -e 's/-ffortify=.//g' -e 's/-Wall//g' -e 's/-m32//g' -e 's/-m64//g'`
352 %ifarch %ix86
353 # -mcpu is superceded by -mtune but -mtune is not supported by
354 # our bootstrap compiler.  -mcpu gives a warning that stops
355 # the build process, so remove it for now.  Also remove all other
356 # -march and -mtune flags.  They are superseeded by proper
357 # default compiler settings now.
358 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-mcpu=i.86//g' -e 's/-march=i.86//g' -e 's/-mtune=i.86//g'`
359 %endif
360 %if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
361 # Kill all -march/tune/cpu because that screws building the target libs
362 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/-m\(arch\|tune\|cpu\)=[^ ]*//g'`
363 %endif
364 # Replace 2 spaces by one finally
365 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS|sed -e 's/  / /g'`
366
367 languages=c
368 %if %{build_cp}
369 languages=$languages,c++
370 %endif
371 %if %{build_objc}
372 languages=$languages,objc
373 %endif
374 %if %{build_fortran}
375 languages=$languages,fortran
376 %endif
377 %if %{build_objcp}
378 languages=$languages,obj-c++
379 %endif
380 %if %{build_java}
381 languages=$languages,java
382 %endif
383 %if %{build_ada}
384 languages=$languages,ada
385 %endif
386
387 J=%{?jobs:%jobs}
388 if test -z "$J"; then
389   J=$(getconf _NPROCESSORS_CONF)
390   JL=$(($J * 2))
391 else
392   test 1 -gt "$J" && J=1
393   JL=$(($(getconf _NPROCESSORS_CONF)*2))
394 fi
395 if test "$J" == "0"; then
396   J=1
397 fi
398 if test "$JL" == "0"; then
399   JL=1
400 fi
401 PARALLEL="-j$J -l$JL"
402
403 # we don't want some miscompiles in the testsuite, or some fault in
404 # the compiler to kill the machine.  Hence we limit the amount of memory
405 # by the physical RAM plus half of swap
406 #MEM=$(free -m | awk '/^Mem:/ {print $2}')
407 #SWAP=$(free -m | awk '/^Swap:/ {print $2}')
408 #ulimit -v $(((MEM + SWAP/2)*1024))
409
410 # In general we want to ship release checking enabled compilers
411 # and run BETA with checking enabled.
412 #ENABLE_CHECKING="--enable-checking=yes"
413 ENABLE_CHECKING="--enable-checking=release"
414
415 # Work around tail/head -1 changes
416 export _POSIX2_VERSION=199209
417
418 # configure tries to parse include/features.h to detect
419 # if glibc supports SSP.  When cross compiling we would need
420 # to install a cross glibc, which we don't, or make the whole
421 # thing point to the native glibc, which is in /, hence the
422 # --with-sysroot=/
423
424 %if %{build_ada}
425 # Using the host gnatmake like
426 #   CC="gcc%{hostsuffix}" GNATBIND="gnatbind%{hostsuffix}"
427 #   GNATMAKE="gnatmake%{hostsuffix}"
428 # doesn't work due to PR33857, so an un-suffixed gnatmake has to be
429 # available
430 mkdir -p host-tools/bin
431 cp -a /usr/bin/gnatmake%{hostsuffix} host-tools/bin/gnatmake
432 cp -a /usr/bin/gnatlink%{hostsuffix} host-tools/bin/gnatlink
433 cp -a /usr/bin/gnatbind%{hostsuffix} host-tools/bin/gnatbind
434 cp -a /usr/bin/gcc%{hostsuffix} host-tools/bin/gcc
435 ln -sf /usr/%{_lib} host-tools/%{_lib}
436 export PATH="`pwd`/host-tools/bin:$PATH"
437 %endif
438 #%if 0%{?gcc_target_arch:1} && 0%{!?gcc_icecream:1}
439 #%else
440 #       --enable-threads=posix \
441 #%endif
442 #       --enable-shared \
443 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" XCFLAGS="$RPM_OPT_FLAGS" \
444 TCFLAGS="$RPM_OPT_FLAGS" GCJFLAGS="$RPM_OPT_FLAGS" \
445 ../configure \
446         --prefix=%{_prefix} \
447         --infodir=%{_infodir} \
448         --mandir=%{_mandir} \
449         --libdir=%{_libdir} \
450         --libexecdir=%{_libdir} \
451         --enable-languages=$languages \
452         $ENABLE_CHECKING \
453         --with-gxx-include-dir=%{_prefix}/include/c++/%{gcc_dir_version} \
454         --enable-ssp \
455         --disable-libssp \
456         --disable-libitm \
457 %if 0%{?fast_build}
458         --disable-bootstrap \
459 %endif
460         --disable-plugin \
461         --with-bugurl="http://bugs.tizen.org/" \
462         --with-pkgversion="Tizen Linux" \
463 %if !%{build_libjava}
464         --disable-libgcj \
465 %else
466         --with-java-home=%{_libdir}/jvm/java-1.5.0-gcj%{binsuffix}-1.5.0.0/jre \
467         --with-ecj-jar=%{libsubdir}/ecj.jar \
468         --disable-java-awt \
469 %if !%{biarch_libjava}
470         --disable-libjava-multilib \
471 %endif
472 %endif
473 %if !%{build_with_mudflap}
474         --disable-libmudflap \
475 %endif
476         --with-slibdir=/%{_lib} \
477         --with-system-zlib \
478         --enable-__cxa_atexit \
479         --enable-libstdcxx-allocator=new \
480         --disable-libstdcxx-pch \
481         --enable-version-specific-runtime-libs \
482         --enable-linker-build-id \
483 %if 0%{?gcc_target_arch:1}
484 %if 0%{?gcc_icecream:1}
485         --with-build-sysroot=/ \
486         --with-sysroot=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi} \
487         --with-gxx-include-dir=%{_prefix}/%{gcc_target_arch}%{?canonical_target_abi:%canonical_target_abi}/usr/include/c++/%{gcc_dir_version} \
488         --enable-linux-futex \
489 %endif
490 %if 0%{?canonical_target:1}
491         --with-build-time-tools=/usr/%{canonical_target}-tizen-linux%{?canonical_target_abi:%canonical_target_abi}/bin \
492 %endif
493 %if 0%{?build_static:1}
494         --disable-shared \
495 %endif
496 %if "%{TARGET_ARCH}" == "spu"
497         --with-sysroot=/usr/spu \
498         --with-gxx-include-dir=%{_prefix}/spu/include/c++/%{gcc_dir_version} \
499         --with-newlib \
500 %endif
501         --disable-nls \
502         --target=%{CONFIGURE_TARGET} \
503 %else
504         --program-suffix=%{binsuffix} \
505         --enable-linux-futex \
506 %ifarch ia64
507         --with-system-libunwind \
508 %else
509         --without-system-libunwind \
510 %endif
511 %endif
512 %if "%{TARGET_ARCH}" == "armv5tel"
513         --with-arch=armv5te \
514         --with-float=soft \
515         --with-mode=arm \
516         --with-abi=aapcs-linux \
517         --disable-sjlj-exceptions \
518 %endif
519 %if "%{TARGET_ARCH}" == "armv7el" 
520         --with-arch=armv7-a \
521         --with-tune=cortex-a9 \
522         --with-float=soft \
523         --with-abi=softfp \
524         --with-fpu=vfpv3 \
525         --disable-sjlj-exceptions \
526 %endif
527 %if "%{TARGET_ARCH}" == "armv7l" || "%{TARGET_ARCH}" == "armv7hl"
528         --with-arch=armv7-a \
529         --with-tune=cortex-a9 \
530         --with-float=hard \
531         --with-abi=aapcs-linux \
532         --with-fpu=vfpv3-d16 \
533         --disable-sjlj-exceptions \
534 %endif
535 %if "%{TARGET_ARCH}" == "i586"
536         --with-arch-32=i586 \
537         --with-tune=generic \
538 %endif
539 %if "%{TARGET_ARCH}" == "x86_64"
540         --with-arch-32=i586 \
541         --with-tune=generic \
542 %endif
543         --build=%{GCCDIST}
544
545 # COMMON-END
546
547 %if 0%{?building_libffi:1}
548 make stage1-bubble $PARALLEL
549 make all-target-libffi $PARALLEL
550 %else
551 # Only run profiled bootstrap on archs where it works
552 #%ifarch %ix86 x86_64 ppc ppc64 ia64
553 #make profiledbootstrap-lean STAGE1_CFLAGS="-O -g" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
554 #%else
555 %ifarch %arm
556 STAGE1_FLAGS="-O0"
557 %else
558 STAGE1_FLAGS="-O -g"
559 %endif
560 #make bootstrap-lean STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
561 make STAGE1_CFLAGS="$STAGE1_FLAGS" BOOT_CFLAGS="$RPM_OPT_FLAGS" $PARALLEL
562 #%endif
563 #make -C gcc proto
564 make info
565 %if 0%{?run_tests:1}
566 echo "Run testsuite"
567 (make -C %{GCCDIST}/libstdc++-v3 check-abi || true)
568 mv %{GCCDIST}/libstdc++-v3/testsuite/libstdc++.log %{GCCDIST}/libstdc++-v3/testsuite/libstdc++-abi.log
569 mv %{GCCDIST}/libstdc++-v3/testsuite/libstdc++.sum %{GCCDIST}/libstdc++-v3/testsuite/libstdc++-abi.sum
570 make -k check $PARALLEL || true
571 mkdir ../testresults
572 ../contrib/test_summary | tee ../testresults/test_summary.txt
573 %endif
574 %endif
575
576 %install
577 export NO_BRP_CHECK_BYTECODE_VERSION=true
578 cd obj-%{GCCDIST}
579 %if 0%{?run_tests:1} 
580 cp `find . -name "*.sum"` ../testresults/
581 cp `find . -name "*.log"  \! -name "config.log" | grep -v 'acats.\?/tests' ` ../testresults/
582 chmod 644 ../testresults/*
583 %endif
584
585 %if 0%{?run_tests:1}
586 %files 
587 %defattr(-,root,root)
588 %doc testresults/test_summary.txt
589 %doc testresults/*.sum
590 %doc testresults/*.log
591 %endif
592
593
594 %changelog