Update to 4.8
[platform/upstream/gcc.git] / packaging / gcc.spec
1 Name:           gcc
2 %define separate_bi32 0
3 %define separate_bi64 0
4 %ifarch ppc
5 %define separate_bi64 1
6 %endif
7 %ifarch x86_64 s390x ppc64
8 %define separate_bi32 1
9 %endif
10 Url:            http://gcc.gnu.org/
11 %define gcc_version 48
12 %define gcc_suffix 4.8
13 Version:        4.8
14 Release:        0
15 VCS:            platform/upstream/gcc#submit/tizen/20130710.130950-0-g53ff3a85824df4cdadecc563ddb81c5a021bcc0b
16 Summary:        The system GNU C Compiler
17 License:        GPL-3.0+
18 Group:          Development/Toolchain
19 Provides:       c_compiler
20 Obsoletes:      gcc-mudflap
21 Requires:       cpp
22 Requires:       gcc%{gcc_version}
23 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
24 Source:         cpp
25 Source99:       README.packaging
26
27 %description
28 The system GNU C Compiler.
29
30
31
32 %package -n gcc-32bit
33 Summary:        The system GNU C Compiler
34 License:        GPL-3.0+
35 Requires:       gcc = %{version}
36 Requires:       gcc%{gcc_version}-32bit
37
38 %description -n gcc-32bit
39 The system GNU C Compiler.
40
41
42
43 %package -n gcc-64bit
44 Summary:        The system GNU C Compiler
45 License:        GPL-3.0+
46 Requires:       gcc = %{version}
47 Requires:       gcc%{gcc_version}-64bit
48
49 %description -n gcc-64bit
50 The system GNU C Compiler.
51
52
53
54 %package -n cpp
55 Summary:        The system GNU Preprocessor
56 License:        GPL-3.0+
57 Requires:       cpp%{gcc_version}
58
59 %description -n cpp
60 The system GNU Preprocessor.
61
62
63
64 %package -n gcc-locale
65 Summary:        The system GNU Compiler locale files
66 License:        GPL-3.0+
67 Requires:       gcc%{gcc_version}-locale
68
69 %description -n gcc-locale
70 The system GNU Compiler locale files.
71
72
73
74 %package -n gcc-info
75 Summary:        The system GNU Compiler documentation
76 License:        GFDL-1.2
77 Requires:       gcc%{gcc_version}-info
78
79 %description -n gcc-info
80 The system GNU Compiler documentation.
81
82 # There is intentionally no postun with install_info_delete as there
83 # is no way to just remove the aliased entries.  The content owners
84 # install_info_delete will also remove the aliases though.
85 # install-info does not pick up descriptions from the content.
86
87 %package -n gcc-c++
88 Summary:        The system GNU C++ Compiler
89 License:        GPL-3.0+
90 Provides:       c++_compiler
91 Requires:       gcc = %{version}
92 Requires:       gcc%{gcc_version}-c++
93
94 %description -n gcc-c++
95 The system GNU C++ Compiler.
96
97
98 %package -n gcc-c++-32bit
99 Summary:        The system GNU C++ Compiler
100 License:        GPL-3.0+
101 Requires:       gcc-32bit = %{version}
102 Requires:       gcc-c++ = %{version}
103 Requires:       libstdc++%{gcc_version}-devel-32bit
104
105 %description -n gcc-c++-32bit
106 The system GNU C++ Compiler 32 bit support.
107
108
109 %package -n gcc-c++-64bit
110 Summary:        The system GNU C++ Compiler
111 License:        GPL-3.0+
112 Requires:       gcc-64bit = %{version}
113 Requires:       gcc-c++ = %{version}
114 Requires:       libstdc++%{gcc_version}-devel-64bit
115
116 %description -n gcc-c++-64bit
117 The system GNU C++ Compiler 64 bit support.
118
119
120
121 %package -n libstdc++-devel
122 Summary:        The system GNU C++ development files
123 License:        GPL-3.0-with-GCC-exception
124 Requires:       libstdc++%{gcc_version}-devel
125
126 %description -n libstdc++-devel
127 The system GNU C++ development files.
128
129
130
131 %package -n gcc-fortran
132 Summary:        The system GNU Fortran Compiler
133 License:        GPL-3.0+
134 Requires:       gcc = %{version}
135 Requires:       gcc%{gcc_version}-fortran
136
137 %description -n gcc-fortran
138 The system GNU Fortran Compiler.
139
140
141 %package -n gcc-fortran-32bit
142 Summary:        The system GNU Fortran Compiler
143 License:        GPL-3.0+
144 Requires:       gcc%{gcc_version}-fortran-32bit
145 Requires:       gcc-fortran = %{version}
146
147 %description -n gcc-fortran-32bit
148 The system GNU Fortran Compiler 32 bit support.
149
150
151 %package -n gcc-fortran-64bit
152 Summary:        The system GNU Fortran Compiler
153 License:        GPL-3.0+
154 Requires:       gcc%{gcc_version}-fortran-64bit
155 Requires:       gcc-fortran = %{version}
156
157 %description -n gcc-fortran-64bit
158 The system GNU Fortran Compiler 64 bit support.
159
160
161 %package -n gcc-java
162 Summary:        The system GNU Java Compiler
163 License:        GPL-3.0+
164 Requires:       gcc%{gcc_version}-java
165 Requires:       libgcj-devel = %{version}
166 Recommends:     gcc-gij = %{version}
167 Requires:       gcc = %{version}
168
169 %description -n gcc-java
170 The system GNU Java Compiler.
171
172
173
174 %package -n libgcj-devel
175 Summary:        The system GNU Java development files.
176 License:        GPL-2.0-with-classpath-exception
177 Requires:       libgcj%{gcc_version}-devel
178
179 %description -n libgcj-devel
180 The system GNU Java development files.
181
182
183
184 %package -n gcc-gij
185 Summary:        The system GNU Java bytecode interpreter
186 License:        GPL-2.0+
187 Requires:       gcc%{gcc_version}-gij
188
189 %description -n gcc-gij
190 The system GNU Java bytecode interpreter.
191
192
193
194 %package -n gcc-gij-32bit
195 Summary:        The system GNU Java bytecode interpreter
196 License:        GPL-2.0+
197 Requires:       gcc%{gcc_version}-gij-32bit
198
199 %description -n gcc-gij-32bit
200 The system GNU Java bytecode interpreter as 32 bit application.
201
202
203
204 %package -n gcc-gij-64bit
205 Summary:        The system GNU Java bytecode interpreter
206 License:        GPL-2.0+
207 Requires:       gcc%{gcc_version}-gij-64bit
208
209 %description -n gcc-gij-64bit
210 The system GNU Java bytecode interpreter as 64 bit application.
211
212
213
214 %package -n gcc-objc
215 Summary:        The system GNU Objective C Compiler
216 License:        GPL-3.0+
217 Requires:       gcc = %{version}
218 Requires:       gcc%{gcc_version}-objc
219 %ifarch ppc64
220 Obsoletes:      gcc-objc-64bit
221 %endif
222
223 %description -n gcc-objc
224 The system GNU Objective C Compiler.
225
226
227
228 %package -n gcc-objc-32bit
229 Summary:        The system GNU Objective C Compiler
230 License:        GPL-3.0+
231 Requires:       gcc%{gcc_version}-objc-32bit
232 Requires:       gcc-objc = %{version}
233
234 %description -n gcc-objc-32bit
235 The system GNU Objective C Compiler 32 bit support.
236
237
238
239 %package -n gcc-objc-64bit
240 Summary:        The system GNU Objective C Compiler
241 License:        GPL-3.0+
242 Requires:       gcc%{gcc_version}-objc-64bit
243 Requires:       gcc-objc = %{version}
244
245 %description -n gcc-objc-64bit
246 The system GNU Objective C Compiler 64 bit support.
247
248
249
250 %package -n gcc-obj-c++
251 Summary:        The system GNU Objective C++ Compiler
252 License:        GPL-3.0+
253 Requires:       gcc%{gcc_version}-obj-c++
254 Requires:       gcc-objc = %{version}
255
256 %description -n gcc-obj-c++
257 The system GNU Objective C++ Compiler.
258
259
260
261 %package -n gcc-ada
262 Summary:        The system GNU Ada Compiler
263 License:        GPL-3.0+
264 Requires:       gcc = %{version}
265 Requires:       gcc%{gcc_version}-ada
266
267 %description -n gcc-ada
268 The system GNU Ada Compiler.
269
270
271 %package -n gcc-z9
272 Summary:        The system GNU C Compiler
273 License:        GPL-3.0+
274 Requires:       gcc
275
276 %description -n gcc-z9
277 The system GNU C Compiler.
278
279
280 %prep 
281
282 %build
283 echo "This is a dummy package to provide a dependency on the system compiler." > README
284
285 %install
286 mkdir -p $RPM_BUILD_ROOT/lib
287 mkdir -p $RPM_BUILD_ROOT%{_prefix}/bin
288 mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
289 mkdir -p $RPM_BUILD_ROOT%{_prefix}/share/doc/packages/gcc-objc/
290 mkdir -p $RPM_BUILD_ROOT%{_prefix}/share/doc/packages/gcc-obj-c++/
291 # Link all the binaries
292 for program in \
293         gcc gcov \
294         g++ \
295         cpp \
296         gcj gcjh gcj-dbtool jcf-dump jv-convert gc-analyze \
297         gij \
298         gappletviewer \
299         gjar gjarsigner gjavah gkeytool gnative2ascii gorbd grmic \
300         grmid grmiregistry gserialver gtnameserv \
301 %if %{separate_bi32}
302         grmiregistry32 \
303         gij32 \
304 %endif
305 %if %{separate_bi64}
306         grmiregistry64 \
307         gij64 \
308 %endif
309         gfortran \
310         gnat gnatbind gnatbl gnatchop gnatclean gnatfind gnatkr \
311         gnatlink gnatls gnatmake gnatname gnatprep gnatxref gprmake \
312     ; do
313   ln -sf $program-%{gcc_suffix} $RPM_BUILD_ROOT%{_prefix}/bin/$program
314 done
315 # Link section 1 manpages
316 for man1 in \
317         gcc gcov \
318         g++ \
319         cpp \
320         gfortran \
321         gcj gcjh gcj-dbtool jcf-dump jv-convert gc-analyze \
322         gij \
323         gappletviewer gjar gjarsigner gjavah \
324         gkeytool gnative2ascii gorbd grmic grmid grmiregistry gserialver \
325         gtnameserv \
326     ; do
327   ln -sf $man1-%{gcc_suffix}.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/$man1.1.gz
328 done
329 # Provide the traditional /lib/cpp that only handles C
330 cp $RPM_SOURCE_DIR/cpp $RPM_BUILD_ROOT/lib/
331 chmod 755 $RPM_BUILD_ROOT/lib/cpp
332 # Provide extra symlinks
333 ln -sf g++-%{gcc_suffix} $RPM_BUILD_ROOT%{_prefix}/bin/c++
334 ln -sf gcc-%{gcc_suffix} $RPM_BUILD_ROOT%{_prefix}/bin/cc
335 ln -sf g++-%{gcc_suffix}.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/c++.1.gz
336 ln -sf gcc-%{gcc_suffix}.1.gz $RPM_BUILD_ROOT%{_mandir}/man1/cc.1.gz
337 %ifarch s390 s390x
338 dir=`gcc-%{gcc_suffix} -print-prog-name=cc1`
339 dir=${dir%/cc1}
340 mkdir -p $RPM_BUILD_ROOT/$dir
341 cat > $RPM_BUILD_ROOT/$dir/defaults.spec <<EOF
342 *default_spec:
343 %{!mtune=*:-mtune=z10} %{!march=*:-march=z9-109}
344 EOF
345 %endif
346
347 %files
348 %defattr(-,root,root)
349 %{_prefix}/bin/gcc
350 %{_prefix}/bin/cc
351 %{_prefix}/bin/gcov
352 %doc %{_mandir}/man1/gcc.1.gz
353 %doc %{_mandir}/man1/cc.1.gz
354 %doc %{_mandir}/man1/gcov.1.gz
355
356 %files -n cpp
357 %defattr(-,root,root)
358 /lib/cpp
359 %{_prefix}/bin/cpp
360 %doc %{_mandir}/man1/cpp.1.gz
361
362 %files -n gcc-c++
363 %defattr(-,root,root)
364 %{_prefix}/bin/g++
365 %{_prefix}/bin/c++
366 %doc %{_mandir}/man1/g++.1.gz
367 %doc %{_mandir}/man1/c++.1.gz
368
369 %files -n gcc-fortran
370 %defattr(-,root,root)
371 %{_prefix}/bin/gfortran
372 %doc %{_mandir}/man1/gfortran.1.gz
373
374 %files -n gcc-java
375 %defattr(-,root,root)
376 %{_prefix}/bin/gcj
377 %{_prefix}/bin/gcjh
378 %{_prefix}/bin/gcj-dbtool
379 %{_prefix}/bin/jcf-dump
380 %{_prefix}/bin/jv-convert
381 %{_prefix}/bin/gc-analyze
382 %doc %{_mandir}/man1/gcj.1.gz
383 %doc %{_mandir}/man1/gcjh.1.gz
384 %doc %{_mandir}/man1/gcj-dbtool.1.gz
385 %doc %{_mandir}/man1/jcf-dump.1.gz
386 %doc %{_mandir}/man1/jv-convert.1.gz
387 %doc %{_mandir}/man1/gc-analyze.1.gz
388
389 %files -n gcc-gij
390 %defattr(-,root,root)
391 %{_prefix}/bin/gij
392 %{_prefix}/bin/gappletviewer
393 %{_prefix}/bin/gjar
394 %{_prefix}/bin/gjarsigner
395 %{_prefix}/bin/gjavah
396 %{_prefix}/bin/gkeytool
397 %{_prefix}/bin/gnative2ascii
398 %{_prefix}/bin/gorbd
399 %{_prefix}/bin/grmic
400 %{_prefix}/bin/grmid
401 %{_prefix}/bin/grmiregistry
402 %{_prefix}/bin/gserialver
403 %{_prefix}/bin/gtnameserv
404 %doc %{_mandir}/man1/gij.1.gz
405 %doc %{_mandir}/man1/gappletviewer.1.gz
406 %doc %{_mandir}/man1/gjar.1.gz
407 %doc %{_mandir}/man1/gjarsigner.1.gz
408 %doc %{_mandir}/man1/gjavah.1.gz
409 %doc %{_mandir}/man1/gkeytool.1.gz
410 %doc %{_mandir}/man1/gnative2ascii.1.gz
411 %doc %{_mandir}/man1/gorbd.1.gz
412 %doc %{_mandir}/man1/grmic.1.gz
413 %doc %{_mandir}/man1/grmid.1.gz
414 %doc %{_mandir}/man1/grmiregistry.1.gz
415 %doc %{_mandir}/man1/gserialver.1.gz
416 %doc %{_mandir}/man1/gtnameserv.1.gz
417
418 %files -n gcc-objc
419 %defattr(-,root,root)
420 # empty - only for the dependency
421 %doc README
422
423 %files -n gcc-obj-c++
424 %defattr(-,root,root)
425 # empty - only for the dependency
426 %doc README
427
428 %files -n gcc-locale
429 %defattr(-,root,root)
430 # empty - only for the dependency
431 %doc README
432
433 %files -n gcc-info
434 %defattr(-,root,root)
435 # empty - only for the dependency
436 %doc README
437
438 %files -n gcc-ada
439 %defattr(-,root,root)
440 %{_prefix}/bin/gnat
441 %{_prefix}/bin/gnatbind
442 %{_prefix}/bin/gnatbl
443 %{_prefix}/bin/gnatchop
444 %{_prefix}/bin/gnatclean
445 %{_prefix}/bin/gnatfind
446 %{_prefix}/bin/gnatkr
447 %{_prefix}/bin/gnatlink
448 %{_prefix}/bin/gnatls
449 %{_prefix}/bin/gnatmake
450 %{_prefix}/bin/gnatname
451 %{_prefix}/bin/gnatprep
452 %{_prefix}/bin/gnatxref
453 %{_prefix}/bin/gprmake
454
455 %files -n libstdc++-devel
456 %defattr(-,root,root)
457 # empty - only for the dependency
458 %doc README
459
460 %files -n libgcj-devel
461 %defattr(-,root,root)
462 # empty - only for the dependency
463 %doc README
464
465 %if %{separate_bi32}
466
467 %files -n gcc-32bit
468 %defattr(-,root,root)
469 # empty - only for the dependency
470 %doc README
471
472 %files -n gcc-c++-32bit
473 %defattr(-,root,root)
474 # empty - only for the dependency
475 %doc README
476
477 %files -n gcc-fortran-32bit
478 %defattr(-,root,root)
479 # empty - only for the dependency
480 %doc README
481
482 %files -n gcc-objc-32bit
483 %defattr(-,root,root)
484 # empty - only for the dependency
485 %doc README
486
487 %files -n gcc-gij-32bit
488 %defattr(-,root,root)
489 %{_prefix}/bin/gij32
490 %{_prefix}/bin/grmiregistry32
491
492 %endif
493 %if %{separate_bi64}
494
495 %files -n gcc-64bit
496 %defattr(-,root,root)
497 # empty - only for the dependency
498 %doc README
499
500 %files -n gcc-c++-64bit
501 %defattr(-,root,root)
502 # empty - only for the dependency
503 %doc README
504
505 %files -n gcc-fortran-64bit
506 %defattr(-,root,root)
507 # empty - only for the dependency
508 %doc README
509
510 %files -n gcc-objc-64bit
511 %defattr(-,root,root)
512 # empty - only for the dependency
513 %doc README
514
515 %files -n gcc-gij-64bit
516 %defattr(-,root,root)
517 %{_prefix}/bin/gij64
518 %{_prefix}/bin/grmiregistry64
519
520 %endif
521 %ifarch s390 s390x
522
523 %files -n gcc-z9
524 %defattr(-,root,root)
525 /usr/lib*/gcc/*-suse-linux/*/defaults.spec
526 %endif
527
528 %changelog