Install license file to /usr/share/licenses
[platform/upstream/fuse.git] / packaging / fuse.spec
1 Name:           fuse
2 Summary:        User space File System
3 License:        GPL-2.0 and LGPL-2.1
4 Group:          System/Libraries
5 Version:        2.9.6
6 Release:        0
7 Source:         %{name}-%{version}.tar.gz
8 Source2:        fuse.rpmlintrc
9 Source98:       baselibs.conf
10 Source1001:     fuse.manifest
11 Url:            http://fuse.sourceforge.net
12 Requires:       util-linux >= 2.18
13 Requires:       which
14 BuildRequires:  pkgconfig
15 Supplements:    filesystem(fuse)
16
17 %description
18 With FUSE, a user space program can export a file system through the
19 kernel-default (Linux kernel).
20
21 User space file systems which are implemented using FUSE are provided
22 by the following packages:
23
24 - curlftpfs (mount FTP servers),
25
26 - encfs (layered file encryption),
27
28 - fuseiso (mount iso, img, bin, mdf and nrg CD-ROM images),
29
30 - fusepod (mount iPods),
31
32 - fusesmb (mount a fully browseable network neighborhood),
33
34 - gphotofs (mount gphoto-supported cameras),
35
36 - ntfs-3g (mount NTFS volumes read-write),
37
38 - obexfs (mount of bluetooth devices),
39
40 - sshfs (mount over ssh),
41
42 - wdfs (mount of WebDAV shares)
43
44 This package contains the mount binaries for fuse (might not be needed
45 by some FUSE filesystems like ntfs-3g) and the documentation for FUSE.
46
47 After installing fuse-devel, administrators can compile and install
48 other user space file systems which can be found at
49 http://fuse.sourceforge.net/wiki
50
51 %package -n libulockmgr
52 Summary:        Library of FUSE, the User space File System for GNU/Linux and BSD
53
54 %description -n libulockmgr
55 With FUSE, a user space program can export a file system through the
56 kernel-default (Linux kernel).
57
58 %package -n libfuse
59 Summary:        Library of FUSE, the User space File System for GNU/Linux and BSD
60
61 %description -n libfuse
62 With FUSE, a user space program can export a file system through the
63 kernel-default (Linux kernel).
64
65 A FUSE file system which only needs libfuse is ntfs-3g, other FUSE
66 file systems might need the fuse package in addition to have fusermount
67 and /sbin/mount.fuse.
68
69 After installing fuse-devel, administrators can compile and install
70 other user space file systems which can be found at
71 http://fuse.sourceforge.net/wiki
72
73 %package devel
74 Summary:        Development package for FUSE (userspace filesystem) modules
75 Requires:       fuse = %{version}
76 Requires:       glibc-devel
77 Requires:       libfuse = %{version}
78 Requires:       libulockmgr = %{version}
79
80 %description devel
81 This package contains all include files, libraries and configuration
82 files needed to develop programs that use the fuse (FUSE) library to
83 implement kernel-default (Linux) file systems in user space.
84
85 With fuse-devel, administrators can compile and install other user
86 space file systems which can be found at
87 http://fuse.sourceforge.net/wiki
88
89 %prep
90 %setup -q
91 cp %{SOURCE1001} .
92
93 %build
94 export CFLAGS="$RPM_OPT_FLAGS -g -fno-strict-aliasing"
95 export MOUNT_FUSE_PATH=%{_sbindir}
96 %configure --with-pic \
97     --with-pkgconfigdir=%{_libdir}/pkgconfig \
98     --enable-lib \
99     --disable-example \
100     --enable-static
101 make %{?_smp_mflags}
102
103 %install
104 %make_install
105 rm -rf $RPM_BUILD_ROOT/%{_sysconfdir}/init.d
106
107 %post -n libfuse -p /sbin/ldconfig
108
109 %postun -n libfuse -p /sbin/ldconfig
110
111 %post -n libulockmgr -p /sbin/ldconfig
112
113 %postun -n libulockmgr -p /sbin/ldconfig
114
115
116 %docs_package
117
118 %files
119 %manifest %{name}.manifest
120 %defattr(-,root,root)
121 %license COPYING*
122 %verify(not mode) %attr(4755,root,root) %{_bindir}/fusermount
123 %{_sbindir}/mount.fuse
124 %{_bindir}/ulockmgr_server
125 /etc/udev/rules.d/99-fuse.rules
126
127 %files -n libfuse
128 %manifest %{name}.manifest
129 %defattr(-,root,root)
130 %license COPYING.LIB
131 %{_libdir}/libfuse.so.2*
132
133 %files -n libulockmgr
134 %manifest %{name}.manifest
135 %defattr(-,root,root)
136 %{_libdir}/libulockmgr.so.*
137
138 %files devel
139 %manifest %{name}.manifest
140 %defattr(-,root,root)
141 %{_libdir}/libfuse.so
142 %{_libdir}/libulockmgr.so
143 %{_includedir}/fuse.h
144 %{_includedir}/fuse
145 %{_libdir}/pkgconfig/*.pc
146 %{_includedir}/ulockmgr.h