Clarify license declaration for each package
[platform/upstream/fuse.git] / packaging / fuse.spec
1 Name:           fuse
2 Summary:        User space File System
3 License:        GPL-2.0 and LGPL-2.1
4 Group:          System/Libraries
5 Version:        2.9.6
6 Release:        0
7 Source:         %{name}-%{version}.tar.gz
8 Source2:        fuse.rpmlintrc
9 Source98:       baselibs.conf
10 Source1001:     fuse.manifest
11 Url:            http://fuse.sourceforge.net
12 Requires:       util-linux >= 2.18
13 Requires:       which
14 BuildRequires:  pkgconfig
15 Supplements:    filesystem(fuse)
16
17 %description
18 With FUSE, a user space program can export a file system through the
19 kernel-default (Linux kernel).
20
21 User space file systems which are implemented using FUSE are provided
22 by the following packages:
23
24 - curlftpfs (mount FTP servers),
25
26 - encfs (layered file encryption),
27
28 - fuseiso (mount iso, img, bin, mdf and nrg CD-ROM images),
29
30 - fusepod (mount iPods),
31
32 - fusesmb (mount a fully browseable network neighborhood),
33
34 - gphotofs (mount gphoto-supported cameras),
35
36 - ntfs-3g (mount NTFS volumes read-write),
37
38 - obexfs (mount of bluetooth devices),
39
40 - sshfs (mount over ssh),
41
42 - wdfs (mount of WebDAV shares)
43
44 This package contains the mount binaries for fuse (might not be needed
45 by some FUSE filesystems like ntfs-3g) and the documentation for FUSE.
46
47 After installing fuse-devel, administrators can compile and install
48 other user space file systems which can be found at
49 http://fuse.sourceforge.net/wiki
50
51 %package -n libulockmgr
52 Summary:        Library of FUSE, the User space File System for GNU/Linux and BSD
53 License:        LGPL-2.1
54
55 %description -n libulockmgr
56 With FUSE, a user space program can export a file system through the
57 kernel-default (Linux kernel).
58
59 %package -n libfuse
60 Summary:        Library of FUSE, the User space File System for GNU/Linux and BSD
61 License:        LGPL-2.1
62
63 %description -n libfuse
64 With FUSE, a user space program can export a file system through the
65 kernel-default (Linux kernel).
66
67 A FUSE file system which only needs libfuse is ntfs-3g, other FUSE
68 file systems might need the fuse package in addition to have fusermount
69 and /sbin/mount.fuse.
70
71 After installing fuse-devel, administrators can compile and install
72 other user space file systems which can be found at
73 http://fuse.sourceforge.net/wiki
74
75 %package devel
76 Summary:        Development package for FUSE (userspace filesystem) modules
77 License:        LGPL-2.1
78 Requires:       fuse = %{version}
79 Requires:       glibc-devel
80 Requires:       libfuse = %{version}
81 Requires:       libulockmgr = %{version}
82
83 %description devel
84 This package contains all include files, libraries and configuration
85 files needed to develop programs that use the fuse (FUSE) library to
86 implement kernel-default (Linux) file systems in user space.
87
88 With fuse-devel, administrators can compile and install other user
89 space file systems which can be found at
90 http://fuse.sourceforge.net/wiki
91
92 %prep
93 %setup -q
94 cp %{SOURCE1001} .
95
96 %build
97 export CFLAGS="$RPM_OPT_FLAGS -g -fno-strict-aliasing"
98 export MOUNT_FUSE_PATH=%{_sbindir}
99 %configure --with-pic \
100     --with-pkgconfigdir=%{_libdir}/pkgconfig \
101     --enable-lib \
102     --disable-example \
103     --enable-static
104 make %{?_smp_mflags}
105
106 %install
107 %make_install
108 rm -rf $RPM_BUILD_ROOT/%{_sysconfdir}/init.d
109
110 %post -n libfuse -p /sbin/ldconfig
111
112 %postun -n libfuse -p /sbin/ldconfig
113
114 %post -n libulockmgr -p /sbin/ldconfig
115
116 %postun -n libulockmgr -p /sbin/ldconfig
117
118
119 %docs_package
120
121 %files
122 %manifest %{name}.manifest
123 %defattr(-,root,root)
124 %license COPYING*
125 %verify(not mode) %attr(4755,root,root) %{_bindir}/fusermount
126 %{_sbindir}/mount.fuse
127 %{_bindir}/ulockmgr_server
128 /etc/udev/rules.d/99-fuse.rules
129
130 %files -n libfuse
131 %manifest %{name}.manifest
132 %defattr(-,root,root)
133 %license COPYING.LIB
134 %{_libdir}/libfuse.so.2*
135
136 %files -n libulockmgr
137 %manifest %{name}.manifest
138 %defattr(-,root,root)
139 %license COPYING.LIB
140 %{_libdir}/libulockmgr.so.*
141
142 %files devel
143 %manifest %{name}.manifest
144 %defattr(-,root,root)
145 %license COPYING.LIB
146 %{_libdir}/libfuse.so
147 %{_libdir}/libulockmgr.so
148 %{_includedir}/fuse.h
149 %{_includedir}/fuse
150 %{_libdir}/pkgconfig/*.pc
151 %{_includedir}/ulockmgr.h