resetting manifest requested domain to floor
[platform/upstream/freeglut.git] / packaging / freeglut.spec
1 %define debug 0
2
3 Name:           freeglut
4 Version:        2.8.0
5 Release:        0
6 License:        MIT
7 Summary:        Freely licensed alternative to the GLUT library
8 Url:            http://freeglut.sourceforge.net/
9 Group:          System/Libraries
10 Source:         %{name}-%{version}.tar.bz2
11 Source1001:     freeglut.manifest
12 BuildRequires:  gcc-c++
13 BuildRequires:  libtool
14 BuildRequires:  mesa-devel
15 BuildRequires:  pkgconfig
16 BuildRequires:  pkgconfig(glu)
17 BuildRequires:  pkgconfig(libdrm)
18 BuildRequires:  pkgconfig(xi)
19
20 %description
21 Freeglut is a completely open source alternative to the OpenGL Utility
22 Toolkit (GLUT) library. GLUT was originally written by Mark Kilgard to
23 support the sample programs in the second edition OpenGL Redbook. Since
24 then, GLUT has been used in a wide variety of practical applications
25 because it is simple, universally available, and highly portable.
26
27 GLUT (and freeglut) allow the user to create and manage windows
28 containing OpenGL contexts and also read the mouse, keyboard, and
29 joystick functions on a wide range of platforms.
30
31 %package -n libglut
32 Summary:        Freely licensed alternative to the GLUT library
33 Group:          Development/Libraries/X11
34
35 %description -n libglut
36 Freeglut is a completely open source alternative to the OpenGL Utility
37 Toolkit (GLUT) library. GLUT was originally written by Mark Kilgard to
38 support the sample programs in the second edition OpenGL Redbook. Since
39 then, GLUT has been used in a wide variety of practical applications
40 because it is simple, universally available, and highly portable.
41
42 GLUT (and freeglut) allow the user to create and manage windows
43 containing OpenGL contexts and also read the mouse, keyboard, and
44 joystick functions on a wide range of platforms.
45
46 %package devel
47 Summary:        Development libraries, includes and man pages for freeglut (GLUT Library)
48 Group:          Development/Libraries/X11
49 Requires:       libglut = %{version}
50 Requires:       mesa-devel
51
52 %description devel
53 This package contains all necessary include files and libraries needed
54 to compile and link applications for the freeglut library.
55
56 In addition, it also includes manual pages which describe all functions
57 provided by the freeglut library.
58
59 Freeglut is a completely open source alternative to the OpenGL Utility
60 Toolkit (GLUT) library. GLUT was originally written by Mark Kilgard to
61 support the sample programs in the second edition OpenGL Redbook. Since
62 then, GLUT has been used in a wide variety of practical applications
63 because it is simple, universally available, and highly portable.
64
65 GLUT (and freeglut) allow the user to create and manage windows
66 containing OpenGL contexts and also read the mouse, keyboard, and
67 joystick functions on a wide range of platforms.
68
69 %package demo
70 Summary:        Demonstration applications for the freeglut library
71 Group:          System/X11/Utilities
72
73 %description demo
74 This package contains demonstration applications for the freeglut library.
75
76 Freeglut is a completely open source alternative to the OpenGL Utility
77 Toolkit (GLUT) library. GLUT was originally written by Mark Kilgard to
78 support the sample programs in the second edition OpenGL Redbook. Since
79 then, GLUT has been used in a wide variety of practical applications
80 because it is simple, universally available, and highly portable.
81
82 GLUT (and freeglut) allow the user to create and manage windows
83 containing OpenGL contexts and also read the mouse, keyboard, and
84 joystick functions on a wide range of platforms.
85
86 %prep
87 %setup -q
88 cp %{SOURCE1001} .
89
90 %build
91 ./autogen.sh
92 %configure \
93   --enable-replace-glut \
94 %if %debug
95   --enable-debug \
96 %endif
97   --disable-static
98 make %{?_smp_mflags}  -C src
99 make %{?_smp_mflags}  -C include
100
101 %install
102 make install -C src DESTDIR=%{buildroot}
103 make install -C include DESTDIR=%{buildroot}
104 rm -rf %{buildroot}%{_libdir}/libglut.la
105
106 %post -n libglut -p /sbin/ldconfig
107
108 %postun -n libglut -p /sbin/ldconfig
109
110 %files  -n libglut
111 %manifest %{name}.manifest
112 %defattr(-,root,root)
113 %doc COPYING
114 %{_libdir}/libglut.so.*
115
116 %files devel
117 %manifest %{name}.manifest
118 %defattr(-,root,root)
119 %{_includedir}/GL
120 %{_libdir}/libglut.so