version up
[platform/upstream/fontsproto.git] / packaging / fontsproto.spec
1 %bcond_with x
2
3 Name:           fontsproto
4 Version:        2.1.3
5 Release:        1
6 License:        MIT
7 Summary:        X
8 Url:            http://www.x.org
9 Group:          Development/System
10 Source0:        %{name}-%{version}.tar.bz2
11 Source1001:     fontsproto.manifest
12
13 BuildRequires:  pkgconfig
14 BuildRequires:  pkgconfig(xorg-macros)
15
16 %if !%{with x}
17 ExclusiveArch:
18 %endif
19
20 %description
21 %{summary}.
22
23 %prep
24 %setup -q
25 cp %{SOURCE1001} .
26
27 %build
28 %autogen --disable-static \
29              --libdir=%{_datadir} \
30              --without-xmlto
31
32 make %{?_smp_mflags}
33
34 %install
35 %make_install
36
37 %remove_docs
38
39
40 %files
41 %manifest %{name}.manifest
42 %license COPYING
43 %defattr(-,root,root,-)
44 %{_includedir}/X11/fonts/*.h
45 %{_datadir}/pkgconfig/*.pc