b6810bde66270a8479c1195c993208eb668f9d93
[profile/ivi/flashrom.git] / packaging / flashrom.spec
1 #
2 # spec file for package flashrom
3 #
4 # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14
15 # Please submit bugfixes or comments via http://bugs.opensuse.org/
16 #
17
18
19 Name:           flashrom
20 Url:            http://coreboot.org/
21 Summary:        A universal flash programming utility
22 License:        GPL-2.0 ; GPL-2.0+
23 Group:          Development/Tools/Other
24 Version:        0.9.6.1
25 Release:        1
26 Source0:        flashrom-%{version}.tar.bz2
27 BuildRequires:  libpci-devel
28 BuildRequires:  zlib-devel
29
30 %description
31 flashrom is a utility for reading, writing, verifying and erasing flash ROM
32 chips. It's often used to flash BIOS/EFI/coreboot/firmware images in-system
33 using a supported mainboard, but it also supports flashing of network
34 cards (NICs), SATA controller cards, and other external devices which can
35 program flash chips.
36
37 It supports a wide range of DIP32, PLCC32, DIP8, SO8/SOIC8, TSOP32, and
38 TSOP40 chips, which use various protocols such as LPC, FWH, parallel flash,
39 or SPI.
40
41 %prep
42 %setup -q
43
44 %build
45 make %{?_smp_mflags}
46 gzip flashrom.8
47
48 %install
49
50 mkdir -p %{buildroot}/%{_sbindir}
51 mkdir -p %{buildroot}/%{_mandir}/man8
52 install -m 0755 flashrom %{buildroot}/%{_sbindir}
53 install -m 0644 flashrom.8.gz %{buildroot}/%{_mandir}/man8
54
55 %files
56 %defattr(-,root,root)
57 %doc COPYING
58 %doc README
59 %{_sbindir}/flashrom
60 %{_mandir}/man8/flashrom.8.gz
61