packging: Bump to version 1.3.0
[platform/upstream/flac.git] / packaging / flac.spec
1 Name:           flac
2 BuildRequires:  gcc-c++
3 BuildRequires:  gettext-tools
4 BuildRequires:  libogg-devel
5 BuildRequires:  libtool
6 BuildRequires:  pkg-config
7 %ifarch %{ix86}
8 BuildRequires:  nasm
9 %endif
10 Version:        1.3.0
11 Release:        0
12 License:        BSD-3-Clause
13 Summary:        Free Lossless Audio Codec
14 Url:            http://flac.sourceforge.net/
15 #X-Vcs-Url:     https://git.xiph.org/flac.git
16 Group:          Multimedia/Audio
17 Source:         %{name}-%{version}.tar.bz2
18 Source1001:     flac.manifest
19
20 %description
21 FLAC is an open source lossless audio codec developed by Josh Coalson.
22
23 %package -n libflac
24 Summary:        Free Lossless Audio Codec Library
25
26 %description -n libflac
27 This package contains the library for FLAC (Free Lossless Audio Codec)
28 developed by Josh Coalson.
29
30 %package -n libflac++
31 Summary:        Free Lossless Audio Codec Library
32
33 %description -n libflac++
34 This package contains the C++ library for FLAC (Free Lossless Audio
35 Codec) developed by Josh Coalson.
36
37 %package devel
38 Summary:        FLAC Library Development Package
39 Requires:       glibc-devel
40 Requires:       libflac = %{version}
41 Requires:       libflac = %{version}
42 Requires:       libstdc++-devel
43
44 %description devel
45 This package contains the files needed to compile programs that use the
46 FLAC library.
47
48 %prep
49 %setup -q
50 cp %{SOURCE1001} .
51
52 %build
53 %autogen
54 %define warn_flags -O3 -W -Wall -Wstrict-prototypes -Wformat-security
55 export CFLAGS="%{optflags} %{warn_flags}"
56 export CXXFLAGS="$CFLAGS"
57 %configure  --disable-thorough-tests --disable-exhaustive-tests\
58             --disable-xmms-plugin \
59             --disable-static \
60             --disable-rpath \
61             --with-pic \
62             --enable-sse
63
64 %__make %{?_smp_mflags}
65
66 %install
67 %make_install
68 rm -rf %{buildroot}%{_datadir}/doc/%{name}-%{version}
69
70 %post -n libflac -p /sbin/ldconfig
71
72 %postun -n libflac -p /sbin/ldconfig
73
74 %post -n libflac++ -p /sbin/ldconfig
75
76 %postun -n libflac++ -p /sbin/ldconfig
77
78 %files
79 %manifest %{name}.manifest
80 %defattr(-, root, root)
81 %license  COPYING.*
82 %{_bindir}/*
83 %{_mandir}/man*/*
84
85 %files -n libflac
86 %manifest %{name}.manifest
87 %defattr(-, root, root)
88 %{_libdir}/libFLAC.so.8*
89
90 %files -n libflac++
91 %manifest %{name}.manifest
92 %defattr(-, root, root)
93 %{_libdir}/libFLAC++.so.6*
94
95 %files devel
96 %manifest %{name}.manifest
97 %defattr(-, root, root)
98 %{_libdir}/lib*.so
99 %{_includedir}/*
100 %{_libdir}/pkgconfig/*.pc
101 %{_datadir}/aclocal/*.m4