Bump to expect 5.45.4
[platform/upstream/expect.git] / packaging / expect.spec
1 Name:           expect
2 Version:        5.45.4
3 Release:        0
4 Summary:        A Tool for Automating Interactive Programs
5 License:        Public-Domain
6 Group:          Development/Languages/Tcl
7 Url:            http://expect.nist.gov
8 Source:         %{name}%{version}.tar.gz
9 Source1:        expect-rpmlintrc
10 Source2:            add_pie_compile_option.patch
11 Source1001:     expect.manifest
12
13 BuildRequires:  autoconf
14 BuildRequires:  tcl-devel
15
16 %description
17 Expect is a tool primarily for automating interactive applications,
18 such as telnet, ftp, passwd, fsck, rlogin, tip, and more.  Expect
19 really makes this stuff trivial.  Expect is also useful for testing
20 these applications.  It is described in many books, articles, papers,
21 and FAQs.  There is an entire book on it available from O'Reilly.
22
23 %package devel
24 Summary:        Header Files and C API Documentation for expect
25 Group:          Development/Libraries/Tcl
26
27 %description devel
28 This package contains header files and documentation needed for linking
29 to expect from programs written in compiled languages like C, C++, etc.
30 This package is not needed for developing scripts that run under the
31 /usr/bin/expect interpreter, or any other Tcl interpreter with the
32 expect package loaded.
33
34 %prep
35 %setup -q -n %name%version
36 cp %{SOURCE1001} .
37 %{__patch} -p1 < %{SOURCE2}
38
39 %build
40 %reconfigure \
41         --with-tcl=%_libdir \
42         --with-tk=no_tk \
43         --with-tclinclude=%_includedir \
44         --enable-shared
45
46 make %{?_smp_mflags} all
47
48 # %check
49 # make test
50
51 %install
52 make install DESTDIR=$RPM_BUILD_ROOT
53 # Remove some executables and manpages we don't want to ship
54 rm $RPM_BUILD_ROOT%_prefix/bin/*passwd
55 rm $RPM_BUILD_ROOT%_mandir/*/*passwd*
56
57 %{remove_docs}
58
59 %files
60 %manifest %{name}.manifest
61 %{_prefix}/bin/*
62 %{_libdir}/%{name}%{version}/lib*.so
63 %{_libdir}/%{name}%{version}/pkgIndex.tcl
64
65 %files devel
66 %manifest %{name}.manifest
67 %{_includedir}/*
68
69 %changelog