resetting manifest requested domain to floor
[platform/upstream/expect.git] / packaging / expect.spec
1 Url:            http://expect.nist.gov
2 Name:           expect
3 BuildRequires:  autoconf
4 BuildRequires:  tcl-devel
5 Version:        5.45
6 Release:        0
7 Summary:        A Tool for Automating Interactive Programs
8 License:        SUSE-Public-Domain
9 Group:          Development/Languages/Tcl
10 Source:         %{name}%{version}.tar.gz
11 Source1:        expect-rpmlintrc
12 Source1001:     expect.manifest
13
14 %description
15 Expect is a tool primarily for automating interactive applications,
16 such as telnet, ftp, passwd, fsck, rlogin, tip, and more.  Expect
17 really makes this stuff trivial.  Expect is also useful for testing
18 these applications.  It is described in many books, articles, papers,
19 and FAQs.  There is an entire book on it available from O'Reilly.
20
21 %package devel
22 Summary:        Header Files and C API Documentation for expect
23 Group:          Development/Libraries/Tcl
24
25 %description devel
26 This package contains header files and documentation needed for linking
27 to expect from programs written in compiled languages like C, C++, etc.
28
29 This package is not needed for developing scripts that run under the
30 /usr/bin/expect interpreter, or any other Tcl interpreter with the
31 expect package loaded.
32
33 %prep
34 %setup -q -n %name%version
35 cp %{SOURCE1001} .
36
37 %build
38 autoreconf
39 %configure \
40         --with-tcl=%_libdir \
41         --with-tk=no_tk \
42         --with-tclinclude=%_includedir \
43         --enable-shared
44 make %{?_smp_mflags} all pkglibdir=%_libdir/tcl/%name%version
45
46
47 %check
48 make test
49
50 %install
51 # set the right path to the expect binary...
52 sed -i \
53     -e '1s,^#![^ ]*expectk,#!/usr/bin/wish\npackage require Expect,' \
54     -e '1s,^#![^ ]*expect,#!/usr/bin/expect,' \
55     example/*
56 make install DESTDIR=$RPM_BUILD_ROOT pkglibdir=%_libdir/tcl/%name%version
57 # Remove some executables and manpages we don't want to ship
58 rm $RPM_BUILD_ROOT%_prefix/bin/*passwd
59 rm $RPM_BUILD_ROOT%_mandir/*/*passwd*
60
61 %files
62 %manifest %{name}.manifest
63 %defattr(-,root,root)
64 %_prefix/bin/*
65 %_libdir/tcl/*
66 %_libdir/lib*.so
67 %doc %_mandir/man1/*
68
69 %files devel
70 %manifest %{name}.manifest
71 %defattr(-,root,root)
72 %_includedir/*
73 %doc %_mandir/man3/*
74
75 %changelog