cleanup spec
[platform/upstream/expat.git] / packaging / expat.spec
1 Name:           expat
2 Version:        2.1.0
3 Release:        0
4 Url:            http://expat.sourceforge.net/
5 Summary:        XML Parser Toolkit
6 License:        MIT
7 Group:          Development/Libraries/C and C++
8 Source0:        %{name}-%{version}.tar.bz2
9 Source1:        baselibs.conf
10 BuildRequires:  gcc-c++
11 BuildRequires:  libtool
12 BuildRequires:  pkg-config
13
14 %description
15 Expat is an XML 1.0 parser written in C. It aims to be fully
16 conformant. It is currently not a validating XML processor. The current
17 production version of expat can be downloaded from
18 ftp://ftp.jclark.com/pub/xml/expat.zip. The directory xmltok contains a
19 low-level library for tokenizing XML. The interface is documented in
20 xmltok/xmltok.h. The directory xmlparse contains an XML parser library
21 that is built on top of the xmltok library. The interface is documented
22 in xmlparse/xmlparse.h. The directory sample contains a simple example
23 program using this interface. The file sample/build.bat is a batch
24 file to build the example using Visual C++. The directory xmlwf
25 contains the xmlwf application, which uses the xmlparse library. The
26 arguments to xmlwf are one or more files to check for well-formedness.
27 An option -d dir can be specified. For each well-formed input file, the
28 corresponding canonical XML is written to dir/f, where f is the
29 filename (without any path) of the input file. A -x option causes
30 references to external general entities to be processed. A -s option
31 makes documents that are not stand-alone cause an error (a document is
32 considered stand-alone if it is intrinsically stand-alone because it
33 has no external subset and no references to parameter entities in the
34 internal subset or it is declared as stand-alone in the XML
35 declaration).
36
37 %package -n libexpat
38 Summary:        XML Parser Toolkit
39 Group:          Development/Libraries/C and C++
40
41 %description -n libexpat
42 Expat is an XML 1.0 parser written in C. It aims to be fully
43 conformant. It is currently not a validating XML processor. The current
44 production version of expat can be downloaded from
45 ftp://ftp.jclark.com/pub/xml/expat.zip. The directory xmltok contains a
46 low-level library for tokenizing XML. The interface is documented in
47 xmltok/xmltok.h. The directory xmlparse contains an XML parser library
48 that is built on top of the xmltok library. The interface is documented
49 in xmlparse/xmlparse.h. The directory sample contains a simple example
50 program using this interface. The file sample/build.bat is a batch
51 file to build the example using Visual C++. The directory xmlwf
52 contains the xmlwf application, which uses the xmlparse library. The
53 arguments to xmlwf are one or more files to check for well-formedness.
54 An option -d dir can be specified. For each well-formed input file, the
55 corresponding canonical XML is written to dir/f, where f is the
56 filename (without any path) of the input file. A -x option causes
57 references to external general entities to be processed. A -s option
58 makes documents that are not stand-alone cause an error (a document is
59 considered stand-alone if it is intrinsically stand-alone because it
60 has no external subset and no references to parameter entities in the
61 internal subset or it is declared as stand-alone in the XML
62 declaration).
63
64 %package -n libexpat-devel
65 Summary:        XML Parser Toolkit
66 Group:          Development/Libraries/C and C++
67 Requires:       glibc-devel
68 Requires:       libexpat = %{version}
69 Provides:       expat-devel
70
71 %description -n libexpat-devel
72 Expat is an XML 1.0 parser written in C. It aims to be fully
73 conformant. It is currently not a validating XML processor. The current
74 production version of expat can be downloaded from
75 ftp://ftp.jclark.com/pub/xml/expat.zip. The directory xmltok contains a
76 low-level library for tokenizing XML. The interface is documented in
77 xmltok/xmltok.h. The directory xmlparse contains an XML parser library
78 that is built on top of the xmltok library. The interface is documented
79 in xmlparse/xmlparse.h. The directory sample contains a simple example
80 program using this interface. The file sample/build.bat is a batch
81 file to build the example using Visual C++. The directory xmlwf
82 contains the xmlwf application, which uses the xmlparse library. The
83 arguments to xmlwf are one or more files to check for well-formedness.
84 An option -d dir can be specified. For each well-formed input file, the
85 corresponding canonical XML is written to dir/f, where f is the
86 filename (without any path) of the input file. A -x option causes
87 references to external general entities to be processed. A -s option
88 makes documents that are not stand-alone cause an error (a document is
89 considered stand-alone if it is intrinsically stand-alone because it
90 has no external subset and no references to parameter entities in the
91 internal subset or it is declared as stand-alone in the XML
92 declaration).
93
94 %prep
95 %setup -q 
96
97 rm -f examples/*.dsp
98 %build
99 autoreconf -fi
100 %configure --disable-static --with-pic
101 make %{?_smp_mflags}
102
103 %check
104 make check
105
106 %install
107 %make_install
108 rm doc/xmlwf.1
109
110 %post -n libexpat -p /sbin/ldconfig
111
112 %postun -n libexpat -p /sbin/ldconfig
113
114 %files
115 %defattr(-, root, root)
116 %doc COPYING 
117 %doc %{_mandir}/man?/*
118 %{_bindir}/xmlwf
119
120 %files -n libexpat
121 %defattr(-, root, root)
122 %{_libdir}/libexpat.so.*
123
124 %files -n libexpat-devel
125 %defattr(-, root, root)
126 %{_includedir}/*
127 %{_libdir}/libexpat.so
128 %{_libdir}/pkgconfig/expat.pc
129
130 %changelog