add packaging
[platform/upstream/expat.git] / packaging / expat.spec
1 Name:           expat
2 Version:        2.1.0
3 Release:        1
4 Summary:        An XML parser library
5 Group:          System/Libraries
6 Source:         %{name}-%{version}.tar.bz2
7 Source1001:     expat.manifest
8
9 License:        MIT
10 Url:            http://www.libexpat.org/
11
12 %description
13 This is expat, the C library for parsing XML, written by James Clark. Expat
14 is a stream oriented XML parser. This means that you register handlers with
15 the parser prior to starting the parse. These handlers are called when the
16 parser discovers the associated structures in the document being parsed. A
17 start tag is an example of the kind of structures for which you may
18 register handlers.
19
20 %package devel
21 Summary:        Libraries and header files to develop applications using expat
22 Group:          Development/Libraries
23 Requires:       expat = %{version}
24
25 %description devel
26 The expat-devel package contains the libraries, include files and documentation
27 to develop XML applications with expat.
28
29 %prep
30 %setup -q
31 %build
32 cp %{SOURCE1001} .
33 %configure
34 make %{?_smp_mflags}
35
36 %install
37 rm -f examples/*.dsp
38
39 %make_install
40
41 %remove_docs
42
43 %post -p /sbin/ldconfig
44
45 %postun -p /sbin/ldconfig
46
47 %files
48 %manifest expat.manifest
49 %{_bindir}/*
50 /%{_libdir}/lib*.so.*
51
52 %files devel
53 %manifest expat.manifest
54 %{_libdir}/lib*.so
55 %{_libdir}/pkgconfig/*.pc
56 %{_includedir}/*.h
57