Bump to 3.7.5
[platform/upstream/evolution-data-server.git] / packaging / evolution-data-server.spec
1 %define baseline 3.7
2
3 %define USE_EVOLDAP 0
4 %define with_introspection 1
5
6 # should match configure.ac
7 %define so_edataserver 17
8 %define so_ecal 15
9 %define so_edata_cal 20
10 %define so_edata_book 16
11 %define so_ebook 14
12 %define so_camel 43
13 %define so_ebackend 6
14 %define _evo_version 3.8
15
16
17 Name:           evolution-data-server
18 Version:        3.7.5
19 Release:        0
20 Summary:        Evolution Data Server
21 License:        LGPLv2
22 Group:          Development/Libraries/GNOME
23 Url:            http://www.gnome.org
24 Source0:        http://download.gnome.org/sources/evolution-data-server/%{baseline}/%{name}-%{version}.tar.xz
25 Source98:       baselibs.conf
26 BuildRequires:  db4-devel
27 BuildRequires:  fdupes
28 BuildRequires:  gtk-doc
29 BuildRequires:  gcc-c++
30 BuildRequires:  gettext-tools
31 BuildRequires:  glibc-locale
32 BuildRequires:  gnome-common
33 BuildRequires:  gperf
34 BuildRequires:  intltool
35 BuildRequires:  libidl-devel
36 BuildRequires:  python-devel
37 BuildRequires:  vala
38 BuildRequires:  pkgconfig(gcr-base-3) >= 3.4
39 BuildRequires:  pkgconfig(gnome-keyring-1)
40 BuildRequires:  pkgconfig(goa-1.0) >= 3.2
41 BuildRequires:  pkgconfig(gobject-introspection-1.0)
42 BuildRequires:  pkgconfig(gtk+-3.0)
43 BuildRequires:  pkgconfig(gweather-3.0)
44 BuildRequires:  pkgconfig(libgdata)
45 BuildRequires:  pkgconfig(libical) >= 0.43
46 BuildRequires:  pkgconfig(libsecret-unstable)
47 BuildRequires:  pkgconfig(libsoup-2.4)
48 BuildRequires:  pkgconfig(nss)
49 BuildRequires:  pkgconfig(oauth)
50 BuildRequires:  pkgconfig(sqlite3)
51
52 Recommends:     %{name}-lang = %{version}
53 %ifarch  %ix86
54 Obsoletes:      evolution-data-server-32bit
55 %endif
56 Requires(post): glib2-tools
57 Requires(postun): glib2-tools
58
59
60 %description
61 Evolution Data Server provides a central location for your address book
62 and calendar in the GNOME Desktop.
63
64
65 %package -n libcamel
66 Summary:        Evolution Data Server - Messaging Library
67 Group:          System/Libraries
68
69 %description -n libcamel
70 Evolution Data Server provides a central location for your address book
71 and calendar in the GNOME Desktop.
72
73 This package contains a shared system library for messaging.
74
75
76 %package -n libebackend
77 Summary:        Evolution Data Server - Backend Utilities Library
78 Group:          System/Libraries
79
80 %description -n libebackend
81 Evolution Data Server provides a central location for your address book
82 and calendar in the GNOME Desktop.
83
84 This package contains a shared system library for backends.
85
86
87 %package -n libebook
88 Summary:        Evolution Data Server - Address Book Client Library
89 Group:          System/Libraries
90
91 %description -n libebook
92 Evolution Data Server provides a central location for your address book
93 and calendar in the GNOME Desktop.
94
95 This package contains a shared system library to access address books.
96
97
98 %package -n libecal
99 Summary:        Evolution Data Server - Calendar Client Library
100 Group:          System/Libraries
101
102 %description -n libecal
103 Evolution Data Server provides a central location for your address book
104 and calendar in the GNOME Desktop.
105
106 This package contains a shared system library to access calendars.
107
108 %package -n libedata-book
109 Summary:        Evolution Data Server - Address Book Backend Library
110 Group:          System/Libraries
111
112 %description -n libedata-book
113 Evolution Data Server provides a central location for your address book
114 and calendar in the GNOME Desktop.
115
116 This package contains a shared system library for address book backends.
117
118 %if %{?with_introspection}
119
120
121 %package -n typelib-EBook
122 Summary:        Evolution Data Server - Address Book Backend Library, Introspection bindings
123 Group:          System/Libraries
124
125 %description -n typelib-EBook
126 Evolution Data Server provides a central location for your address book
127 and calendar in the GNOME Desktop.
128
129 This package provides the GObject Introspection bindings for the library
130 for address book backends.
131 %endif
132
133
134 %package -n libedata-cal
135 Summary:        Evolution Data Server - Calendar Backend Library
136 Group:          System/Libraries
137
138 %description -n libedata-cal
139 Evolution Data Server provides a central location for your address book
140 and calendar in the GNOME Desktop.
141
142 This package contains a shared system library for calendar backends.
143
144
145 %package -n libedataserver
146 Summary:        Evolution Data Server - Utilities Library
147 Group:          System/Libraries
148
149 %description -n libedataserver
150 Evolution Data Server provides a central location for your address book
151 and calendar in the GNOME Desktop.
152
153 This package contains a shared system library.
154
155
156 %if %{?with_introspection}
157
158 %package -n typelib-EDataServer
159 Summary:        Evolution Data Server - Utilities Library, Introspection bindings
160 Group:          System/Libraries
161
162 %description -n typelib-EDataServer
163 Evolution Data Server provides a central location for your address book
164 and calendar in the GNOME Desktop.
165
166 This package provides the GObject Introspection bindings for the
167 libedataserver library.
168 %endif
169
170 This package contains a shared system library.
171
172
173 %package devel
174 Summary:        Evolution Data Server - Development Files
175 Group:          Development/Libraries/GNOME
176 Requires:       evolution-data-server = %{?epoch:}%{version}
177 Requires:       libcamel = %{version}
178 Requires:       libebackend = %{version}
179 Requires:       libebook = %{version}
180 Requires:       libecal = %{version}
181 Requires:       libedata-book = %{version}
182 Requires:       libedata-cal = %{version}
183 Requires:       libedataserver = %{version}
184 %if %{?with_introspection}
185 Requires:       typelib-EBook = %{version}
186 Requires:       typelib-EDataServer = %{version}
187 %endif
188
189 %description devel
190 The Evolution Data Server development files provide the necessary
191 libraries, headers, and other files for developing applications which
192 use the Evolution Data Server for storing contact and calendar
193 information.
194
195
196 %package doc
197 Summary:        Evolution Data Server - Developer Documentation
198 Group:          Development/Libraries/GNOME
199 Requires:       %{name} = %{version}
200
201 %description doc
202 Evolution Data Server provides a central location for your address book
203 and calendar in the GNOME Desktop.
204
205 This package contains developer documentation.
206
207 %prep
208 %setup -q
209
210 %build
211 %autogen
212
213 %{configure} \
214  --libexecdir=%{_libexecdir}/evolution-data-server \
215  --enable-ipv6=yes \
216  --enable-smime=yes \
217  --enable-nntp=yes \
218  --disable-static \
219 %if %{?with_introspection}
220  --enable-vala-bindings \
221  --enable-introspection \
222 %else
223  --disable-vala-bindings \
224  --disable-introspection \
225 %endif
226  # end of configure line
227
228 make %{?_smp_mflags} V=1
229
230 %install
231 %make_install
232 %find_lang evolution-data-server-%{_evo_version}
233 mv evolution-data-server-%{_evo_version}.lang evolution-data-server.lang
234 %fdupes %{buildroot}
235
236 %lang_package
237
238 %post
239 %glib2_gsettings_schema_post
240
241 %postun
242 %glib2_gsettings_schema_postun
243
244 %post -n libcamel -p /sbin/ldconfig
245
246 %postun -n libcamel -p /sbin/ldconfig
247
248 %post -n libebackend -p /sbin/ldconfig
249
250 %postun -n libebackend -p /sbin/ldconfig
251
252 %post -n libebook -p /sbin/ldconfig
253
254 %postun -n libebook -p /sbin/ldconfig
255
256 %post -n  libecal -p /sbin/ldconfig
257
258 %postun -n  libecal -p /sbin/ldconfig
259
260 %post -n libedata-book -p /sbin/ldconfig
261
262 %postun -n libedata-book -p /sbin/ldconfig
263
264 %post -n libedata-cal -p /sbin/ldconfig
265
266 %postun -n libedata-cal -p /sbin/ldconfig
267
268 %post -n libedataserver -p /sbin/ldconfig
269
270 %postun -n libedataserver -p /sbin/ldconfig
271
272
273 %files
274 %defattr(-,root,root)
275 %license COPYING
276 %{_datadir}/evolution-data-server/
277 %{_datadir}/GConf/gsettings/evolution-data-server.convert
278 %{_datadir}/GConf/gsettings/libedataserver.convert
279 %{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
280 %{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
281 %{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
282 %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
283 %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
284 %{_datadir}/pixmaps/evolution-data-server/
285 %{_datadir}/dbus-1/services/org.gnome.evolution.dataserver.*.service
286 %{_libdir}/evolution-data-server/
287 %if "%{_libdir}" != "%{_libexecdir}"
288 %{_libexecdir}/evolution-data-server/
289 %endif
290
291
292 %files -n libcamel
293 %defattr(-, root, root)
294 %{_libdir}/libcamel-1.2.so.%{so_camel}*
295
296
297 %files -n libebackend
298 %defattr(-, root, root)
299 %{_libdir}/libebackend-1.2.so.%{so_ebackend}*
300
301
302 %files -n libebook
303 %defattr(-, root, root)
304 %{_libdir}/libebook-1.2.so.%{so_ebook}*
305
306
307 %files -n libecal
308 %defattr(-, root, root)
309 %{_libdir}/libecal-1.2.so.%{so_ecal}*
310
311 %files -n libedata-book
312 %defattr(-, root, root)
313 %{_libdir}/libedata-book-1.2.so.%{so_edata_book}*
314
315
316 %if %{?with_introspection}
317
318 %files -n typelib-EBook
319 %defattr(-, root, root)
320 %{_libdir}/girepository-1.0/EBook-1.2.typelib
321 %endif
322
323
324 %files -n libedata-cal
325 %defattr(-, root, root)
326 %{_libdir}/libedata-cal-1.2.so.%{so_edata_cal}*
327
328
329 %files -n libedataserver
330 %defattr(-, root, root)
331 %{_libdir}/libedataserver-1.2.so.%{so_edataserver}*
332
333 %if %{?with_introspection}
334
335
336 %files -n typelib-EDataServer
337 %defattr(-, root, root)
338 %{_libdir}/girepository-1.0/EDataServer-1.2.typelib
339 %endif
340
341
342 %files devel
343 %defattr(-, root, root)
344 %{_includedir}/evolution-data-server/
345 %{_libdir}/*.so
346 %{_libdir}/pkgconfig/*.pc
347 %if %{?with_introspection}
348 %{_datadir}/gir-1.0/*.gir
349 %dir %{_datadir}/vala
350 %dir %{_datadir}/vala/vapi
351 %{_datadir}/vala/vapi/*.deps
352 %{_datadir}/vala/vapi/*.vapi
353 %endif
354