Initial packaging on 3.7.4 (using previous ones)
[platform/upstream/evolution-data-server.git] / packaging / evolution-data-server.spec
1 %define baseline 3.7
2
3 %define USE_EVOLDAP 0
4 %define with_introspection 1
5
6 # should match configure.ac
7 %define so_edataserver 17
8 %define so_ecal 15
9 %define so_edata_cal 20
10 %define so_edata_book 16
11 %define so_ebook 17
12 %define so_camel 43
13 %define so_ebackend 6
14 %define so_edataserverui 5
15 %define _evo_version 3.8
16
17
18 Name:           evolution-data-server
19 Version:        3.7.4
20 Release:        0
21 Summary:        Evolution Data Server
22 License:        LGPLv2
23 Group:          Development/Libraries/GNOME
24 Url:            http://www.gnome.org
25 Source0:        http://download.gnome.org/sources/evolution-data-server/%{baseline}/%{name}-%{version}.tar.xz
26 Source98:       baselibs.conf
27 BuildRequires:  db4-devel
28 BuildRequires:  fdupes
29 BuildRequires:  gtk-doc
30 BuildRequires:  gcc-c++
31 BuildRequires:  gettext-tools
32 BuildRequires:  glibc-locale
33 BuildRequires:  gnome-common
34 BuildRequires:  gperf
35 BuildRequires:  intltool
36 BuildRequires:  libidl-devel
37 BuildRequires:  python-devel
38 BuildRequires:  vala
39 BuildRequires:  pkgconfig(gcr-base-3) >= 3.4
40 BuildRequires:  pkgconfig(gnome-keyring-1)
41 BuildRequires:  pkgconfig(goa-1.0) >= 3.2
42 BuildRequires:  pkgconfig(gobject-introspection-1.0)
43 BuildRequires:  pkgconfig(gtk+-3.0)
44 BuildRequires:  pkgconfig(gweather-3.0)
45 BuildRequires:  pkgconfig(libgdata)
46 BuildRequires:  pkgconfig(libical) >= 0.43
47 BuildRequires:  pkgconfig(libsecret-unstable)
48 BuildRequires:  pkgconfig(libsoup-2.4)
49 BuildRequires:  pkgconfig(nss)
50 BuildRequires:  pkgconfig(oauth)
51 BuildRequires:  pkgconfig(sqlite3)
52
53 Recommends:     %{name}-lang = %{version}
54 %ifarch  %ix86
55 Obsoletes:      evolution-data-server-32bit
56 %endif
57 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
58 Requires(post): glib2-tools
59 Requires(postun): glib2-tools
60
61
62 %description
63 Evolution Data Server provides a central location for your address book
64 and calendar in the GNOME Desktop.
65
66
67 %package -n libcamel
68 Summary:        Evolution Data Server - Messaging Library
69 Group:          System/Libraries
70
71 %description -n libcamel
72 Evolution Data Server provides a central location for your address book
73 and calendar in the GNOME Desktop.
74
75 This package contains a shared system library for messaging.
76
77
78 %package -n libebackend
79 Summary:        Evolution Data Server - Backend Utilities Library
80 Group:          System/Libraries
81
82 %description -n libebackend
83 Evolution Data Server provides a central location for your address book
84 and calendar in the GNOME Desktop.
85
86 This package contains a shared system library for backends.
87
88
89 %package -n libebook
90 Summary:        Evolution Data Server - Address Book Client Library
91 Group:          System/Libraries
92
93 %description -n libebook
94 Evolution Data Server provides a central location for your address book
95 and calendar in the GNOME Desktop.
96
97 This package contains a shared system library to access address books.
98
99
100 %package -n libecal
101 Summary:        Evolution Data Server - Calendar Client Library
102 Group:          System/Libraries
103
104 %description -n libecal
105 Evolution Data Server provides a central location for your address book
106 and calendar in the GNOME Desktop.
107
108 This package contains a shared system library to access calendars.
109
110 %if %{?with_introspection}
111
112
113 %package -n typelib-ECalendar
114 Summary:        Evolution Data Server - Calendar Client Library, Introspection bindings
115 Group:          System/Libraries
116
117 %description -n typelib-ECalendar
118 Evolution Data Server provides a central location for your address book
119 and calendar in the GNOME Desktop.
120
121 This package provides the GObject Introspection bindings for the library
122 to access calendars.
123 %endif
124
125
126 %package -n libedata-book
127 Summary:        Evolution Data Server - Address Book Backend Library
128 Group:          System/Libraries
129
130 %description -n libedata-book
131 Evolution Data Server provides a central location for your address book
132 and calendar in the GNOME Desktop.
133
134 This package contains a shared system library for address book backends.
135
136 %if %{?with_introspection}
137
138
139 %package -n typelib-EBook
140 Summary:        Evolution Data Server - Address Book Backend Library, Introspection bindings
141 Group:          System/Libraries
142
143 %description -n typelib-EBook
144 Evolution Data Server provides a central location for your address book
145 and calendar in the GNOME Desktop.
146
147 This package provides the GObject Introspection bindings for the library
148 for address book backends.
149 %endif
150
151
152 %package -n libedata-cal
153 Summary:        Evolution Data Server - Calendar Backend Library
154 Group:          System/Libraries
155
156 %description -n libedata-cal
157 Evolution Data Server provides a central location for your address book
158 and calendar in the GNOME Desktop.
159
160 This package contains a shared system library for calendar backends.
161
162
163 %package -n libedataserver
164 Summary:        Evolution Data Server - Utilities Library
165 Group:          System/Libraries
166
167 %description -n libedataserver
168 Evolution Data Server provides a central location for your address book
169 and calendar in the GNOME Desktop.
170
171 This package contains a shared system library.
172
173 %if %{?with_introspection}
174
175
176 %package -n typelib-EDataServer
177 Summary:        Evolution Data Server - Utilities Library, Introspection bindings
178 Group:          System/Libraries
179
180 %description -n typelib-EDataServer
181 Evolution Data Server provides a central location for your address book
182 and calendar in the GNOME Desktop.
183
184 This package provides the GObject Introspection bindings for the
185 libedataserver library.
186 %endif
187
188
189 %package -n libedataserverui
190 Summary:        Evolution Data Server - Graphical Utilities Library
191 Group:          System/Libraries
192
193 %description -n libedataserverui
194 Evolution Data Server provides a central location for your address book
195 and calendar in the GNOME Desktop.
196
197 This package contains a shared system library.
198
199
200 %package devel
201 Summary:        Evolution Data Server - Development Files
202 Group:          Development/Libraries/GNOME
203 Requires:       evolution-data-server = %{?epoch:}%{version}
204 Requires:       libcamel = %{version}
205 Requires:       libebackend = %{version}
206 Requires:       libebook = %{version}
207 Requires:       libecal = %{version}
208 Requires:       libedata-book = %{version}
209 Requires:       libedata-cal = %{version}
210 Requires:       libedataserver = %{version}
211 Requires:       libedataserverui = %{version}
212 %if %{?with_introspection}
213 Requires:       typelib-EBook = %{version}
214 Requires:       typelib-ECalendar = %{version}
215 Requires:       typelib-EDataServer = %{version}
216 %endif
217
218 %description devel
219 The Evolution Data Server development files provide the necessary
220 libraries, headers, and other files for developing applications which
221 use the Evolution Data Server for storing contact and calendar
222 information.
223
224 %package doc
225 Summary:        Evolution Data Server - Developer Documentation
226 Group:          Development/Libraries/GNOME
227 Requires:       %{name} = %{version}
228
229 %description doc
230 Evolution Data Server provides a central location for your address book
231 and calendar in the GNOME Desktop.
232
233 This package contains developer documentation.
234
235 %prep
236 %setup -q
237
238 %build
239 %autogen
240
241 %{configure} \
242  --libexecdir=%{_libexecdir}/evolution-data-server \
243  --enable-ipv6=yes \
244  --enable-smime=yes \
245  --enable-nntp=yes \
246  --disable-static \
247 %if %{?with_introspection}
248  --enable-vala-bindings \
249  --enable-introspection \
250 %else
251  --disable-vala-bindings \
252  --disable-introspection \
253 %endif
254  # end of configure line
255
256 make %{?_smp_mflags} V=1
257
258 %install
259 %make_install
260 %find_lang evolution-data-server-%{_evo_version}
261 mv evolution-data-server-%{_evo_version}.lang evolution-data-server.lang
262 %fdupes %{buildroot}
263
264 %lang_package
265
266 %post
267 %glib2_gsettings_schema_post
268
269 %postun
270 %glib2_gsettings_schema_postun
271
272 %post -n libcamel -p /sbin/ldconfig
273
274 %postun -n libcamel -p /sbin/ldconfig
275
276 %post -n libebackend -p /sbin/ldconfig
277
278 %postun -n libebackend -p /sbin/ldconfig
279
280 %post -n libebook -p /sbin/ldconfig
281
282 %postun -n libebook -p /sbin/ldconfig
283
284 %post -n  libecal -p /sbin/ldconfig
285
286 %postun -n  libecal -p /sbin/ldconfig
287
288 %post -n libedata-book -p /sbin/ldconfig
289
290 %postun -n libedata-book -p /sbin/ldconfig
291
292 %post -n libedata-cal -p /sbin/ldconfig
293
294 %postun -n libedata-cal -p /sbin/ldconfig
295
296 %post -n libedataserver -p /sbin/ldconfig
297
298 %postun -n libedataserver -p /sbin/ldconfig
299
300 %post -n libedataserverui -p /sbin/ldconfig
301
302 %postun -n libedataserverui -p /sbin/ldconfig
303
304 %files
305 %defattr(-,root,root)
306 %license COPYING
307 %{_datadir}/evolution-data-server/
308 %{_datadir}/GConf/gsettings/evolution-data-server.convert
309 %{_datadir}/GConf/gsettings/libedataserver.convert
310 %{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
311 %{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
312 %{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
313 %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
314 %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
315 %{_datadir}/pixmaps/evolution-data-server/
316 %{_datadir}/dbus-1/services/org.gnome.evolution.dataserver.*.service
317 %{_libdir}/evolution-data-server/
318 %if "%{_libdir}" != "%{_libexecdir}"
319 %{_libexecdir}/evolution-data-server/
320 %endif
321
322
323 %files -n libcamel
324 %defattr(-, root, root)
325 %{_libdir}/libcamel-1.2.so.%{so_camel}*
326
327
328 %files -n libebackend
329 %defattr(-, root, root)
330 %{_libdir}/libebackend-1.2.so.%{so_ebackend}*
331
332
333 %files -n libebook
334 %defattr(-, root, root)
335 %{_libdir}/libebook-1.2.so.%{so_ebook}*
336
337
338 %files -n libecal
339 %defattr(-, root, root)
340 %{_libdir}/libecal-1.2.so.%{so_ecal}*
341
342 %if %{?with_introspection}
343
344 %files -n typelib-ECalendar
345 %defattr(-, root, root)
346 %{_libdir}/girepository-1.0/ECalendar-1.2.typelib
347 %endif
348
349
350 %files -n libedata-book
351 %defattr(-, root, root)
352 %{_libdir}/libedata-book-1.2.so.%{so_edata_book}*
353
354
355 %if %{?with_introspection}
356
357 %files -n typelib-EBook
358 %defattr(-, root, root)
359 %{_libdir}/girepository-1.0/EBook-1.2.typelib
360 %endif
361
362
363 %files -n libedata-cal
364 %defattr(-, root, root)
365 %{_libdir}/libedata-cal-1.2.so.%{so_edata_cal}*
366
367
368 %files -n libedataserver
369 %defattr(-, root, root)
370 %{_libdir}/libedataserver-1.2.so.%{so_edataserver}*
371
372 %if %{?with_introspection}
373
374
375 %files -n typelib-EDataServer
376 %defattr(-, root, root)
377 %{_libdir}/girepository-1.0/EDataServer-1.2.typelib
378 %endif
379
380
381 %files -n libedataserverui
382 %defattr(-, root, root)
383 %{_libdir}/libedataserverui-3.0.so.%{so_edataserverui}*
384
385
386 %files devel
387 %defattr(-, root, root)
388 %{_includedir}/evolution-data-server/
389 %{_libdir}/*.so
390 %{_libdir}/pkgconfig/*.pc
391 %if %{?with_introspection}
392 %{_datadir}/gir-1.0/*.gir
393 %dir %{_datadir}/vala
394 %dir %{_datadir}/vala/vapi
395 %{_datadir}/vala/vapi/*.deps
396 %{_datadir}/vala/vapi/*.vapi
397 %endif
398