spec: add libebook-contacts package
[platform/upstream/evolution-data-server.git] / packaging / evolution-data-server.spec
1 %define baseline 3.7
2
3 %define USE_EVOLDAP 0
4 %define with_introspection 1
5
6 # should match configure.ac
7 %define so_edataserver 17
8 %define so_ecal 15
9 %define so_edata_cal 20
10 %define so_edata_book 17
11 %define so_ebook 14
12 %define so_camel 43
13 %define so_ebackend 6
14 %define _evo_version 3.8
15
16
17 Name:           evolution-data-server
18 Version:        3.7.90
19 Release:        0
20 Summary:        Evolution Data Server
21 License:        LGPL-2.0+
22 Group:          Development/Libraries
23 Url:            http://www.gnome.org
24 Source0:        http://download.gnome.org/sources/evolution-data-server/%{baseline}/%{name}-%{version}.tar.xz
25 Source98:       baselibs.conf
26 BuildRequires:  db4-devel
27 BuildRequires:  fdupes
28 BuildRequires:  gtk-doc
29 BuildRequires:  gcc-c++
30 BuildRequires:  gettext-tools
31 BuildRequires:  glibc-locale
32 BuildRequires:  gnome-common
33 BuildRequires:  gperf
34 BuildRequires:  intltool
35 BuildRequires:  vala
36 BuildRequires:  pkgconfig(gcr-base-3) >= 3.4
37 BuildRequires:  pkgconfig(goa-1.0) >= 3.2
38 BuildRequires:  pkgconfig(gobject-introspection-1.0)
39 BuildRequires:  pkgconfig(gtk+-3.0)
40 BuildRequires:  pkgconfig(gweather-3.0) >= 3.5.0
41 BuildRequires:  pkgconfig(libgdata) >= 0.10
42 BuildRequires:  pkgconfig(libical) >= 0.43
43 BuildRequires:  pkgconfig(libIDL-2.0)
44 BuildRequires:  pkgconfig(libsecret-unstable) >= 0.5
45 BuildRequires:  pkgconfig(libsoup-2.4) >= 2.40.3
46 BuildRequires:  pkgconfig(nss)
47 BuildRequires:  pkgconfig(oauth)
48 BuildRequires:  pkgconfig(python-2.7)
49 BuildRequires:  pkgconfig(sqlite3) >= 3.5
50
51 Recommends:     %{name}-locale = %{version}
52 %ifarch  %ix86
53 Obsoletes:      evolution-data-server-32bit
54 %endif
55 Requires(post): glib2-tools
56 Requires(postun): glib2-tools
57
58 %description
59 Evolution Data Server provides a central location for your address book
60 and calendar in the GNOME Desktop.
61
62 %package -n libcamel
63 Summary:        Evolution Data Server - Messaging Library
64 Group:          System/Libraries
65
66 %description -n libcamel
67 Evolution Data Server provides a central location for your address book
68 and calendar in the GNOME Desktop.
69
70 This package contains a shared system library for messaging.
71
72 %package -n libebackend
73 Summary:        Evolution Data Server - Backend Utilities Library
74 Group:          System/Libraries
75
76 %description -n libebackend
77 Evolution Data Server provides a central location for your address book
78 and calendar in the GNOME Desktop.
79
80 This package contains a shared system library for backends.
81
82 %package -n libebook
83 Summary:        Evolution Data Server - Address Book Client Library
84 Group:          System/Libraries
85
86 %description -n libebook
87 Evolution Data Server provides a central location for your address book
88 and calendar in the GNOME Desktop.
89
90 This package contains a shared system library to access address books.
91
92 %package -n libebook-contacts
93 Summary:        Evolution Data Server - Address Book Client Library
94 Group:          System/Libraries
95
96 %description -n libebook-contacts
97 Evolution Data Server provides a central location for your address book
98 and calendar in the GNOME Desktop.
99
100 This package contains a shared system library to access address books.
101
102 %if %{?with_introspection}
103
104 %package -n typelib-EBookContacts
105 Summary:        Evolution Data Server - Address Book Backend Library, Introspection bindings
106 Group:          System/Libraries
107
108 %description -n typelib-EBookContacts
109 Evolution Data Server provides a central location for your address book
110 and calendar in the GNOME Desktop.
111
112 This package provides the GObject Introspection bindings for the library
113 for address book contacts.
114 %endif
115
116 %package -n libecal
117 Summary:        Evolution Data Server - Calendar Client Library
118 Group:          System/Libraries
119
120 %description -n libecal
121 Evolution Data Server provides a central location for your address book
122 and calendar in the GNOME Desktop.
123
124 This package contains a shared system library to access calendars.
125
126 %package -n libedata-book
127 Summary:        Evolution Data Server - Address Book Backend Library
128 Group:          System/Libraries
129
130 %description -n libedata-book
131 Evolution Data Server provides a central location for your address book
132 and calendar in the GNOME Desktop.
133
134 This package contains a shared system library for address book backends.
135
136 %if %{?with_introspection}
137
138 %package -n typelib-EBook
139 Summary:        Evolution Data Server - Address Book Backend Library, Introspection bindings
140 Group:          System/Libraries
141
142 %description -n typelib-EBook
143 Evolution Data Server provides a central location for your address book
144 and calendar in the GNOME Desktop.
145
146 This package provides the GObject Introspection bindings for the library
147 for address book backends.
148 %endif
149
150 %package -n libedata-cal
151 Summary:        Evolution Data Server - Calendar Backend Library
152 Group:          System/Libraries
153
154 %description -n libedata-cal
155 Evolution Data Server provides a central location for your address book
156 and calendar in the GNOME Desktop.
157
158 This package contains a shared system library for calendar backends.
159
160
161 %package -n libedataserver
162 Summary:        Evolution Data Server - Utilities Library
163 Group:          System/Libraries
164
165 %description -n libedataserver
166 Evolution Data Server provides a central location for your address book
167 and calendar in the GNOME Desktop.
168
169 This package contains a shared system library.
170
171
172 %if %{?with_introspection}
173
174 %package -n typelib-EDataServer
175 Summary:        Evolution Data Server - Utilities Library, Introspection bindings
176 Group:          System/Libraries
177
178 %description -n typelib-EDataServer
179 Evolution Data Server provides a central location for your address book
180 and calendar in the GNOME Desktop.
181
182 This package provides the GObject Introspection bindings for the
183 libedataserver library.
184
185 %endif
186
187 %package devel
188 Summary:        Evolution Data Server - Development Files
189 Group:          Development/Libraries
190 Requires:       evolution-data-server = %{?epoch:}%{version}
191 Requires:       libcamel = %{version}
192 Requires:       libebackend = %{version}
193 Requires:       libebook = %{version}
194 Requires:       libecal = %{version}
195 Requires:       libedata-book = %{version}
196 Requires:       libedata-cal = %{version}
197 Requires:       libedataserver = %{version}
198 %if %{?with_introspection}
199 Requires:       typelib-EBook = %{version}
200 Requires:       typelib-EDataServer = %{version}
201 %endif
202 Requires(post):   /sbin/ldconfig
203 Requires(postun): /sbin/ldconfig
204
205 %description devel
206 The Evolution Data Server development files provide the necessary
207 libraries, headers, and other files for developing applications which
208 use the Evolution Data Server for storing contact and calendar
209 information.
210
211
212 %package doc
213 Summary:        Evolution Data Server - Developer Documentation
214 Group:          Documentation
215 Requires:       %{name} = %{version}
216
217 %description doc
218 Evolution Data Server provides a central location for your address book
219 and calendar in the GNOME Desktop.
220
221 This package contains developer documentation.
222
223 %prep
224 %setup -q
225
226 %build
227 %autogen \
228  --libexecdir=%{_libexecdir}/evolution-data-server \
229  --enable-ipv6=yes \
230  --enable-smime=yes \
231  --enable-nntp=yes \
232  --disable-static \
233  --disable-uoa \
234 %if %{?with_introspection}
235  --enable-vala-bindings \
236  --enable-introspection \
237 %else
238  --disable-vala-bindings \
239  --disable-introspection \
240 %endif
241  # end of configure line
242
243 make %{?_smp_mflags} V=1
244
245 %install
246 %make_install
247 %find_lang evolution-data-server-%{_evo_version}
248 mv evolution-data-server-%{_evo_version}.lang evolution-data-server.lang
249 %fdupes %{buildroot}
250
251 %lang_package
252
253 %post
254 %glib2_gsettings_schema_post
255
256 %postun
257 %glib2_gsettings_schema_postun
258
259 %post -n libcamel -p /sbin/ldconfig
260
261 %postun -n libcamel -p /sbin/ldconfig
262
263 %post -n libebackend -p /sbin/ldconfig
264
265 %postun -n libebackend -p /sbin/ldconfig
266
267 %post -n libebook -p /sbin/ldconfig
268
269 %postun -n libebook -p /sbin/ldconfig
270
271 %post -n libebook-contacts -p /sbin/ldconfig
272
273 %postun -n libebook-contacts -p /sbin/ldconfig
274
275 %post -n  libecal -p /sbin/ldconfig
276
277 %postun -n  libecal -p /sbin/ldconfig
278
279 %post -n libedata-book -p /sbin/ldconfig
280
281 %postun -n libedata-book -p /sbin/ldconfig
282
283 %post -n libedata-cal -p /sbin/ldconfig
284
285 %postun -n libedata-cal -p /sbin/ldconfig
286
287 %post -n libedataserver -p /sbin/ldconfig
288
289 %postun -n libedataserver -p /sbin/ldconfig
290
291
292 %files
293 %defattr(-,root,root)
294 %license COPYING
295 %{_datadir}/GConf/gsettings/evolution-data-server.convert
296 %{_datadir}/GConf/gsettings/libedataserver.convert
297 %{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
298 %{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
299 %{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
300 %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
301 %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
302 %{_datadir}/pixmaps/evolution-data-server/
303 %{_datadir}/dbus-1/services/org.gnome.evolution.dataserver.*.service
304 %{_libdir}/evolution-data-server/
305 %if "%{_libdir}" != "%{_libexecdir}"
306 %{_libexecdir}/evolution-data-server/
307 %endif
308
309 %files -n libcamel
310 %defattr(-, root, root)
311 %{_libdir}/libcamel-1.2.so.%{so_camel}*
312
313 %files -n libebackend
314 %defattr(-, root, root)
315 %{_libdir}/libebackend-1.2.so.%{so_ebackend}*
316
317 %files -n libebook
318 %defattr(-, root, root)
319 %{_libdir}/libebook-1.2.so.%{so_ebook}*
320
321 %if %{?with_introspection}
322 %files -n typelib-EBook
323 %defattr(-, root, root)
324 %{_libdir}/girepository-1.0/EBook-1.2.typelib
325 %endif
326
327 %files -n libebook-contacts
328 %defattr(-, root, root)
329 %{_libdir}/libebook-contacts-1.2.so.0*
330
331 %if %{?with_introspection}
332 %files -n typelib-EBookContacts
333 %defattr(-, root, root)
334 %{_libdir}/girepository-1.0/EBookContacts-1.2.typelib
335 %endif
336
337 %files -n libecal
338 %defattr(-, root, root)
339 %{_libdir}/libecal-1.2.so.%{so_ecal}*
340
341 %files -n libedata-book
342 %defattr(-, root, root)
343 %{_libdir}/libedata-book-1.2.so.%{so_edata_book}*
344
345 %files -n libedata-cal
346 %defattr(-, root, root)
347 %{_libdir}/libedata-cal-1.2.so.%{so_edata_cal}*
348
349 %files -n libedataserver
350 %defattr(-, root, root)
351 %{_libdir}/libedataserver-1.2.so.%{so_edataserver}*
352
353 %if %{?with_introspection}
354 %files -n typelib-EDataServer
355 %defattr(-, root, root)
356 %{_libdir}/girepository-1.0/EDataServer-1.2.typelib
357 %endif
358
359 %files devel
360 %defattr(-, root, root)
361 %{_includedir}/evolution-data-server/
362 %{_libdir}/*.so
363 %{_libdir}/pkgconfig/*.pc
364 %if %{?with_introspection}
365 %{_datadir}/gir-1.0/*.gir
366 %dir %{_datadir}/vala
367 %dir %{_datadir}/vala/vapi
368 %{_datadir}/vala/vapi/*.deps
369 %{_datadir}/vala/vapi/*.vapi
370 %endif
371