Bump to 3.7.90
[platform/upstream/evolution-data-server.git] / packaging / evolution-data-server.spec
1 %define baseline 3.7
2
3 %define USE_EVOLDAP 0
4 %define with_introspection 1
5
6 # should match configure.ac
7 %define so_edataserver 17
8 %define so_ecal 15
9 %define so_edata_cal 20
10 %define so_edata_book 16
11 %define so_ebook 14
12 %define so_camel 43
13 %define so_ebackend 6
14 %define _evo_version 3.8
15
16
17 Name:           evolution-data-server
18 Version:        3.7.90
19 Release:        0
20 Summary:        Evolution Data Server
21 License:        LGPL-2.0+
22 Group:          Development/Libraries
23 Url:            http://www.gnome.org
24 Source0:        http://download.gnome.org/sources/evolution-data-server/%{baseline}/%{name}-%{version}.tar.xz
25 Source98:       baselibs.conf
26 BuildRequires:  db4-devel
27 BuildRequires:  fdupes
28 BuildRequires:  gtk-doc
29 BuildRequires:  gcc-c++
30 BuildRequires:  gettext-tools
31 BuildRequires:  glibc-locale
32 BuildRequires:  gnome-common
33 BuildRequires:  gperf
34 BuildRequires:  intltool
35 BuildRequires:  vala
36 BuildRequires:  pkgconfig(gcr-base-3) >= 3.4
37 BuildRequires:  pkgconfig(goa-1.0) >= 3.2
38 BuildRequires:  pkgconfig(gobject-introspection-1.0)
39 BuildRequires:  pkgconfig(gtk+-3.0)
40 BuildRequires:  pkgconfig(gweather-3.0)
41 BuildRequires:  pkgconfig(libgdata)
42 BuildRequires:  pkgconfig(libical) >= 0.43
43 BuildRequires:  pkgconfig(libIDL-2.0)
44 BuildRequires:  pkgconfig(libsecret-unstable)
45 BuildRequires:  pkgconfig(libsoup-2.4)
46 BuildRequires:  pkgconfig(nss)
47 BuildRequires:  pkgconfig(oauth)
48 BuildRequires:  pkgconfig(python-2.7)
49 BuildRequires:  pkgconfig(sqlite3)
50
51 Recommends:     %{name}-lang = %{version}
52 %ifarch  %ix86
53 Obsoletes:      evolution-data-server-32bit
54 %endif
55 Requires(post): glib2-tools
56 Requires(postun): glib2-tools
57
58
59 %description
60 Evolution Data Server provides a central location for your address book
61 and calendar in the GNOME Desktop.
62
63
64 %package -n libcamel
65 Summary:        Evolution Data Server - Messaging Library
66 Group:          System/Libraries
67
68 %description -n libcamel
69 Evolution Data Server provides a central location for your address book
70 and calendar in the GNOME Desktop.
71
72 This package contains a shared system library for messaging.
73
74
75 %package -n libebackend
76 Summary:        Evolution Data Server - Backend Utilities Library
77 Group:          System/Libraries
78
79 %description -n libebackend
80 Evolution Data Server provides a central location for your address book
81 and calendar in the GNOME Desktop.
82
83 This package contains a shared system library for backends.
84
85
86 %package -n libebook
87 Summary:        Evolution Data Server - Address Book Client Library
88 Group:          System/Libraries
89
90 %description -n libebook
91 Evolution Data Server provides a central location for your address book
92 and calendar in the GNOME Desktop.
93
94 This package contains a shared system library to access address books.
95
96
97 %package -n libecal
98 Summary:        Evolution Data Server - Calendar Client Library
99 Group:          System/Libraries
100
101 %description -n libecal
102 Evolution Data Server provides a central location for your address book
103 and calendar in the GNOME Desktop.
104
105 This package contains a shared system library to access calendars.
106
107
108 %package -n libedata-book
109 Summary:        Evolution Data Server - Address Book Backend Library
110 Group:          System/Libraries
111
112 %description -n libedata-book
113 Evolution Data Server provides a central location for your address book
114 and calendar in the GNOME Desktop.
115
116 This package contains a shared system library for address book backends.
117
118 %if %{?with_introspection}
119
120
121 %package -n typelib-EBook
122 Summary:        Evolution Data Server - Address Book Backend Library, Introspection bindings
123 Group:          System/Libraries
124
125 %description -n typelib-EBook
126 Evolution Data Server provides a central location for your address book
127 and calendar in the GNOME Desktop.
128
129 This package provides the GObject Introspection bindings for the library
130 for address book backends.
131 %endif
132
133 %package -n libedata-cal
134 Summary:        Evolution Data Server - Calendar Backend Library
135 Group:          System/Libraries
136
137 %description -n libedata-cal
138 Evolution Data Server provides a central location for your address book
139 and calendar in the GNOME Desktop.
140
141 This package contains a shared system library for calendar backends.
142
143
144 %package -n libedataserver
145 Summary:        Evolution Data Server - Utilities Library
146 Group:          System/Libraries
147
148 %description -n libedataserver
149 Evolution Data Server provides a central location for your address book
150 and calendar in the GNOME Desktop.
151
152 This package contains a shared system library.
153
154
155 %if %{?with_introspection}
156
157 %package -n typelib-EDataServer
158 Summary:        Evolution Data Server - Utilities Library, Introspection bindings
159 Group:          System/Libraries
160
161 %description -n typelib-EDataServer
162 Evolution Data Server provides a central location for your address book
163 and calendar in the GNOME Desktop.
164
165 This package provides the GObject Introspection bindings for the
166 libedataserver library.
167 %endif
168
169 This package contains a shared system library.
170
171
172 %package devel
173 Summary:        Evolution Data Server - Development Files
174 Group:          Development/Libraries
175 Requires:       evolution-data-server = %{?epoch:}%{version}
176 Requires:       libcamel = %{version}
177 Requires:       libebackend = %{version}
178 Requires:       libebook = %{version}
179 Requires:       libecal = %{version}
180 Requires:       libedata-book = %{version}
181 Requires:       libedata-cal = %{version}
182 Requires:       libedataserver = %{version}
183 %if %{?with_introspection}
184 Requires:       typelib-EBook = %{version}
185 Requires:       typelib-EDataServer = %{version}
186 %endif
187 Requires(post):   /sbin/ldconfig
188 Requires(postun): /sbin/ldconfig
189
190 %description devel
191 The Evolution Data Server development files provide the necessary
192 libraries, headers, and other files for developing applications which
193 use the Evolution Data Server for storing contact and calendar
194 information.
195
196
197 %package doc
198 Summary:        Evolution Data Server - Developer Documentation
199 Group:          Development/Libraries
200 Requires:       %{name} = %{version}
201
202 %description doc
203 Evolution Data Server provides a central location for your address book
204 and calendar in the GNOME Desktop.
205
206 This package contains developer documentation.
207
208 %prep
209 %setup -q
210
211 %build
212 %autogen \
213  --libexecdir=%{_libexecdir}/evolution-data-server \
214  --enable-ipv6=yes \
215  --enable-smime=yes \
216  --enable-nntp=yes \
217  --disable-static \
218  --disable-uoa \
219 %if %{?with_introspection}
220  --enable-vala-bindings \
221  --enable-introspection \
222 %else
223  --disable-vala-bindings \
224  --disable-introspection \
225 %endif
226  # end of configure line
227
228 make %{?_smp_mflags} V=1
229
230 %install
231 %make_install
232 %find_lang evolution-data-server-%{_evo_version}
233 mv evolution-data-server-%{_evo_version}.lang evolution-data-server.lang
234 %fdupes %{buildroot}
235
236 %lang_package
237
238 %post
239 %glib2_gsettings_schema_post
240
241 %postun
242 %glib2_gsettings_schema_postun
243
244 %post -n libcamel -p /sbin/ldconfig
245
246 %postun -n libcamel -p /sbin/ldconfig
247
248 %post -n libebackend -p /sbin/ldconfig
249
250 %postun -n libebackend -p /sbin/ldconfig
251
252 %post -n libebook -p /sbin/ldconfig
253
254 %postun -n libebook -p /sbin/ldconfig
255
256 %post -n  libecal -p /sbin/ldconfig
257
258 %postun -n  libecal -p /sbin/ldconfig
259
260 %post -n libedata-book -p /sbin/ldconfig
261
262 %postun -n libedata-book -p /sbin/ldconfig
263
264 %post -n libedata-cal -p /sbin/ldconfig
265
266 %postun -n libedata-cal -p /sbin/ldconfig
267
268 %post -n libedataserver -p /sbin/ldconfig
269
270 %postun -n libedataserver -p /sbin/ldconfig
271
272
273 %files
274 %defattr(-,root,root)
275 %license COPYING
276 %{_datadir}/GConf/gsettings/evolution-data-server.convert
277 %{_datadir}/GConf/gsettings/libedataserver.convert
278 %{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
279 %{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
280 %{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
281 %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
282 %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
283 %{_datadir}/pixmaps/evolution-data-server/
284 %{_datadir}/dbus-1/services/org.gnome.evolution.dataserver.*.service
285 %{_libdir}/evolution-data-server/
286 %if "%{_libdir}" != "%{_libexecdir}"
287 %{_libexecdir}/evolution-data-server/
288 %endif
289
290
291 %files -n libcamel
292 %defattr(-, root, root)
293 %{_libdir}/libcamel-1.2.so.%{so_camel}*
294
295
296 %files -n libebackend
297 %defattr(-, root, root)
298 %{_libdir}/libebackend-1.2.so.%{so_ebackend}*
299
300
301 %files -n libebook
302 %defattr(-, root, root)
303 %{_libdir}/libebook-1.2.so.%{so_ebook}*
304
305
306 %files -n libecal
307 %defattr(-, root, root)
308 %{_libdir}/libecal-1.2.so.%{so_ecal}*
309
310 %files -n libedata-book
311 %defattr(-, root, root)
312 %{_libdir}/libedata-book-1.2.so.%{so_edata_book}*
313
314
315 %if %{?with_introspection}
316
317 %files -n typelib-EBook
318 %defattr(-, root, root)
319 %{_libdir}/girepository-1.0/EBook-1.2.typelib
320 %endif
321
322
323 %files -n libedata-cal
324 %defattr(-, root, root)
325 %{_libdir}/libedata-cal-1.2.so.%{so_edata_cal}*
326
327
328 %files -n libedataserver
329 %defattr(-, root, root)
330 %{_libdir}/libedataserver-1.2.so.%{so_edataserver}*
331
332 %if %{?with_introspection}
333
334
335 %files -n typelib-EDataServer
336 %defattr(-, root, root)
337 %{_libdir}/girepository-1.0/EDataServer-1.2.typelib
338 %endif
339
340
341 %files devel
342 %defattr(-, root, root)
343 %{_includedir}/evolution-data-server/
344 %{_libdir}/*.so
345 %{_libdir}/pkgconfig/*.pc
346 %if %{?with_introspection}
347 %{_datadir}/gir-1.0/*.gir
348 %dir %{_datadir}/vala
349 %dir %{_datadir}/vala/vapi
350 %{_datadir}/vala/vapi/*.deps
351 %{_datadir}/vala/vapi/*.vapi
352 %endif
353