update to openismus-work-3-8 branch
[platform/upstream/evolution-data-server.git] / packaging / evolution-data-server.spec
1 %define baseline 3.9
2
3 %define USE_EVOLDAP 0
4 %define with_introspection 1
5 %define enable_goa no
6 %define enable_uoa no
7 %define enable_gtk no
8 %define enable_gdata no
9 %define enable_weather no
10 %define enable_email no
11
12 # should match configure.ac
13 %define so_edataserver 17
14 %define so_ecal 15
15 %define so_edata_cal 20
16 %define so_edata_book 17
17 %define so_ebook 14
18 %define so_camel 43
19 %define so_ebackend 6
20 %define _evo_version 3.9
21
22
23 Name:           evolution-data-server
24 Version:        3.9.90
25 Release:        0
26 Summary:        Evolution Data Server
27 License:        LGPL-2.0+
28 Group:          Development/Libraries
29 Url:            http://www.gnome.org
30 Source0:        http://download.gnome.org/sources/evolution-data-server/%{baseline}/%{name}-%{version}.tar.xz
31 Source98:       baselibs.conf
32 BuildRequires:  db4-devel
33 BuildRequires:  fdupes
34 BuildRequires:  gcc-c++
35 BuildRequires:  gettext-tools
36 BuildRequires:  glibc-locale
37 BuildRequires:  gnome-common
38 BuildRequires:  gperf
39 BuildRequires:  gtk-doc
40 BuildRequires:  intltool
41 BuildRequires:  vala
42 BuildRequires:  pkgconfig(icu-i18n)
43 BuildRequires:  pkgconfig(gcr-base-3) >= 3.4
44 %if %{?enable_goa} != no
45 BuildRequires:  pkgconfig(goa-1.0) >= 3.2
46 %endif
47 BuildRequires:  pkgconfig(gobject-introspection-1.0)
48 %if %{?enable_gtk} != no
49 BuildRequires:  pkgconfig(gtk+-3.0)
50 %endif
51 %if %{?enable_weather} != no
52 BuildRequires:  pkgconfig(gweather-3.0) >= 3.5.0
53 %endif
54 # Not sure what this is for. Not checked by current configure.ac?
55 # BuildRequires:  pkgconfig(libIDL-2.0)
56 %if %{?enable_gdata} != no
57 BuildRequires:  pkgconfig(libgdata) >= 0.10
58 BuildRequires:  pkgconfig(oauth)
59 %endif
60 BuildRequires:  pkgconfig(libical) >= 0.43
61 BuildRequires:  pkgconfig(libsecret-unstable) >= 0.5
62 BuildRequires:  pkgconfig(libsoup-2.4) >= 2.40.3
63 BuildRequires:  pkgconfig(nss)
64 BuildRequires:  pkgconfig(python-2.7)
65 BuildRequires:  pkgconfig(sqlite3) >= 3.5
66
67 Recommends:     %{name}-locale = %{version}
68 %ifarch  %ix86
69 Obsoletes:      evolution-data-server-32bit
70 %endif
71 Requires(post): glib2-tools
72 Requires(postun): glib2-tools
73
74 %description
75 Evolution Data Server provides a central location for your address book
76 and calendar in the GNOME Desktop.
77
78
79 %package -n libcamel
80 Summary:        Evolution Data Server - Messaging Library
81 Group:          System/Libraries
82
83 %description -n libcamel
84 Evolution Data Server provides a central location for your address book
85 and calendar in the GNOME Desktop.
86
87 This package contains a shared system library for messaging.
88
89
90 %package -n libebackend
91 Summary:        Evolution Data Server - Backend Utilities Library
92 Group:          System/Libraries
93
94 %description -n libebackend
95 Evolution Data Server provides a central location for your address book
96 and calendar in the GNOME Desktop.
97
98 This package contains a shared system library for backends.
99
100
101 %package -n libebook
102 Summary:        Evolution Data Server - Address Book Client Library
103 Group:          System/Libraries
104
105 %description -n libebook
106 Evolution Data Server provides a central location for your address book
107 and calendar in the GNOME Desktop.
108
109 This package contains a shared system library to access address books.
110
111
112 %package -n libebook-contacts
113 Summary:        Evolution Data Server - Address Book Client Library
114 Group:          System/Libraries
115
116 %description -n libebook-contacts
117 Evolution Data Server provides a central location for your address book
118 and calendar in the GNOME Desktop.
119
120 This package contains a shared system library to access address books.
121
122
123 %if %{?with_introspection}
124
125 %package -n typelib-EBookContacts
126 Summary:        Evolution Data Server - Address Book Backend Library, Introspection bindings
127 Group:          System/Libraries
128
129 %description -n typelib-EBookContacts
130 Evolution Data Server provides a central location for your address book
131 and calendar in the GNOME Desktop.
132
133 This package provides the GObject Introspection bindings for the library
134 for address book contacts.
135 %endif
136
137
138 %package -n libecal
139 Summary:        Evolution Data Server - Calendar Client Library
140 Group:          System/Libraries
141
142 %description -n libecal
143 Evolution Data Server provides a central location for your address book
144 and calendar in the GNOME Desktop.
145
146 This package contains a shared system library to access calendars.
147
148 %package -n libedata-book
149 Summary:        Evolution Data Server - Address Book Backend Library
150 Group:          System/Libraries
151
152 %description -n libedata-book
153 Evolution Data Server provides a central location for your address book
154 and calendar in the GNOME Desktop.
155
156 This package contains a shared system library for address book backends.
157
158
159 %if %{?with_introspection}
160
161 %package -n typelib-EBook
162 Summary:        Evolution Data Server - Address Book Backend Library, Introspection bindings
163 Group:          System/Libraries
164
165 %description -n typelib-EBook
166 Evolution Data Server provides a central location for your address book
167 and calendar in the GNOME Desktop.
168
169 This package provides the GObject Introspection bindings for the library
170 for address book backends.
171 %endif
172
173
174 %package -n libedata-cal
175 Summary:        Evolution Data Server - Calendar Backend Library
176 Group:          System/Libraries
177
178 %description -n libedata-cal
179 Evolution Data Server provides a central location for your address book
180 and calendar in the GNOME Desktop.
181
182 This package contains a shared system library for calendar backends.
183
184
185 %package -n libedataserver
186 Summary:        Evolution Data Server - Utilities Library
187 Group:          System/Libraries
188
189 %description -n libedataserver
190 Evolution Data Server provides a central location for your address book
191 and calendar in the GNOME Desktop.
192
193 This package contains a shared system library.
194
195
196 %if %{?with_introspection}
197
198 %package -n typelib-EDataServer
199 Summary:        Evolution Data Server - Utilities Library, Introspection bindings
200 Group:          System/Libraries
201
202 %description -n typelib-EDataServer
203 Evolution Data Server provides a central location for your address book
204 and calendar in the GNOME Desktop.
205
206 This package provides the GObject Introspection bindings for the
207 libedataserver library.
208
209 %endif
210
211
212 %package devel
213 Summary:        Evolution Data Server - Development Files
214 Group:          Development/Libraries
215 Requires:       evolution-data-server = %{?epoch:}%{version}
216 Requires:       libcamel = %{version}
217 Requires:       libebackend = %{version}
218 Requires:       libebook = %{version}
219 Requires:       libecal = %{version}
220 Requires:       libedata-book = %{version}
221 Requires:       libedata-cal = %{version}
222 Requires:       libedataserver = %{version}
223 %if %{?with_introspection}
224 Requires:       typelib-EBook = %{version}
225 Requires:       typelib-EDataServer = %{version}
226 %endif
227 Requires(post):   /sbin/ldconfig
228 Requires(postun): /sbin/ldconfig
229
230 %description devel
231 The Evolution Data Server development files provide the necessary
232 libraries, headers, and other files for developing applications which
233 use the Evolution Data Server for storing contact and calendar
234 information.
235
236
237 %package doc
238 Summary:        Evolution Data Server - Developer Documentation
239 Group:          Documentation
240 Requires:       %{name} = %{version}
241
242 %description doc
243 Evolution Data Server provides a central location for your address book
244 and calendar in the GNOME Desktop.
245
246 This package contains developer documentation.
247
248 %prep
249 %setup -q
250
251 %build
252
253 # "maintainer mode" depends on GTK and is not needed
254 # for packaging, so disable it.
255
256 %autogen \
257  --libexecdir=%{_libexecdir}/evolution-data-server \
258  --disable-maintainer-mode \
259  --enable-ipv6=%{?enable_ipv6} \
260  --enable-smime=%{?enable_smime} \
261  --enable-nntp=%{?enable_nntp} \
262  --disable-static \
263  --disable-uoa \
264  --enable-goa=%{?enable_goa} \
265  --enable-weather=%{?enable_weather} \
266  --enable-gtk=%{?enable_gtk} \
267  --enable-google=%{?enable_gdata} \
268 %if %{?with_introspection}
269  --enable-vala-bindings \
270  --enable-introspection \
271 %else
272  --disable-vala-bindings \
273  --disable-introspection \
274 %endif
275  # end of configure line
276
277 make %{?_smp_mflags} V=1
278
279 %install
280 %make_install
281 mkdir -p %{buildroot}/%{_datadir}/help
282 %find_lang evolution-data-server-%{_evo_version}
283 mv evolution-data-server-%{_evo_version}.lang evolution-data-server.lang
284 %fdupes %{buildroot}
285
286 %lang_package
287
288 %post
289 %glib2_gsettings_schema_post
290
291 %postun
292 %glib2_gsettings_schema_postun
293
294 %post -n libcamel -p /sbin/ldconfig
295
296 %postun -n libcamel -p /sbin/ldconfig
297
298 %post -n libebackend -p /sbin/ldconfig
299
300 %postun -n libebackend -p /sbin/ldconfig
301
302 %post -n libebook -p /sbin/ldconfig
303
304 %postun -n libebook -p /sbin/ldconfig
305
306 %post -n libebook-contacts -p /sbin/ldconfig
307
308 %postun -n libebook-contacts -p /sbin/ldconfig
309
310 %post -n  libecal -p /sbin/ldconfig
311
312 %postun -n  libecal -p /sbin/ldconfig
313
314 %post -n libedata-book -p /sbin/ldconfig
315
316 %postun -n libedata-book -p /sbin/ldconfig
317
318 %post -n libedata-cal -p /sbin/ldconfig
319
320 %postun -n libedata-cal -p /sbin/ldconfig
321
322 %post -n libedataserver -p /sbin/ldconfig
323
324 %postun -n libedataserver -p /sbin/ldconfig
325
326
327 %files
328 %defattr(-,root,root)
329 %license COPYING
330 %{_datadir}/GConf/gsettings/evolution-data-server.convert
331 %{_datadir}/GConf/gsettings/libedataserver.convert
332 %{_datadir}/glib-2.0/schemas/org.gnome.Evolution.DefaultSources.gschema.xml
333 %{_datadir}/glib-2.0/schemas/org.gnome.evolution.eds-shell.gschema.xml
334 %{_datadir}/glib-2.0/schemas/org.gnome.evolution.shell.network-config.gschema.xml
335 %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.addressbook.gschema.xml
336 %{_datadir}/glib-2.0/schemas/org.gnome.evolution-data-server.calendar.gschema.xml
337 %{_datadir}/pixmaps/evolution-data-server/
338 %{_datadir}/dbus-1/services/org.gnome.evolution.dataserver.*.service
339 %{_libdir}/evolution-data-server/
340 %if "%{_libdir}" != "%{_libexecdir}"
341 %{_libexecdir}/evolution-data-server/
342 %endif
343
344
345 %files -n libcamel
346 %defattr(-, root, root)
347 %{_libdir}/libcamel-1.2.so.%{so_camel}*
348
349
350 %files -n libebackend
351 %defattr(-, root, root)
352 %{_libdir}/libebackend-1.2.so.%{so_ebackend}*
353
354
355 %files -n libebook
356 %defattr(-, root, root)
357 %{_libdir}/libebook-1.2.so.%{so_ebook}*
358
359
360 %if %{?with_introspection}
361 %files -n typelib-EBook
362 %defattr(-, root, root)
363 %{_libdir}/girepository-1.0/EBook-1.2.typelib
364 %endif
365
366
367 %files -n libebook-contacts
368 %defattr(-, root, root)
369 %{_libdir}/libebook-contacts-1.2.so.0*
370
371
372 %if %{?with_introspection}
373 %files -n typelib-EBookContacts
374 %defattr(-, root, root)
375 %{_libdir}/girepository-1.0/EBookContacts-1.2.typelib
376 %endif
377
378
379 %files -n libecal
380 %defattr(-, root, root)
381 %{_libdir}/libecal-1.2.so.%{so_ecal}*
382
383
384 %files -n libedata-book
385 %defattr(-, root, root)
386 %{_libdir}/libedata-book-1.2.so.%{so_edata_book}*
387
388
389 %files -n libedata-cal
390 %defattr(-, root, root)
391 %{_libdir}/libedata-cal-1.2.so.%{so_edata_cal}*
392
393
394 %files -n libedataserver
395 %defattr(-, root, root)
396 %{_libdir}/libedataserver-1.2.so.%{so_edataserver}*
397
398
399 %if %{?with_introspection}
400 %files -n typelib-EDataServer
401 %defattr(-, root, root)
402 %{_libdir}/girepository-1.0/EDataServer-1.2.typelib
403 %endif
404
405
406 %files devel
407 %defattr(-, root, root)
408 %{_includedir}/evolution-data-server/
409 %{_libdir}/*.so
410 %{_libdir}/pkgconfig/*.pc
411 %if %{?with_introspection}
412 %{_datadir}/gir-1.0/*.gir
413 %dir %{_datadir}/vala
414 %dir %{_datadir}/vala/vapi
415 %{_datadir}/vala/vapi/*.deps
416 %{_datadir}/vala/vapi/*.vapi
417 %endif