Add Tizen 2.0 packaging
[profile/ivi/eobj.git] / packaging / eobj.spec
1 Name:       eobj
2 Summary:    EFL Object Library
3 Version:    1.7.1+svn.78409+build01
4 Release:    1
5 Group:      System/Libraries
6 License:    BSD
7 URL:        http://www.enlightenment.org/
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  pkgconfig(eina)
12
13 %description
14 Enlightenment DR17 Object library... because everyone needs a package with
15 the name 'object' inside it.  This completes TLA compliance, have a nice day. 
16
17 %package devel
18 Summary:    Eobj (devel)
19 Group:      Development/Libraries
20 Requires:   %{name} = %{version}-%{release}
21
22
23 %description devel
24 Enlightenment DR17 Object library (devel)
25
26 %prep
27 %setup -q
28
29 %build
30 export CFLAGS+=" -fvisibility=hidden -ffast-math -fPIC"
31 export LDFLAGS+=" -fvisibility=hidden -Wl,--hash-style=both -Wl,--as-needed"
32
33 %autogen
34 %configure --disable-static 
35   
36 make %{?jobs:-j%jobs}
37
38
39 %install
40 rm -rf %{buildroot}
41 %make_install
42
43
44 %post -p /sbin/ldconfig
45
46 %postun -p /sbin/ldconfig
47
48 %files
49 %defattr(-,root,root,-)
50 %{_libdir}/libeo.so.*
51
52 %files devel
53 %defattr(-,root,root,-)
54 %{_includedir}/eo-1/Eo.h
55 %{_libdir}/libeo.so
56 %{_libdir}/pkgconfig/eo.pc
57