Tizen 2.1 base
[external/enchant.git] / packaging / enchant.spec
1 %define name enchant
2 %define version 1.6.1
3 %define release 4
4
5 Summary: An Enchanting Spell Checking Library
6
7 Name: %{name}
8 Version: %{version}
9 Release: %{release}
10 Group: System Environment/Libraries
11 License: LGPL
12
13 Source: ftp://ftp.gnome.org/pub/GNOME/unstable/sources/libenchant/%{name}-%{version}.tar.gz
14 Buildroot: /var/tmp/%{name}-%{version}-%{release}-root
15 URL: http://www.abisource.com/
16
17 Requires: glib2 >= 2.0.0
18 BuildRequires: glib2-devel >= 2.0.0
19
20 %description
21 A library that wraps other spellchecking backends.
22
23 %package devel
24 Summary: Support files necessary to compile applications with libenchant.
25 Group: Development/Libraries
26 Requires: enchant
27
28 %description devel
29 Libraries, headers, and support files necessary to compile applications using libenchant.
30
31 %prep
32
33 %setup
34
35 %build
36 %ifarch alpha
37   MYARCH_FLAGS="--host=alpha-redhat-linux"
38 %endif
39
40 if [ ! -f configure ]; then
41 CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%{_prefix}
42 fi
43 CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix} \
44 %{?_without_ispell:--disable-ispell} \
45 %{?_without_myspell:--disable-myspell} \
46 %{?_without_aspell:--disable-aspell} \
47 %{?_with_uspell:--enable-uspell}
48
49 if [ "$SMP" != "" ]; then
50   (%__make "MAKE=%__make -k -j $SMP"; exit 0)
51   %__make
52 else
53 %__make
54 fi
55
56 %install
57 if [ -d $RPM_BUILD_ROOT ]; then rm -r $RPM_BUILD_ROOT; fi
58 mkdir -p %{buildroot}/usr/share/license
59 cp LICENSE %{buildroot}/usr/share/license/%{name}
60 %__make DESTDIR=$RPM_BUILD_ROOT install
61 find $RPM_BUILD_ROOT/%{_libdir} -name \*.la -exec rm -f \{\} \;
62
63 %files -n enchant
64 %manifest enchant.manifest
65 %defattr(644,root,root,755)
66 %doc AUTHORS COPYING.LIB README
67 %attr(755,root,root)%{_bindir}/*
68 %{_libdir}/lib*.so*
69 %{_prefix}/share/man/man1/enchant.1.gz
70 %{_prefix}/share/enchant/enchant.ordering
71 %{!?_without_ispell:%{_libdir}/enchant/*ispell.so*}
72 %{!?_without_myspell:%{_libdir}/enchant/*myspell.so*}
73 # commented by MR
74 #%{!?_without_aspell:%{_libdir}/enchant/*aspell.so*}
75 %{?_with_uspell:%{_libdir}/enchant/*uspell.so*}
76 /usr/share/license/%{name}
77
78 %files devel
79 %defattr(644,root,root,755)
80 %{_libdir}/*.a
81 %{!?_without_ispell:%{_libdir}/enchant/*ispell.a}
82 %{!?_without_myspell:%{_libdir}/enchant/*myspell.a}
83 # commented by MR
84 #%{!?_without_aspell:%{_libdir}/enchant/*aspell.a}
85 %{?_with_uspell:%{_libdir}/enchant/*uspell.a}
86 %{_libdir}/pkgconfig/enchant.pc
87 %{_includedir}/enchant/*
88
89 %clean
90 %__rm -rf $RPM_BUILD_ROOT
91
92 %changelog
93 * Fri Sep 14 2012 Michal Roj <m.roj@samsung.com>
94 - this spec file updated in order to compile successfully with OBS for Tizen
95
96 * Sun Aug 24 2003 Rui Miguel Seabra <rms@1407.org>
97 - update spec to current stat of affairs
98 - building from source rpm is now aware of --with and --without flags:
99 - --without aspell --without ispell --without myspell --with uspell
100
101 * Wed Jul 16 2003 Rui Miguel Seabra <rms@1407.org>
102 - take advantage of environment rpm macros
103
104 * Sun Jul 13 2003 Dom Lachowicz <cinamod@hotmail.com>
105 - Initial version