Add Tizen 2.0 packaging
[profile/ivi/emotion.git] / packaging / emotion.spec
1 Name:             emotion
2 Summary:          Media Library
3 Version:          1.7.1+svn.79419+build01
4 Release:          1
5 Group:            System Environment/Libraries
6 License:          BSD
7 URL:              http://www.enlightenment.org/
8 Source0:          %{name}-%{version}.tar.gz
9 Requires(post):   /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:    eina-devel
12 BuildRequires:    eet-devel
13 BuildRequires:    evas-devel
14 BuildRequires:    ecore-devel
15 BuildRequires:    edje-devel
16 BuildRequires:    edje-bin
17 BuildRequires:    gstreamer-devel
18 BuildRequires:    gst-plugins-base-devel
19
20
21 %description
22 Video playback library used in Enlightenment DR0.17
23  This is the emotion library, a wrapper library used in the next-generation
24  Enlightenment suite for video playback.
25  .
26  This package contains the shared libraries.
27
28
29 %package devel
30 Summary:    Emotion headers, static libraries, documentation and test programs
31 Group:      TO_BE/FILLED_IN
32 Requires:   %{name} = %{version}
33 Requires: eet-devel evas-devel edje-devel
34
35
36 %description devel
37 Headers, static libraries, test programs and documentation for Emotion
38
39
40 %package gstreamer
41 Summary:    Video playback library used in Enlightenment DR0.17
42 Group:      TO_BE/FILLED_IN
43 Requires:   %{name} = %{version}
44 Requires(post): /sbin/ldconfig
45 Requires(postun): /sbin/ldconfig
46
47
48 %description gstreamer
49 Video playback library used in Enlightenment DR0.17
50 This is the emotion library, a wrapper library used in the next-generation
51 Enlightenment suite for video playback.
52 .
53 This package provides the gstreamer module for emotion.
54
55 %prep
56 %setup -q
57
58 %build
59
60 %autogen
61 %configure --enable-static \
62         --disable-rpath --enable-xine=no --disable-doc
63 make %{?jobs:-j%jobs}
64
65
66 %install
67 rm -rf %{buildroot}
68 %make_install
69 mkdir -p %{buildroot}/usr/share/license
70 cp %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/usr/share/license/%{name}
71
72
73 %post -p /sbin/ldconfig
74
75
76 %postun -p /sbin/ldconfig
77
78
79 %post gstreamer -p /sbin/ldconfig
80
81
82 %postun gstreamer -p /sbin/ldconfig
83
84
85 %files
86 %defattr(-,root,root,-)
87 %{_libdir}/libemotion.so.*
88 %{_bindir}/emotion_*
89 %{_datadir}/emotion/data/*.edj
90 %{_libdir}/emotion
91 %{_libdir}/edje/modules/emotion/*/module.so
92 /usr/share/license/%{name}
93
94
95 %files devel
96 %defattr(-, root, root)
97 %{_includedir}/*
98 %{_libdir}/pkgconfig/emotion*.pc
99 %{_libdir}/libemotion.so
100
101
102 %files gstreamer
103 %defattr(-, root, root)
104 %{_libdir}/emotion/*gstreamer*.so