4d90c543db94b60cacbfb77b82411925da117255
[platform/core/csapi/elm-sharp.git] / packaging / elm-sharp.spec
1 Name:       elm-sharp
2 Summary:    C# Binding for Elementary
3 Version:    1.2.1
4 Release:    1
5 Group:      Development/Libraries
6 License:    Apache-2.0
7 URL:        https://www.tizen.org
8 Source0:    %{name}-%{version}.tar.gz
9 Source1:    %{name}.manifest
10
11 AutoReqProv: no
12 ExcludeArch: aarch64
13
14 BuildRequires: dotnet-build-tools
15
16 %define Assemblies ElmSharp
17
18 %description
19 %{summary}
20
21 %dotnet_import_sub_packages
22
23 %prep
24 %setup -q
25 cp %{SOURCE1} .
26
27 %build
28 for ASM in %{Assemblies}; do
29 %dotnet_build $ASM
30 %dotnet_pack $ASM
31 done
32
33 %install
34 for ASM in %{Assemblies}; do
35 %dotnet_install $ASM
36 done
37
38 %files
39 %manifest %{name}.manifest
40 %license LICENSE
41 %attr(644,root,root) %{dotnet_assembly_files}