Added tizen packaging
[platform/upstream/eldbus.git] / packaging / eldbus.spec
1 Name:       eldbus
2 Summary:    Easy access to D-Bus from EFL applications
3 Version:    1.7.8
4 Release:    1
5 Group:      System/Libraries
6 License:    LGPL-2.1
7 Source0:    %{name}-%{version}.tar.bz2
8 Requires(post): /sbin/ldconfig
9 Requires(postun): /sbin/ldconfig
10 BuildRequires:  pkgconfig(ecore)
11 BuildRequires:  pkgconfig(eina)
12 BuildRequires:  dbus-devel
13
14 %description
15 Eldbus allows connecting to both system and session buses acting as
16 both client and service roles.
17
18 This is a replacement for old library "edbus". Its main purpose is to
19 fix some core bugs and completely encapsulating D-Bus without exposing
20 libdbus to end-user. One day libdbus may be completely removed as a
21 dependency.
22
23
24 %package devel
25 Summary:    Easy access to D-Bus from EFL applications
26 Group:      Development/Libraries
27 Requires:   %{name} = %{version}-%{release}
28
29 %description devel
30 Eldbus allows connecting to both system and session buses acting as
31 both client and service roles.
32
33 This is a replacement for old library "edbus". Its main purpose is to
34 fix some core bugs and completely encapsulating D-Bus without exposing
35 libdbus to end-user. One day libdbus may be completely removed as a
36 dependency.
37
38
39 %prep
40 %setup -q
41
42
43 %build
44 export CFLAGS+=" -fvisibility=hidden -fPIC"
45 export LDFLAGS+=" -fvisibility=hidden -Wl,--hash-style=both -Wl,--as-needed"
46
47 %configure --disable-static
48
49 make %{?jobs:-j%jobs}
50
51 %install
52 rm -rf %{buildroot}
53 %make_install
54 mkdir -p %{buildroot}/usr/share/license
55 cp %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/usr/share/license/%{name}
56
57
58 %post -p /sbin/ldconfig
59
60 %postun -p /sbin/ldconfig
61
62 %files
63 %defattr(-,root,root,-)
64 %{_libdir}/*.so.*
65 %{_bindir}/%{name}*
66 /usr/share/license/%{name}
67
68 %files devel
69 %defattr(-,root,root,-)
70 %{_libdir}/*.so
71 %{_libdir}/pkgconfig/*.pc
72 %{_includedir}/%{name}*/