Package upload
[framework/uifw/eina.git] / packaging / eina.spec
1 Name:       eina
2 Summary:    Data Type Library
3 Version:    1.2.0+svn.70333slp2+build01
4 Release:    1
5 Group:      System/Libraries
6 License:    LGPLv2
7 URL:        http://www.enlightenment.org/
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11
12
13 %description
14 Enlightenment Foundation Library providing optimized data types Eina is a multi-platform library that provides optimized data types and a few
15  tools. It supports the following data types:
16   o Array
17   o Hash Table
18   o Double-linked list
19   o Red-black tree
20   o Shared string
21   o Access Content types
22     + Accessor: can access items of a container randomly
23     + Iterator: can access items of a container sequentially
24
25
26 %package devel
27 Summary:    Data Type Library (devel)
28 Group:      Development/Libraries
29 Requires:   %{name} = %{version}-%{release}
30
31
32 %description devel
33 Enlightenment Foundation Library providing optimized data types (devel)
34
35
36 %prep
37 %setup -q
38
39
40 %build
41 export CFLAGS+=" -fvisibility=hidden"
42 export LDFLAGS+=" -fvisibility=hidden"
43
44 %autogen --disable-static
45 %configure --disable-static \
46     --disable-rpath --enable-static-chained-pool --enable-magic-debug
47
48 make %{?jobs:-j%jobs}
49
50
51 %install
52 rm -rf %{buildroot}
53 %make_install
54
55
56 %post -p /sbin/ldconfig
57
58
59 %postun -p /sbin/ldconfig
60
61
62 %files
63 %defattr(-,root,root,-)
64 %{_libdir}/libeina.so.*
65
66
67 %files devel
68 %defattr(-,root,root,-)
69 %{_includedir}/eina-1
70 %{_libdir}/*.so
71 %{_libdir}/pkgconfig/eina.pc