Add Tizen 2.0 packaging
[profile/ivi/eeze.git] / packaging / eeze.spec
1 Name:       eeze
2 Summary:    Eeze is a library for manipulating devices with an extremely simple api
3 Version:    1.7.3+svn.81116+build01
4 Release:    1
5 Group:      System/Libraries
6 License:    BSD
7 URL:        http://www.enlightenment.org
8 Source0:    %{name}-%{version}.tar.bz2
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  pkgconfig(libudev)
12 BuildRequires:  pkgconfig(ecore)
13
14
15 %description
16 Eeze is a library for manipulating devices with an extremely simple api.
17  It interfaces directly with device subsystems, avoiding such middleman daemons as
18  udisks/upower or hal to immediately gather device information the instant it
19  becomes known to the OS.
20  Core abstraction layer for enlightenment DR 0.17 This is the core event abstraction layer and X abstraction layer that makes
21
22 %package devel
23 Summary:    Development files for using eeze
24 Group:      Development/Libraries
25 Requires:   %{name} = %{version}-%{release}
26
27 %description devel
28 Development files for using eeze
29
30 %prep
31 %setup -q
32
33 %build
34 export CFLAGS+=" -fvisibility=hidden -fPIC"
35 export LDFLAGS+=" -fvisibility=hidden -Wl,--hash-style=both -Wl,--as-needed"
36
37 libtoolize --force
38 %autogen
39 %configure --disable-static
40
41 make %{?jobs:-j%jobs}
42
43 %install
44 rm -rf %{buildroot}
45 %make_install
46
47
48 %post -p /sbin/ldconfig
49
50 %postun -p /sbin/ldconfig
51
52 %files 
53 %defattr(-,root,root,-)
54 %{_libdir}/lib*.so.*
55
56 %files devel
57 %defattr(-,root,root,-)
58 %{_includedir}/eeze-1/*.h
59 %{_libdir}/lib*.so
60 %{_libdir}/pkgconfig/*.pc
61