Update tp 1.7.4
[platform/upstream/eeze.git] / packaging / eeze.spec
1 Name:           eeze
2 Version:        1.7.4
3 Release:        1
4 License:        BSD 2-clause
5 Summary:        Device Convenience Library
6 Url:            http://www.enlightenment.org/
7 Group:          System/Libraries
8 Source0:        eeze-%{version}.tar.bz2
9 BuildRequires:  doxygen
10 BuildRequires:  pkgconfig(ecore)
11 BuildRequires:  pkgconfig(eina)
12 BuildRequires:  pkgconfig(libudev)
13 BuildRequires:  pkgconfig(udev)
14
15 %description
16 Eeze is a library for manipulating devices through udev with a simple
17 and fast api. It interfaces directly with libudev, avoiding such
18 middleman daemons as udisks/upower or hal, to immediately gather
19 device information the instant it becomes known to the system.  This
20 can be used to determine such things as:
21   * If a cdrom has a disk inserted
22   * The temperature of a cpu core
23   * The remaining power left in a battery
24   * The current power consumption of various parts
25   * Monitor in realtime the status of peripheral devices
26
27 Each of the above examples can be performed by using only a single
28 eeze function, as one of the primary focuses of the library is to
29 reduce the complexity of managing devices.
30
31 %package devel
32 Summary:        Development components for the eeze package
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}
35
36 %description devel
37 Development files for eeze
38
39 %prep
40 %setup -q
41
42
43 %build
44
45 %configure --disable-static
46 make %{?_smp_mflags}
47
48 %install
49 %make_install
50
51
52
53
54 %post -p /sbin/ldconfig
55
56 %postun -p /sbin/ldconfig
57
58
59
60
61
62 %files
63 %defattr(-,root,root,-)
64 %doc COPYING
65 %{_libdir}/libeeze.so.*
66
67
68 %files devel
69 %defattr(-,root,root,-)
70 %{_includedir}/eeze-1/*.h
71 %{_libdir}/*.so
72 %{_libdir}/pkgconfig/*.pc
73
74
75
76 %changelog