Delete the duplicate BuildRequires
[profile/ivi/ecore.git] / packaging / ecore.spec
1 Name:       ecore
2 Summary:    Enlightened Core X interface library
3 Version:    1.6.0+svn.74576slp2+build05
4 Release:    1
5 Group:      System/Libraries
6 License:    BSD
7 URL:        http://www.enlightenment.org
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  gettext
12 BuildRequires:  eina-devel
13 BuildRequires:  eet-devel
14 BuildRequires:  evas-devel
15 BuildRequires:  glib2-devel
16 BuildRequires:  libxcursor-devel
17 BuildRequires:  libxrender-devel
18 BuildRequires:  libxinerama-devel
19 BuildRequires:  libxrandr-devel
20 BuildRequires:  libxext-devel
21 BuildRequires:  libxi-devel
22 BuildRequires:  libxfixes-devel
23 BuildRequires:  libxcomposite-devel
24 BuildRequires:  libxdamage-devel
25 BuildRequires:  x11proto-xext
26 BuildRequires:  libxtst-devel
27 BuildRequires:  curl-devel
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libXgesture-devel
30
31 %ifarch %{arm}
32 BuildRequires: pkgconfig(gles20)
33 %else
34 BuildRequires: pkgconfig(gl)
35 BuildRequires: pkgconfig(glesv2)
36 BuildRequires: pkgconfig(egl)
37 %endif
38
39
40 %description
41 Core abstraction layer for enlightenment DR 0.17 This is the core event abstraction layer and X abstraction layer that makes
42  doing selections, Xdnd, general X stuff, and event loops, timeouts and idle
43  handlers fast, optimized, and convenient. It's a separate library so anyone
44  can make use of the work put into Ecore to make this job easy for
45  applications.
46
47
48
49 %package devel
50 Summary:    Enlightened Core X interface library (devel)
51 Group:      Development/Libraries
52 Requires:   %{name} = %{version}-%{release}
53
54 %description devel
55 Core abstraction layer for enlightenment (devel)
56
57 %package tools
58 Summary:    Enlightened Core X interface library (bin)
59 Group:      Development/Libraries
60 Requires:   %{name} = %{version}-%{release}
61 Provides:   %{name}-bin
62 Obsoletes:  %{name}-bin
63
64 %description tools
65 Core abstraction layer for enlightenment (tools)
66
67 %package con
68 Summary:    Enlightened Core X interface library (con)
69 Group:      Development/Libraries
70 Requires:   %{name} = %{version}-%{release}
71 Requires(post): /sbin/ldconfig
72 Requires(postun): /sbin/ldconfig
73
74 %description con
75 Core abstraction layer for enlightenment (con)
76
77 %package evas
78 Summary:    Enlightened Core X interface library (evas)
79 Group:      Development/Libraries
80 Requires:   %{name} = %{version}-%{release}
81 Requires(post): /sbin/ldconfig
82 Requires(postun): /sbin/ldconfig
83
84 %description evas
85 Core abstraction layer for enlightenment (evas)
86
87 %package file
88 Summary:    Enlightened Core X interface library (file)
89 Group:      Development/Libraries
90 Requires:   %{name} = %{version}-%{release}
91 Requires(post): /sbin/ldconfig
92 Requires(postun): /sbin/ldconfig
93
94 %description file
95 Core abstraction layer for enlightenment (file)
96
97 %package imf
98 Summary:    Enlightened Core X interface library (imf)
99 Group:      Development/Libraries
100 Requires:   %{name} = %{version}-%{release}
101 Requires(post): /sbin/ldconfig
102 Requires(postun): /sbin/ldconfig
103
104 %description imf
105 Core abstraction layer for enlightenment (imf)
106
107 %package imf-evas
108 Summary:    Enlightened Core X interface library (imf-evas)
109 Group:      Development/Libraries
110 Requires:   %{name} = %{version}-%{release}
111 Requires(post): /sbin/ldconfig
112 Requires(postun): /sbin/ldconfig
113
114 %description imf-evas
115 Core abstraction layer for enlightenment (imf-evas)
116
117 %package input
118 Summary:    Enlightened Core X interface library (input)
119 Group:      Development/Libraries
120 Requires:   %{name} = %{version}-%{release}
121 Requires(post): /sbin/ldconfig
122 Requires(postun): /sbin/ldconfig
123
124 %description input
125 Core abstraction layer for enlightenment (input)
126
127 %package input-evas
128 Summary:    Enlightened Core X interface library (input-evas)
129 Group:      Development/Libraries
130 Requires:   %{name} = %{version}-%{release}
131 Requires(post): /sbin/ldconfig
132 Requires(postun): /sbin/ldconfig
133
134 %description input-evas
135 Core abstraction layer for enlightenment (input-evas)
136
137 %package ipc
138 Summary:    Enlightened Core X interface library (ipc)
139 Group:      Development/Libraries
140 Requires:   %{name} = %{version}-%{release}
141 Requires(post): /sbin/ldconfig
142 Requires(postun): /sbin/ldconfig
143
144 %description ipc
145 Core abstraction layer for enlightenment (ipc)
146
147 %package x
148 Summary:    Enlightened Core X interface library (x)
149 Group:      Development/Libraries
150 Requires:   %{name} = %{version}-%{release}
151 Requires(post): /sbin/ldconfig
152 Requires(postun): /sbin/ldconfig
153
154 %description x
155 Core abstraction layer for enlightenment (x)
156
157 %package fb
158 Summary:    Enlightened Core X interface library (fb)
159 Group:      Development/Libraries
160 Requires:   %{name} = %{version}-%{release}
161 Requires(post): /sbin/ldconfig
162 Requires(postun): /sbin/ldconfig
163
164 %description fb
165 Core abstraction layer for enlightenment (fb)
166
167
168 %prep
169 %setup -q
170
171
172 %build
173 export CFLAGS+=" -fvisibility=hidden -fPIC"
174 export LDFLAGS+=" -fvisibility=hidden -Wl,--hash-style=both -Wl,--as-needed"
175
176 %autogen
177 %configure --disable-static \
178         --enable-ecore-fb \
179         --enable-dependency-tracking \
180         --disable-ecore-directfb \
181         --enable-ecore-evas-fb \
182         --disable-rpath \
183         --disable-openssl \
184         --disable-gnutls \
185         --disable-tslib \
186         --enable-simple-x11 \
187         --enable-ecore-evas-opengl-x11 \
188         --disable-ecore-evas-xrender-x11 \
189         --enable-curl \
190         --enable-glib-integration-always \
191         --enable-ecore-x-gesture \
192         --disable-xim \
193         --disable-ecore-imf-xim \
194         --disable-ecore-imf-scim
195
196 make %{?jobs:-j%jobs}
197
198 %install
199 rm -rf %{buildroot}
200 %make_install
201
202
203 %post -p /sbin/ldconfig
204
205 %postun -p /sbin/ldconfig
206
207 %post con -p /sbin/ldconfig
208
209 %postun con -p /sbin/ldconfig
210
211 %post evas -p /sbin/ldconfig
212
213 %postun evas -p /sbin/ldconfig
214
215
216 %post file -p /sbin/ldconfig
217
218 %postun file -p /sbin/ldconfig
219
220
221 %post imf -p /sbin/ldconfig
222
223 %postun imf -p /sbin/ldconfig
224
225
226 %post imf-evas -p /sbin/ldconfig
227
228 %postun imf-evas -p /sbin/ldconfig
229
230
231 %post input -p /sbin/ldconfig
232
233 %postun input -p /sbin/ldconfig
234
235
236 %post input-evas -p /sbin/ldconfig
237
238 %postun input-evas -p /sbin/ldconfig
239
240
241 %post ipc -p /sbin/ldconfig
242
243 %postun ipc -p /sbin/ldconfig
244
245
246 %post x -p /sbin/ldconfig
247
248 %postun x -p /sbin/ldconfig
249
250
251 %post fb -p /sbin/ldconfig
252
253 %postun fb -p /sbin/ldconfig
254
255 %files 
256 %defattr(-,root,root,-)
257 %{_libdir}/libecore.so.*
258 /usr/share/locale/*
259
260 %files devel
261 %defattr(-,root,root,-)
262 %{_includedir}/ecore-1/*.h
263 %{_libdir}/pkgconfig/ecore*.pc
264 %{_libdir}/libecore.so
265 %{_libdir}/libecore_con.so
266 %{_libdir}/libecore_evas.so
267 %{_libdir}/libecore_file.so
268 %{_libdir}/libecore_imf.so
269 %{_libdir}/libecore_imf_evas.so
270 %{_libdir}/libecore_input.so
271 %{_libdir}/libecore_input_evas.so
272 %{_libdir}/libecore_ipc.so
273 %{_libdir}/libecore_x.so
274 %{_libdir}/libecore_fb.so
275
276 %files tools
277 %defattr(-,root,root,-)
278 #/usr/bin/ecore_test
279
280 %files con
281 %defattr(-,root,root,-)
282 %{_libdir}/libecore_con.so.*
283
284 %files evas
285 %defattr(-,root,root,-)
286 %{_libdir}/libecore_evas.so.*
287
288 %files file
289 %defattr(-,root,root,-)
290 %{_libdir}/libecore_file.so.*
291
292 %files imf
293 %defattr(-,root,root,-)
294 %{_libdir}/libecore_imf.so.*
295
296 %files imf-evas
297 %defattr(-,root,root,-)
298 %{_libdir}/libecore_imf_evas.so.*
299
300 %files input
301 %defattr(-,root,root,-)
302 %{_libdir}/libecore_input.so.*
303
304 %files input-evas
305 %defattr(-,root,root,-)
306 %{_libdir}/libecore_input_evas.so.*
307
308 %files ipc
309 %defattr(-,root,root,-)
310 %{_libdir}/libecore_ipc.so.*
311
312 %files x
313 %defattr(-,root,root,-)
314 %{_libdir}/libecore_x.so.*
315
316 %files fb
317 %defattr(-,root,root,-)
318 %{_libdir}/libecore_fb.so.*
319