Fix TZIVI-257 by changing the spec file to link against the real graphics libraries...
[profile/ivi/ecore.git] / packaging / ecore.spec
1 Name:       ecore
2 Summary:    Enlightened Core X interface library
3 Version:    1.6.0+svn.74576slp2+build05
4 Release:    1
5 Group:      System/Libraries
6 License:    BSD
7 URL:        http://www.enlightenment.org
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  gettext
12 BuildRequires:  eina-devel
13 BuildRequires:  eet-devel
14 BuildRequires:  evas-devel
15 BuildRequires:  glib2-devel
16 BuildRequires:  libxcursor-devel
17 BuildRequires:  libxrender-devel
18 BuildRequires:  libxinerama-devel
19 BuildRequires:  libxrandr-devel
20 BuildRequires:  libxext-devel
21 BuildRequires:  libxi-devel
22 BuildRequires:  libxfixes-devel
23 BuildRequires:  libxcomposite-devel
24 BuildRequires:  libxdamage-devel
25 BuildRequires:  x11proto-xext
26 BuildRequires:  libxtst-devel
27 BuildRequires:  curl-devel
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libXgesture-devel
30 BuildRequires:  pkgconfig(egl)
31 BuildRequires:  pkgconfig(gl)
32 BuildRequires:  pkgconfig(glesv2) 
33
34
35 %description
36 Core abstraction layer for enlightenment DR 0.17 This is the core event abstraction layer and X abstraction layer that makes
37  doing selections, Xdnd, general X stuff, and event loops, timeouts and idle
38  handlers fast, optimized, and convenient. It's a separate library so anyone
39  can make use of the work put into Ecore to make this job easy for
40  applications.
41
42
43
44 %package devel
45 Summary:    Enlightened Core X interface library (devel)
46 Group:      Development/Libraries
47 Requires:   %{name} = %{version}-%{release}
48
49 %description devel
50 Core abstraction layer for enlightenment (devel)
51
52 %package tools
53 Summary:    Enlightened Core X interface library (bin)
54 Group:      Development/Libraries
55 Requires:   %{name} = %{version}-%{release}
56 Provides:   %{name}-bin
57 Obsoletes:  %{name}-bin
58
59 %description tools
60 Core abstraction layer for enlightenment (tools)
61
62 %package con
63 Summary:    Enlightened Core X interface library (con)
64 Group:      Development/Libraries
65 Requires:   %{name} = %{version}-%{release}
66 Requires(post): /sbin/ldconfig
67 Requires(postun): /sbin/ldconfig
68
69 %description con
70 Core abstraction layer for enlightenment (con)
71
72 %package evas
73 Summary:    Enlightened Core X interface library (evas)
74 Group:      Development/Libraries
75 Requires:   %{name} = %{version}-%{release}
76 Requires(post): /sbin/ldconfig
77 Requires(postun): /sbin/ldconfig
78
79 %description evas
80 Core abstraction layer for enlightenment (evas)
81
82 %package file
83 Summary:    Enlightened Core X interface library (file)
84 Group:      Development/Libraries
85 Requires:   %{name} = %{version}-%{release}
86 Requires(post): /sbin/ldconfig
87 Requires(postun): /sbin/ldconfig
88
89 %description file
90 Core abstraction layer for enlightenment (file)
91
92 %package imf
93 Summary:    Enlightened Core X interface library (imf)
94 Group:      Development/Libraries
95 Requires:   %{name} = %{version}-%{release}
96 Requires(post): /sbin/ldconfig
97 Requires(postun): /sbin/ldconfig
98
99 %description imf
100 Core abstraction layer for enlightenment (imf)
101
102 %package imf-evas
103 Summary:    Enlightened Core X interface library (imf-evas)
104 Group:      Development/Libraries
105 Requires:   %{name} = %{version}-%{release}
106 Requires(post): /sbin/ldconfig
107 Requires(postun): /sbin/ldconfig
108
109 %description imf-evas
110 Core abstraction layer for enlightenment (imf-evas)
111
112 %package input
113 Summary:    Enlightened Core X interface library (input)
114 Group:      Development/Libraries
115 Requires:   %{name} = %{version}-%{release}
116 Requires(post): /sbin/ldconfig
117 Requires(postun): /sbin/ldconfig
118
119 %description input
120 Core abstraction layer for enlightenment (input)
121
122 %package input-evas
123 Summary:    Enlightened Core X interface library (input-evas)
124 Group:      Development/Libraries
125 Requires:   %{name} = %{version}-%{release}
126 Requires(post): /sbin/ldconfig
127 Requires(postun): /sbin/ldconfig
128
129 %description input-evas
130 Core abstraction layer for enlightenment (input-evas)
131
132 %package ipc
133 Summary:    Enlightened Core X interface library (ipc)
134 Group:      Development/Libraries
135 Requires:   %{name} = %{version}-%{release}
136 Requires(post): /sbin/ldconfig
137 Requires(postun): /sbin/ldconfig
138
139 %description ipc
140 Core abstraction layer for enlightenment (ipc)
141
142 %package x
143 Summary:    Enlightened Core X interface library (x)
144 Group:      Development/Libraries
145 Requires:   %{name} = %{version}-%{release}
146 Requires(post): /sbin/ldconfig
147 Requires(postun): /sbin/ldconfig
148
149 %description x
150 Core abstraction layer for enlightenment (x)
151
152 %package fb
153 Summary:    Enlightened Core X interface library (fb)
154 Group:      Development/Libraries
155 Requires:   %{name} = %{version}-%{release}
156 Requires(post): /sbin/ldconfig
157 Requires(postun): /sbin/ldconfig
158
159 %description fb
160 Core abstraction layer for enlightenment (fb)
161
162
163 %prep
164 %setup -q
165
166
167 %build
168 export CFLAGS+=" -fvisibility=hidden -fPIC"
169 export LDFLAGS+=" -fvisibility=hidden -Wl,--hash-style=both -Wl,--as-needed"
170
171 %autogen
172 %configure --disable-static \
173         --enable-ecore-fb \
174         --enable-dependency-tracking \
175         --disable-ecore-directfb \
176         --enable-ecore-evas-fb \
177         --disable-rpath \
178         --disable-openssl \
179         --disable-gnutls \
180         --disable-tslib \
181         --enable-simple-x11 \
182         --enable-ecore-evas-opengl-x11 \
183         --disable-ecore-evas-xrender-x11 \
184         --enable-curl \
185         --enable-glib-integration-always \
186         --enable-ecore-x-gesture \
187         --disable-xim \
188         --disable-ecore-imf-xim \
189         --disable-ecore-imf-scim
190
191 make %{?jobs:-j%jobs}
192
193 %install
194 rm -rf %{buildroot}
195 %make_install
196
197
198 %post -p /sbin/ldconfig
199
200 %postun -p /sbin/ldconfig
201
202 %post con -p /sbin/ldconfig
203
204 %postun con -p /sbin/ldconfig
205
206 %post evas -p /sbin/ldconfig
207
208 %postun evas -p /sbin/ldconfig
209
210
211 %post file -p /sbin/ldconfig
212
213 %postun file -p /sbin/ldconfig
214
215
216 %post imf -p /sbin/ldconfig
217
218 %postun imf -p /sbin/ldconfig
219
220
221 %post imf-evas -p /sbin/ldconfig
222
223 %postun imf-evas -p /sbin/ldconfig
224
225
226 %post input -p /sbin/ldconfig
227
228 %postun input -p /sbin/ldconfig
229
230
231 %post input-evas -p /sbin/ldconfig
232
233 %postun input-evas -p /sbin/ldconfig
234
235
236 %post ipc -p /sbin/ldconfig
237
238 %postun ipc -p /sbin/ldconfig
239
240
241 %post x -p /sbin/ldconfig
242
243 %postun x -p /sbin/ldconfig
244
245
246 %post fb -p /sbin/ldconfig
247
248 %postun fb -p /sbin/ldconfig
249
250 %files 
251 %defattr(-,root,root,-)
252 %{_libdir}/libecore.so.*
253 /usr/share/locale/*
254
255 %files devel
256 %defattr(-,root,root,-)
257 %{_includedir}/ecore-1/*.h
258 %{_libdir}/pkgconfig/ecore*.pc
259 %{_libdir}/libecore.so
260 %{_libdir}/libecore_con.so
261 %{_libdir}/libecore_evas.so
262 %{_libdir}/libecore_file.so
263 %{_libdir}/libecore_imf.so
264 %{_libdir}/libecore_imf_evas.so
265 %{_libdir}/libecore_input.so
266 %{_libdir}/libecore_input_evas.so
267 %{_libdir}/libecore_ipc.so
268 %{_libdir}/libecore_x.so
269 %{_libdir}/libecore_fb.so
270
271 %files tools
272 %defattr(-,root,root,-)
273 #/usr/bin/ecore_test
274
275 %files con
276 %defattr(-,root,root,-)
277 %{_libdir}/libecore_con.so.*
278
279 %files evas
280 %defattr(-,root,root,-)
281 %{_libdir}/libecore_evas.so.*
282
283 %files file
284 %defattr(-,root,root,-)
285 %{_libdir}/libecore_file.so.*
286
287 %files imf
288 %defattr(-,root,root,-)
289 %{_libdir}/libecore_imf.so.*
290
291 %files imf-evas
292 %defattr(-,root,root,-)
293 %{_libdir}/libecore_imf_evas.so.*
294
295 %files input
296 %defattr(-,root,root,-)
297 %{_libdir}/libecore_input.so.*
298
299 %files input-evas
300 %defattr(-,root,root,-)
301 %{_libdir}/libecore_input_evas.so.*
302
303 %files ipc
304 %defattr(-,root,root,-)
305 %{_libdir}/libecore_ipc.so.*
306
307 %files x
308 %defattr(-,root,root,-)
309 %{_libdir}/libecore_x.so.*
310
311 %files fb
312 %defattr(-,root,root,-)
313 %{_libdir}/libecore_fb.so.*
314