Package Upload
[profile/ivi/ecore.git] / packaging / ecore.spec
1 Name:       ecore
2 Summary:    Enlightened Core X interface library
3 Version:    1.2.0+svn.70444slp2+build06
4 Release:    2
5 Group:      System/Libraries
6 License:    BSD
7 URL:        http://www.enlightenment.org
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  eina-devel
12 BuildRequires:  eet-devel
13 BuildRequires:  evas-devel
14 BuildRequires:  glib2-devel
15 BuildRequires:  libxcursor-devel
16 BuildRequires:  libxrender-devel
17 BuildRequires:  libxinerama-devel
18 BuildRequires:  libxrandr-devel
19 BuildRequires:  libxext-devel
20 BuildRequires:  libxi-devel
21 BuildRequires:  libxfixes-devel
22 BuildRequires:  libxcomposite-devel
23 BuildRequires:  libxdamage-devel
24 BuildRequires:  x11proto-xext
25 BuildRequires:  libxtst-devel
26 BuildRequires:  curl-devel
27 BuildRequires:  libjpeg-devel
28
29
30 %description
31 Core abstraction layer for enlightenment DR 0.17 This is the core event abstraction layer and X abstraction layer that makes
32  doing selections, Xdnd, general X stuff, and event loops, timeouts and idle
33  handlers fast, optimized, and convenient. It's a separate library so anyone
34  can make use of the work put into Ecore to make this job easy for
35  applications.
36
37
38
39 %package devel
40 Summary:    Enlightened Core X interface library (devel)
41 Group:      Development/Libraries
42 Requires:   %{name} = %{version}-%{release}
43
44 %description devel
45 Core abstraction layer for enlightenment (devel)
46
47 %package tools
48 Summary:    Enlightened Core X interface library (bin)
49 Group:      Development/Libraries
50 Requires:   %{name} = %{version}-%{release}
51 Provides:   %{name}-bin
52 Obsoletes:  %{name}-bin
53
54 %description tools
55 Core abstraction layer for enlightenment (tools)
56
57 %package con
58 Summary:    Enlightened Core X interface library (con)
59 Group:      Development/Libraries
60 Requires:   %{name} = %{version}-%{release}
61 Requires(post): /sbin/ldconfig
62 Requires(postun): /sbin/ldconfig
63
64 %description con
65 Core abstraction layer for enlightenment (con)
66
67 %package evas
68 Summary:    Enlightened Core X interface library (evas)
69 Group:      Development/Libraries
70 Requires:   %{name} = %{version}-%{release}
71 Requires(post): /sbin/ldconfig
72 Requires(postun): /sbin/ldconfig
73
74 %description evas
75 Core abstraction layer for enlightenment (evas)
76
77 %package file
78 Summary:    Enlightened Core X interface library (file)
79 Group:      Development/Libraries
80 Requires:   %{name} = %{version}-%{release}
81 Requires(post): /sbin/ldconfig
82 Requires(postun): /sbin/ldconfig
83
84 %description file
85 Core abstraction layer for enlightenment (file)
86
87 %package imf
88 Summary:    Enlightened Core X interface library (imf)
89 Group:      Development/Libraries
90 Requires:   %{name} = %{version}-%{release}
91 Requires(post): /sbin/ldconfig
92 Requires(postun): /sbin/ldconfig
93
94 %description imf
95 Core abstraction layer for enlightenment (imf)
96
97 %package imf-evas
98 Summary:    Enlightened Core X interface library (imf-evas)
99 Group:      Development/Libraries
100 Requires:   %{name} = %{version}-%{release}
101 Requires(post): /sbin/ldconfig
102 Requires(postun): /sbin/ldconfig
103
104 %description imf-evas
105 Core abstraction layer for enlightenment (imf-evas)
106
107 %package input
108 Summary:    Enlightened Core X interface library (input)
109 Group:      Development/Libraries
110 Requires:   %{name} = %{version}-%{release}
111 Requires(post): /sbin/ldconfig
112 Requires(postun): /sbin/ldconfig
113
114 %description input
115 Core abstraction layer for enlightenment (input)
116
117 %package input-evas
118 Summary:    Enlightened Core X interface library (input-evas)
119 Group:      Development/Libraries
120 Requires:   %{name} = %{version}-%{release}
121 Requires(post): /sbin/ldconfig
122 Requires(postun): /sbin/ldconfig
123
124 %description input-evas
125 Core abstraction layer for enlightenment (input-evas)
126
127 %package ipc
128 Summary:    Enlightened Core X interface library (ipc)
129 Group:      Development/Libraries
130 Requires:   %{name} = %{version}-%{release}
131 Requires(post): /sbin/ldconfig
132 Requires(postun): /sbin/ldconfig
133
134 %description ipc
135 Core abstraction layer for enlightenment (ipc)
136
137 %package x
138 Summary:    Enlightened Core X interface library (x)
139 Group:      Development/Libraries
140 Requires:   %{name} = %{version}-%{release}
141 Requires(post): /sbin/ldconfig
142 Requires(postun): /sbin/ldconfig
143
144 %description x
145 Core abstraction layer for enlightenment (x)
146
147 %package fb
148 Summary:    Enlightened Core X interface library (fb)
149 Group:      Development/Libraries
150 Requires:   %{name} = %{version}-%{release}
151 Requires(post): /sbin/ldconfig
152 Requires(postun): /sbin/ldconfig
153
154 %description fb
155 Core abstraction layer for enlightenment (fb)
156
157
158 %prep
159 %setup -q
160
161
162 %build
163 export CFLAGS+=" -fvisibility=hidden -fPIC"
164 export LDFLAGS+=" -fvisibility=hidden -Wl,--hash-style=both -Wl,--as-needed"
165
166 %autogen
167 %configure --disable-static \
168         --enable-ecore-fb \
169         --enable-dependency-tracking \
170         --disable-ecore-directfb \
171         --enable-ecore-evas-fb \
172         --disable-rpath \
173         --disable-openssl \
174         --disable-gnutls \
175         --disable-tslib \
176         --enable-simple-x11 \
177         --enable-ecore-evas-opengl-x11 \
178         --disable-ecore-evas-xrender-x11 \
179         --enable-curl \
180         --enable-glib-integration-always \
181         --enable-ecore-x-gesture \
182         --disable-xim \
183         --disable-ecore-imf-xim \
184         --disable-ecore-imf-scim
185
186 make %{?jobs:-j%jobs}
187
188 %install
189 rm -rf %{buildroot}
190 %make_install
191
192
193 %post -p /sbin/ldconfig
194
195 %postun -p /sbin/ldconfig
196
197 %post con -p /sbin/ldconfig
198
199 %postun con -p /sbin/ldconfig
200
201 %post evas -p /sbin/ldconfig
202
203 %postun evas -p /sbin/ldconfig
204
205
206 %post file -p /sbin/ldconfig
207
208 %postun file -p /sbin/ldconfig
209
210
211 %post imf -p /sbin/ldconfig
212
213 %postun imf -p /sbin/ldconfig
214
215
216 %post imf-evas -p /sbin/ldconfig
217
218 %postun imf-evas -p /sbin/ldconfig
219
220
221 %post input -p /sbin/ldconfig
222
223 %postun input -p /sbin/ldconfig
224
225
226 %post input-evas -p /sbin/ldconfig
227
228 %postun input-evas -p /sbin/ldconfig
229
230
231 %post ipc -p /sbin/ldconfig
232
233 %postun ipc -p /sbin/ldconfig
234
235
236 %post x -p /sbin/ldconfig
237
238 %postun x -p /sbin/ldconfig
239
240
241 %post fb -p /sbin/ldconfig
242
243 %postun fb -p /sbin/ldconfig
244
245 %files 
246 %defattr(-,root,root,-)
247 %{_libdir}/libecore.so.*
248
249 %files devel
250 %defattr(-,root,root,-)
251 %{_includedir}/ecore-1/*.h
252 %{_libdir}/pkgconfig/ecore*.pc
253 %{_libdir}/libecore.so
254 %{_libdir}/libecore_con.so
255 %{_libdir}/libecore_evas.so
256 %{_libdir}/libecore_file.so
257 %{_libdir}/libecore_imf.so
258 %{_libdir}/libecore_imf_evas.so
259 %{_libdir}/libecore_input.so
260 %{_libdir}/libecore_input_evas.so
261 %{_libdir}/libecore_ipc.so
262 %{_libdir}/libecore_x.so
263 %{_libdir}/libecore_fb.so
264
265 %files tools
266 %defattr(-,root,root,-)
267 #/usr/bin/ecore_test
268
269 %files con
270 %defattr(-,root,root,-)
271 %{_libdir}/libecore_con.so.*
272
273 %files evas
274 %defattr(-,root,root,-)
275 %{_libdir}/libecore_evas.so.*
276
277 %files file
278 %defattr(-,root,root,-)
279 %{_libdir}/libecore_file.so.*
280
281 %files imf
282 %defattr(-,root,root,-)
283 %{_libdir}/libecore_imf.so.*
284
285 %files imf-evas
286 %defattr(-,root,root,-)
287 %{_libdir}/libecore_imf_evas.so.*
288
289 %files input
290 %defattr(-,root,root,-)
291 %{_libdir}/libecore_input.so.*
292
293 %files input-evas
294 %defattr(-,root,root,-)
295 %{_libdir}/libecore_input_evas.so.*
296
297 %files ipc
298 %defattr(-,root,root,-)
299 %{_libdir}/libecore_ipc.so.*
300
301 %files x
302 %defattr(-,root,root,-)
303 %{_libdir}/libecore_x.so.*
304
305 %files fb
306 %defattr(-,root,root,-)
307 %{_libdir}/libecore_fb.so.*
308