3e78e07358aab449cf3ef35ced187977ef0db11d
[profile/ivi/ecore.git] / packaging / ecore.spec
1 Name:       ecore
2 Summary:    Enlightened Core X interface library
3 Version:    1.6.0+svn.74576slp2+build05
4 Release:    1
5 Group:      System/Libraries
6 License:    BSD
7 URL:        http://www.enlightenment.org
8 Source0:    %{name}-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  gettext
12 BuildRequires:  eina-devel
13 BuildRequires:  eet-devel
14 BuildRequires:  evas-devel
15 BuildRequires:  glib2-devel
16 BuildRequires:  libxcursor-devel
17 BuildRequires:  libxrender-devel
18 BuildRequires:  libxinerama-devel
19 BuildRequires:  libxrandr-devel
20 BuildRequires:  libxext-devel
21 BuildRequires:  libxi-devel
22 BuildRequires:  libxfixes-devel
23 BuildRequires:  libxcomposite-devel
24 BuildRequires:  libxdamage-devel
25 BuildRequires:  x11proto-xext
26 BuildRequires:  libxtst-devel
27 BuildRequires:  curl-devel
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  libXgesture-devel
30 BuildRequires:  pkgconfig(egl)
31 BuildRequires:  pkgconfig(gl)
32 BuildRequires:  pkgconfig(glesv2) 
33
34 %ifarch %{arm}
35 BuildRequires: pkgconfig(gles20)
36 %else
37 BuildRequires: pkgconfig(gl)
38 BuildRequires: pkgconfig(glesv2)
39 BuildRequires: pkgconfig(egl)
40 %endif
41
42
43 %description
44 Core abstraction layer for enlightenment DR 0.17 This is the core event abstraction layer and X abstraction layer that makes
45  doing selections, Xdnd, general X stuff, and event loops, timeouts and idle
46  handlers fast, optimized, and convenient. It's a separate library so anyone
47  can make use of the work put into Ecore to make this job easy for
48  applications.
49
50
51
52 %package devel
53 Summary:    Enlightened Core X interface library (devel)
54 Group:      Development/Libraries
55 Requires:   %{name} = %{version}-%{release}
56
57 %description devel
58 Core abstraction layer for enlightenment (devel)
59
60 %package tools
61 Summary:    Enlightened Core X interface library (bin)
62 Group:      Development/Libraries
63 Requires:   %{name} = %{version}-%{release}
64 Provides:   %{name}-bin
65 Obsoletes:  %{name}-bin
66
67 %description tools
68 Core abstraction layer for enlightenment (tools)
69
70 %package con
71 Summary:    Enlightened Core X interface library (con)
72 Group:      Development/Libraries
73 Requires:   %{name} = %{version}-%{release}
74 Requires(post): /sbin/ldconfig
75 Requires(postun): /sbin/ldconfig
76
77 %description con
78 Core abstraction layer for enlightenment (con)
79
80 %package evas
81 Summary:    Enlightened Core X interface library (evas)
82 Group:      Development/Libraries
83 Requires:   %{name} = %{version}-%{release}
84 Requires(post): /sbin/ldconfig
85 Requires(postun): /sbin/ldconfig
86
87 %description evas
88 Core abstraction layer for enlightenment (evas)
89
90 %package file
91 Summary:    Enlightened Core X interface library (file)
92 Group:      Development/Libraries
93 Requires:   %{name} = %{version}-%{release}
94 Requires(post): /sbin/ldconfig
95 Requires(postun): /sbin/ldconfig
96
97 %description file
98 Core abstraction layer for enlightenment (file)
99
100 %package imf
101 Summary:    Enlightened Core X interface library (imf)
102 Group:      Development/Libraries
103 Requires:   %{name} = %{version}-%{release}
104 Requires(post): /sbin/ldconfig
105 Requires(postun): /sbin/ldconfig
106
107 %description imf
108 Core abstraction layer for enlightenment (imf)
109
110 %package imf-evas
111 Summary:    Enlightened Core X interface library (imf-evas)
112 Group:      Development/Libraries
113 Requires:   %{name} = %{version}-%{release}
114 Requires(post): /sbin/ldconfig
115 Requires(postun): /sbin/ldconfig
116
117 %description imf-evas
118 Core abstraction layer for enlightenment (imf-evas)
119
120 %package input
121 Summary:    Enlightened Core X interface library (input)
122 Group:      Development/Libraries
123 Requires:   %{name} = %{version}-%{release}
124 Requires(post): /sbin/ldconfig
125 Requires(postun): /sbin/ldconfig
126
127 %description input
128 Core abstraction layer for enlightenment (input)
129
130 %package input-evas
131 Summary:    Enlightened Core X interface library (input-evas)
132 Group:      Development/Libraries
133 Requires:   %{name} = %{version}-%{release}
134 Requires(post): /sbin/ldconfig
135 Requires(postun): /sbin/ldconfig
136
137 %description input-evas
138 Core abstraction layer for enlightenment (input-evas)
139
140 %package ipc
141 Summary:    Enlightened Core X interface library (ipc)
142 Group:      Development/Libraries
143 Requires:   %{name} = %{version}-%{release}
144 Requires(post): /sbin/ldconfig
145 Requires(postun): /sbin/ldconfig
146
147 %description ipc
148 Core abstraction layer for enlightenment (ipc)
149
150 %package x
151 Summary:    Enlightened Core X interface library (x)
152 Group:      Development/Libraries
153 Requires:   %{name} = %{version}-%{release}
154 Requires(post): /sbin/ldconfig
155 Requires(postun): /sbin/ldconfig
156
157 %description x
158 Core abstraction layer for enlightenment (x)
159
160 %package fb
161 Summary:    Enlightened Core X interface library (fb)
162 Group:      Development/Libraries
163 Requires:   %{name} = %{version}-%{release}
164 Requires(post): /sbin/ldconfig
165 Requires(postun): /sbin/ldconfig
166
167 %description fb
168 Core abstraction layer for enlightenment (fb)
169
170
171 %prep
172 %setup -q
173
174
175 %build
176 export CFLAGS+=" -fvisibility=hidden -fPIC"
177 export LDFLAGS+=" -fvisibility=hidden -Wl,--hash-style=both -Wl,--as-needed"
178
179 %autogen
180 %configure --disable-static \
181         --enable-ecore-fb \
182         --enable-dependency-tracking \
183         --disable-ecore-directfb \
184         --enable-ecore-evas-fb \
185         --disable-rpath \
186         --disable-openssl \
187         --disable-gnutls \
188         --disable-tslib \
189         --enable-simple-x11 \
190         --enable-ecore-evas-opengl-x11 \
191         --disable-ecore-evas-xrender-x11 \
192         --enable-curl \
193         --enable-glib-integration-always \
194         --enable-ecore-x-gesture \
195         --disable-xim \
196         --disable-ecore-imf-xim \
197         --disable-ecore-imf-scim
198
199 make %{?jobs:-j%jobs}
200
201 %install
202 rm -rf %{buildroot}
203 %make_install
204
205
206 %post -p /sbin/ldconfig
207
208 %postun -p /sbin/ldconfig
209
210 %post con -p /sbin/ldconfig
211
212 %postun con -p /sbin/ldconfig
213
214 %post evas -p /sbin/ldconfig
215
216 %postun evas -p /sbin/ldconfig
217
218
219 %post file -p /sbin/ldconfig
220
221 %postun file -p /sbin/ldconfig
222
223
224 %post imf -p /sbin/ldconfig
225
226 %postun imf -p /sbin/ldconfig
227
228
229 %post imf-evas -p /sbin/ldconfig
230
231 %postun imf-evas -p /sbin/ldconfig
232
233
234 %post input -p /sbin/ldconfig
235
236 %postun input -p /sbin/ldconfig
237
238
239 %post input-evas -p /sbin/ldconfig
240
241 %postun input-evas -p /sbin/ldconfig
242
243
244 %post ipc -p /sbin/ldconfig
245
246 %postun ipc -p /sbin/ldconfig
247
248
249 %post x -p /sbin/ldconfig
250
251 %postun x -p /sbin/ldconfig
252
253
254 %post fb -p /sbin/ldconfig
255
256 %postun fb -p /sbin/ldconfig
257
258 %files 
259 %defattr(-,root,root,-)
260 %{_libdir}/libecore.so.*
261 /usr/share/locale/*
262
263 %files devel
264 %defattr(-,root,root,-)
265 %{_includedir}/ecore-1/*.h
266 %{_libdir}/pkgconfig/ecore*.pc
267 %{_libdir}/libecore.so
268 %{_libdir}/libecore_con.so
269 %{_libdir}/libecore_evas.so
270 %{_libdir}/libecore_file.so
271 %{_libdir}/libecore_imf.so
272 %{_libdir}/libecore_imf_evas.so
273 %{_libdir}/libecore_input.so
274 %{_libdir}/libecore_input_evas.so
275 %{_libdir}/libecore_ipc.so
276 %{_libdir}/libecore_x.so
277 %{_libdir}/libecore_fb.so
278
279 %files tools
280 %defattr(-,root,root,-)
281 #/usr/bin/ecore_test
282
283 %files con
284 %defattr(-,root,root,-)
285 %{_libdir}/libecore_con.so.*
286
287 %files evas
288 %defattr(-,root,root,-)
289 %{_libdir}/libecore_evas.so.*
290
291 %files file
292 %defattr(-,root,root,-)
293 %{_libdir}/libecore_file.so.*
294
295 %files imf
296 %defattr(-,root,root,-)
297 %{_libdir}/libecore_imf.so.*
298
299 %files imf-evas
300 %defattr(-,root,root,-)
301 %{_libdir}/libecore_imf_evas.so.*
302
303 %files input
304 %defattr(-,root,root,-)
305 %{_libdir}/libecore_input.so.*
306
307 %files input-evas
308 %defattr(-,root,root,-)
309 %{_libdir}/libecore_input_evas.so.*
310
311 %files ipc
312 %defattr(-,root,root,-)
313 %{_libdir}/libecore_ipc.so.*
314
315 %files x
316 %defattr(-,root,root,-)
317 %{_libdir}/libecore_x.so.*
318
319 %files fb
320 %defattr(-,root,root,-)
321 %{_libdir}/libecore_fb.so.*
322