Update to 1.7.5
[platform/upstream/ecore.git] / packaging / ecore.spec
1 %bcond_with wayland
2
3 Name:           ecore
4 Version:        1.7.5
5 Release:        1
6 License:        BSD 2-clause
7 Summary:        Enlightened Core X interface library
8 Url:            http://www.enlightenment.org
9 Group:          Graphics/X11
10 Source0:        ecore-%{version}.tar.bz2
11 # Patches auto-generated by git-buildpackage:
12 BuildRequires:  curl-devel
13 BuildRequires:  doxygen
14 BuildRequires:  gettext
15 BuildRequires:  libgcrypt-devel
16 %if %{with wayland}
17 BuildRequires:  libwayland-egl
18 BuildRequires:  pkgconfig(wayland-client)
19 BuildRequires:  pkgconfig(wayland-cursor)
20 BuildRequires:  pkgconfig(xkbcommon)
21 %endif
22 BuildRequires:  pkgconfig(eet)
23 BuildRequires:  pkgconfig(egl)
24 BuildRequires:  pkgconfig(eina)
25 BuildRequires:  pkgconfig(evas)
26 BuildRequires:  pkgconfig(gl)
27 BuildRequires:  pkgconfig(glesv2)
28 BuildRequires:  pkgconfig(glib-2.0)
29 BuildRequires:  pkgconfig(ice)
30 BuildRequires:  pkgconfig(pixman-1)
31 BuildRequires:  pkgconfig(x11)
32 BuildRequires:  pkgconfig(xcomposite)
33 BuildRequires:  pkgconfig(xcursor)
34 BuildRequires:  pkgconfig(xdamage)
35 BuildRequires:  pkgconfig(xext)
36 BuildRequires:  pkgconfig(xi)
37 BuildRequires:  pkgconfig(xinerama)
38 BuildRequires:  pkgconfig(xrandr)
39 BuildRequires:  pkgconfig(xscrnsaver)
40 BuildRequires:  pkgconfig(xt)
41
42 %description
43 Ecore is the event/X abstraction layer that makes doing selections,
44 Xdnd, general X stuff, event loops, timeouts and idle handlers fast,
45 optimized, and convenient.
46
47 %package devel
48 Summary:        Development components for the ecore package
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}
51
52 %description devel
53 Development files for ecore
54
55 %prep
56 %setup -q
57
58 %build
59 %configure \
60 %if %{with wayland}
61     --enable-ecore-wayland \
62     --enable-ecore-evas-wayland-egl \
63 %endif
64     --disable-static
65 make %{?_smp_mflags}
66
67 %install
68 %make_install
69 %find_lang ecore
70
71 %post -p /sbin/ldconfig
72
73 %postun -p /sbin/ldconfig
74
75
76 %files -f ecore.lang
77 %defattr(-,root,root,-)
78 %doc COPYING
79 %{_libdir}/libecore*.so.*
80 %{_libdir}/ecore/immodules/xim.so
81
82 %files devel
83 %defattr(-,root,root,-)
84 %{_includedir}/ecore-1/*.h
85 %{_libdir}/libecore*.so
86 %{_libdir}/pkgconfig/ecore.pc
87 %{_libdir}/pkgconfig/ecore-*.pc
88
89 %changelog