Update to 1.42.6
[platform/upstream/e2fsprogs.git] / packaging / e2fsprogs.spec
1 Name:           e2fsprogs
2 BuildRequires:  autoconf
3 BuildRequires:  libblkid-devel
4 BuildRequires:  libuuid-devel
5 BuildRequires:  pkg-config
6 Version:        1.42.6
7 Release:        0
8 Summary:        Utilities for the Second Extended File System
9 License:        GPL-2.0
10 Group:          System/Filesystems
11 Url:            http://e2fsprogs.sourceforge.net
12 Requires:       libcom_err >= %{version}
13 Requires:       libext2fs >= %{version}
14 Source:         http://downloads.sourceforge.net/project/e2fsprogs/e2fsprogs/v%{version}/e2fsprogs-%{version}.tar.xz
15 Source1:        baselibs.conf
16 Source2:        e2fsck.conf
17
18 %description
19 Utilities needed to create and maintain ext2 and ext3 file systems
20 under Linux. Included in this package are: chattr, lsattr, mke2fs,
21 mklost+found, tune2fs, e2fsck, resize2fs, and badblocks.
22
23 %package devel
24 Summary:        Dummy development package
25 License:        LGPL-2.0
26 Group:          Development/Libraries/C and C++
27 Requires:       libblkid-devel
28 Requires:       libext2fs-devel = %version
29 Requires:       libuuid-devel
30
31 %description devel
32 Dummy development package for backwards compatibility.
33
34 %package -n libext2fs
35 Summary:        Ext2fs library
36 License:        LGPL-2.0
37 Group:          System/Filesystems
38
39 %description -n libext2fs
40 The basic Ext2fs shared library.
41
42 %package -n libext2fs-devel
43 Summary:        Development files for libext2fs
44 License:        LGPL-2.0
45 Group:          Development/Libraries/C and C++
46 Requires:       libcom_err-devel
47 Requires:       libext2fs = %version
48
49 %description -n libext2fs-devel
50 Development files for libext2fs.
51
52 %package -n libcom_err
53 Summary:        E2fsprogs error reporting library
54 License:        MIT
55 Group:          System/Filesystems
56
57 %description -n libcom_err
58 com_err is an error message display library.
59
60 %package -n libcom_err-devel
61 Summary:        Development files for libcom_err
62 License:        MIT
63 Group:          Development/Libraries/C and C++
64 Requires:       glibc-devel
65 Requires:       libcom_err = %version
66
67 %description -n libcom_err-devel
68 Development files for the com_err error message display library.
69
70 %prep
71 %setup -q
72
73 %build
74 %configure \
75   --disable-evms \
76   --with-root-prefix=''   \
77   --enable-elf-shlibs \
78   --disable-libblkid \
79   --disable-libuuid \
80   --disable-uuidd \
81   --disable-nls \
82   --disable-fsck \
83   CFLAGS="$RPM_OPT_FLAGS"
84 make %{?_smp_mflags} V=1
85
86 %install
87 make install install-libs DESTDIR=$RPM_BUILD_ROOT ELF_INSTALL_DIR=/%{_libdir}
88
89 # Let boot continue even if system clock is wrong
90 install -p -m 644 %{SOURCE2} %{buildroot}/etc/e2fsck.conf
91
92
93 rm $RPM_BUILD_ROOT%{_libdir}/e2initrd_helper
94 rm -f $RPM_BUILD_ROOT/%{_sbindir}/mkfs.ext4dev
95 rm -f $RPM_BUILD_ROOT/%{_sbindir}/fsck.ext4dev
96 rm -f $RPM_BUILD_ROOT/usr/share/man/man8/mkfs.ext4dev.8*
97 rm -f $RPM_BUILD_ROOT/usr/share/man/man8/fsck.ext4dev.8*
98 rm -v %{buildroot}%{_includedir}/quota/mkquota.h
99 rm -v %{buildroot}%{_libdir}/pkgconfig/quota.pc
100
101 %post -p /sbin/ldconfig
102
103 %postun -p /sbin/ldconfig
104
105 %post -n libext2fs -p /sbin/ldconfig
106
107 %postun -n libext2fs -p /sbin/ldconfig
108
109 %post -n libcom_err -p /sbin/ldconfig
110
111 %postun -n libcom_err -p /sbin/ldconfig
112
113 %docs_package
114
115 %files devel
116 %doc README
117
118 %files 
119 %defattr(-, root, root)
120 %doc RELEASE-NOTES README
121 %config /etc/e2fsck.conf
122 %config /etc/mke2fs.conf
123 %{_sbindir}/badblocks
124 %{_sbindir}/debugfs
125 %{_sbindir}/dumpe2fs
126 %{_sbindir}/e2undo
127 %{_sbindir}/e2fsck
128 %{_sbindir}/e2label
129 %{_sbindir}/fsck.ext2
130 %{_sbindir}/fsck.ext3
131 %{_sbindir}/fsck.ext4
132 %{_sbindir}/mke2fs
133 %{_sbindir}/mkfs.ext2
134 %{_sbindir}/mkfs.ext3
135 %{_sbindir}/mkfs.ext4
136 %{_sbindir}/resize2fs
137 %{_sbindir}/tune2fs
138 %{_sbindir}/e2image
139 %{_sbindir}/logsave 
140 %{_bindir}/chattr
141 %{_bindir}/lsattr
142 %{_sbindir}/mklost+found
143 %{_sbindir}/filefrag
144 %{_sbindir}/e2freefrag
145 %{_sbindir}/e4defrag
146
147 %files -n libext2fs
148 %defattr(-, root, root)
149 %{_libdir}/libext2fs.so.*
150 %{_libdir}/libe2p.so.*
151
152 %files -n libext2fs-devel
153 %defattr(-, root, root)
154 %{_libdir}/libext2fs.so
155 %{_libdir}/libe2p.so
156 /usr/include/ext2fs
157 /usr/include/e2p
158 %_libdir/pkgconfig/e2p.pc
159 %_libdir/pkgconfig/ext2fs.pc
160
161 %files -n libcom_err
162 %defattr(-, root, root)
163 %{_libdir}/libcom_err.so.*
164 %{_libdir}/libss.so.*
165
166 %files -n libcom_err-devel
167 %defattr(-, root, root)
168 %_bindir/compile_et
169 %_bindir/mk_cmds
170 %{_libdir}/libcom_err.so
171 %{_libdir}/libss.so
172 %_libdir/pkgconfig/com_err.pc
173 %_libdir/pkgconfig/ss.pc
174 %_includedir/com_err.h
175 %_includedir/et
176 %_includedir/ss
177 %_datadir/et
178 %_datadir/ss
179
180 %changelog