tizen 2.4 release
[framework/uifw/e17-mod-tizen-devicemgr.git] / packaging / e17-mod-tizen-devicemgr.spec
1 Name:       e17-mod-tizen-devicemgr
2 Summary:    The E17 Devicemgr Extra Modules for Tizen
3 Version:    0.1.6
4 Release:    1
5 Group:      System/GUI/Other
6 License:    BSD 2-clause and Flora-1.1
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(enlightenment)
9 BuildRequires:  pkgconfig(utilX)
10 BuildRequires:  pkgconfig(dlog)
11 BuildRequires:  pkgconfig(x11)
12 BuildRequires:  pkgconfig(xrandr)
13 BuildRequires:  pkgconfig(xi)
14 BuildRequires:  pkgconfig(vconf)
15 BuildRequires:  pkgconfig(ttrace)
16 BuildRequires:  pkgconfig(sensor)
17
18 Requires: libX11
19 Requires: vconf
20 Requires: libsensord
21
22 %description
23 The E17 Extra Modules  The E17 extra modules consists of modules.
24
25 %prep
26 %setup -q
27
28
29 %build
30
31 export GC_SECTIONS_FLAGS="-fdata-sections -ffunction-sections -Wl,--gc-sections"
32 export CFLAGS+=" -Wall -g -fPIC -rdynamic -Werror-implicit-function-declaration ${GC_SECTIONS_FLAGS} "
33 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
34 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
35
36 #for devicemgr
37 export CFLAGS+=" -D_F_SUPPORT_XTEST_TOUCH_EVENT_"
38
39 %ifarch %{arm}
40 export CFLAGS+=" -D_ENV_ARM"
41 %endif
42
43 %autogen
44 %configure --prefix=/usr
45 make %{?jobs:-j%jobs}
46
47 %install
48 rm -rf %{buildroot}
49
50 # for smack rule
51 mkdir -p %{buildroot}/etc/smack/accesses.d
52 cp %{_builddir}/%{buildsubdir}/e17-mod-tizen-devicemgr.efl %{buildroot}/etc/smack/accesses.d
53
54 # for license notification
55 mkdir -p %{buildroot}/usr/share/license
56 cp -a %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/usr/share/license/%{name}
57 cat %{_builddir}/%{buildsubdir}/COPYING.Flora >> %{buildroot}/usr/share/license/%{name}
58
59 make install DESTDIR=%{buildroot}
60
61 find  %{buildroot}/usr/lib/enlightenment/modules -name *.la | xargs rm
62
63 %files
64 %manifest e17-mod-tizen-devicemgr.manifest
65 %defattr(-,root,root,-)
66
67 %{_libdir}/enlightenment/modules/e17-mod-tizen-devicemgr
68 /usr/share/license/%{name}
69 /etc/smack/accesses.d/e17-mod-tizen-devicemgr.efl