tizen 2.4 release
[framework/uifw/e17-mod-tizen-comp.git] / packaging / e17-mod-tizen-comp.spec
1 Name:       e17-mod-tizen-comp
2 Summary:    The E17 Extra Compositor Module made by Tizen
3 Version:    0.1.12
4 Release:    1
5 Group:      System/GUI/Other
6 License:    BSD 2-clause
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  pkgconfig(enlightenment)
9 BuildRequires:  pkgconfig(utilX)
10 BuildRequires:  pkgconfig(elementary)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(x11)
13 BuildRequires:  pkgconfig(xrandr)
14 BuildRequires:  pkgconfig(pixman-1)
15 BuildRequires:  pkgconfig(vconf)
16 BuildRequires:  pkgconfig(ttrace)
17 BuildRequires:  pkgconfig(libhwc)
18 Requires: libX11
19 Requires: vconf
20
21 %description
22 The E17 Compositor Module made by Tizen
23
24 %prep
25 %setup -q
26
27
28 %build
29 export GC_SECTIONS_FLAGS="-fdata-sections -ffunction-sections -Wl,--gc-sections"
30 export CFLAGS+=" -Wall -g -fPIC -rdynamic -Werror-implicit-function-declaration ${GC_SECTIONS_FLAGS} "
31 export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
32
33 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
34
35 %if "%{?tizen_profile_name}" == "mobile"
36 export CFLAGS+=" -D_ENV_MOBILE_"
37 %else
38 %if "%{?tizen_profile_name}" == "wearable"
39 export CFLAGS+=" -D_ENV_WEARABLE_"
40 %endif
41 %endif
42
43 %ifarch %{arm}
44 export CFLAGS+=" -D_ENV_ARM"
45 %endif
46
47 export CFLAGS+=" -D_F_USE_GRAB_KEY_SET_"
48 %autogen
49 %configure --enable-hwc \
50            --prefix=/usr
51 make %{?jobs:-j%jobs}
52
53
54 %install
55 rm -rf %{buildroot}
56
57 # for license notification
58 mkdir -p %{buildroot}/usr/share/license
59 cp -a %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/usr/share/license/%{name}
60
61 make install DESTDIR=%{buildroot}
62
63 find  %{buildroot}/usr/lib/enlightenment/modules/ -name *.la | xargs rm
64 find  %{buildroot}/usr/lib/enlightenment/modules/ -name *.a | xargs rm
65
66 %files
67 %manifest e17-mod-tizen-comp.manifest
68 %defattr(-,root,root,-)
69
70 %{_libdir}/enlightenment/modules/e17-mod-tizen-comp
71 %{_datadir}/enlightenment/data/*
72 /usr/share/license/%{name}
73
74 %if "%{?tizen_profile_name}" == "mobile"
75 %exclude %{_libdir}/enlightenment/modules/e17-mod-tizen-comp/effect/micro.so
76 %else
77 %if "%{?tizen_profile_name}" == "wearable"
78 %exclude %{_libdir}/enlightenment/modules/e17-mod-tizen-comp/effect/common.so
79 %endif
80 %endif
81 %exclude %{_libdir}/enlightenment/modules/e17-mod-tizen-comp/effect/mobile.so